• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1718
  • Last Modified:

how to cancel auto escape of single quotes

hi everybody

I am creating html page using the messages given by user in form. As we know the php program automatically replaces single quotes (') in user message with /' and when i display it in browser,it only prints '

Yes of course it is nice feature but when I tried to write this user message in my html it writes /' instead of '.

How to solve this problem. Please help me.

cheers
epdass
0
epdass
Asked:
epdass
1 Solution
 
Richard QuadlingSenior Software DeveloperCommented:
echo stripslashes($textvariable);

might be what you are looking for.

From the PHP Manual.

stripslashes
(PHP 3, PHP 4 )

stripslashes --  Un-quote string quoted with addslashes()
Description

string stripslashes (string str)


Returns a string with backslashes stripped off. (\' becomes ' and so on.) Double backslashes are made into a single backslash.

See also addslashes().



Regards,

Richard Quadling.
0
 
izwizCommented:
Or look in your php.ini for the magic quotes directives.

0
 
curriCommented:
Also, whether php quotes automatically is a configuration option (magic_quotes_gpc), so you may also set it to 0 in your ini file, or with ini_set

Orlando
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now