Solved

dhcpd(abandoned/multiple leases)

Posted on 2001-08-06
11
732 Views
Last Modified: 2007-12-19
Our dhcp server(RH6.2) was working correctly until recently. I'm not sure what has changed, but no Windows2K boxes can correctly obtain an IP from it. What's happening is that clients are continuously reobtaining leases(with different lease times). According to the logs the address is assigned successfully. On the client side however, the client does not get an IP. In the leases file, multiple leases appear for the same client, with the same IP, but different lease times. The issue only seems to appear on Win2k clients....I'm guessing it may have something to do with GMT times on the leases, and the clients interpreting them as local times? OR???
Thanks
0
Comment
Question by:tibori
11 Comments
 
LVL 2

Expert Comment

by:ifincham
Comment Utility
Hi,

Win2k clients have "register this connection's address in DNS" turned on by default. If DDNS is not operating on DNS server an attempt is made to use DDNS features within DHCP. There could be some config problem here so you could try doing ipconfig /release on winbox, unchecking the DDNS in TCP properties and trying again. Also, supposedly, there is a bug in the Win2k code dhcp code that can cause problems with dhcp - see http://marc.theaimsgroup.com/?l=dhcp-server&m=97569091132541&w=2 .

Rgds.
0
 
LVL 3

Author Comment

by:tibori
Comment Utility
I've taken off that setting, but still the same problem. Here's a copy of the config file and the leases file. Please look through them and see if you can see a mistake.


default-lease-time 86400;
max-lease-time 172800;
option domain-name "ourdomain.com";
option domain-name-servers 192.168.1.32, 192.168.1.90;
option routers 192.168.1.252;
option subnet-mask 255.255.255.0;
option broadcast-address 192.168.1.255;

subnet 192.168.1.0 netmask 255.255.255.0
{
        range 192.168.1.163 192.168.1.170;
}


#From /var/state/dhcp/dhcp.leases
lease 192.168.1.165 {
        starts 2 2001/08/07 15:32:07;
        ends 3 2001/08/08 15:32:07;
        hardware ethernet 00:04:76:47:3c:33;
        uid 01:00:04:76:47:3c:33;
        client-hostname "client1";
}
lease 192.168.1.165 {
        starts 2 2001/08/07 15:32:08;
        ends 3 2001/08/08 15:32:08;
        hardware ethernet 00:04:76:47:3c:33;
        uid 01:00:04:76:47:3c:33;
        client-hostname "client1";
}
0
 
LVL 40

Expert Comment

by:jlevie
Comment Utility
From what I see above, dhcpd believes that it has assigned an IP to the client. Meaning that it and the client agreed and the IP assignment packet was sent to the client. Since your w2k boxes don't get an IP, I'd suspect that there's something in the IP assignment data that they don't like. Oh yeah, your DHCP config looks fine to me.

Since 6.2 uses version 2.0.5 (the same as 2.0pl5 from isc.com), I'd suggest that you get and try the current 3.0 release. You can get the sources from http://www.isc.org
0
 
LVL 16

Accepted Solution

by:
The--Captain earned 100 total points
Comment Utility
Do you have a Win2K domain controller on your network?  I've seen several networks where a new win2k server running the retarded Universal Directory Service (or some such crap) was trying to compete with the existing unix dhcp server...  Might be something to check out.

I agree with jlevie (cheers!) about your linux config - no prob there...

-Jon

0
 
LVL 3

Author Comment

by:tibori
Comment Utility
This problem seems to have disappeared....I don't know what happened, but I'm guessing it's possibly a host with a bad NIC that was taken off...I'll leave this question open for a little while more in case the problem resurfaces.
thanks,
tibori
0
Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

 
LVL 3

Author Comment

by:tibori
Comment Utility
It was a rogue BOOTP server that was flooding the DHCP server with broadcasts. Once we found it and turned it off, the problem disappeared.
sorry for the late reply on this
0
 
LVL 49

Expert Comment

by:DanRollins
Comment Utility
Hi tibori,
You've requested to delete this question, but its status has remained as 'Pending Delete' because one or more comments have been added.  Normally, the only way to fully delete such a Question is to post a message to Community Support and ask for assistance.

EE is making a one-time database sweep to purge the Pending Delete Questions automatically.  During this sweep:

    tibori -- To allow the deletion to proceed:  Do nothing.
    EXPERTS -- Please DON'T POST a comment except to contest this deletion.

In the future, please refer to http://www.experts-exchange.com/jsp/cmtyHelpDesk.jsp#8 for instruction on deleting questions.

DanRollins -- EE database cleanup volunteer
0
 
LVL 16

Expert Comment

by:The--Captain
Comment Utility
I nominate myself for points here, since I suggested the closest solution (indeed, my suggestion may have lead to the eventual resolution), which was an additional DHCP server interfering with the primary.  I object strongly to simple deletion.

Cheers,
-Jon

0
 
LVL 1

Expert Comment

by:Moondancer
Comment Utility
Thanks, Jon.

tibori ->  You logged in here recently, please update us here and finalize this versus attempting to delete it.

I thank you all,
Moondancer - EE Moderator
0
 
LVL 16

Expert Comment

by:The--Captain
Comment Utility
At least put it in the PAQ - folks should know that one of the main causes of dhcp funniness is a competing dhcp server.

Cheers,
-Jon


0
 

Expert Comment

by:CleanupPing
Comment Utility
tibori:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now