Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 245
  • Last Modified:

Trouble with Win ME Add/Rem/Setup tab access

When I access WinME's Add/Remove Programs > Setup tab, a Windows Setup dialog appears with 'Please wait
while Setup searches for installed components...'

At this point I usually get a list of install options, accessories etc.

But now a white dialog appears with:

'Rundll32 - An error has occurred in your program. To keep working anyway...etc' - with the option of
CLOSE or IGNORE.

When I use CLOSE, another dialog appears with:

Rundll32 has caused an error in SETUPX.DLL. Rundll32 will now close. Complete error message below.

Anyone come across this or have a handle on it? What is this dll? My current setupx.dll is 722k, a newly
extracted version is 520k.

---------
RUNDLL32 caused a general protection fault
in module SETUPX.DLL at 0002:000074ab.
Registers:
EAX=00000000 CS=4ef7 EIP=000074ab EFLGS=00000206
EBX=00040000 SS=4a27 ESP=00008480 EBP=00008486
ECX=00000fc0 DS=50e7 ESI=000213bc FS=0687
EDX=00005127 ES=50e7 EDI=ffff06f8 GS=0687
Bytes at CS:EIP:
8e 46 fe 26 f6 07 20 75 0e 26 8b 07 8b c8 d1 e9
Stack dump:
0fc004d4 84a05127 13bc857d 50e750e7 0000a33c 00000000 50e713bc 0ace0002 8dd284be 00004ef7 000045d7 06f8004e
a33c4a27 13a40000 623950e7 84e23a8f
----------

System: WinME, Abit BE6II, Matrox G200 graphics card.
Also running 98Lite Pro for ME.

Many thanks

Nzo
0
Nzo
Asked:
Nzo
  • 3
  • 2
  • 2
  • +3
1 Solution
 
NzoAuthor Commented:
Note: I've run 4 different virus apps on my system and all seems ok. Someone mentioned this may be the cause of the problem.

Thanks
0
 
hewittgCommented:
0
 
NzoAuthor Commented:
I saw that but it applies to Add/Rem/*Hardware*, not Add/Rem/Progs.

Thanks for looking though Glenn

0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
NzoAuthor Commented:
Problem solved. In case anyone is interested, someone on one of the MS Usenet BBs sent me a zip file with the following registry info which fixed it -

-------------

REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\VarLDID]
"28700"="C:\\PROGRA~1"
"28701"="C:\\Program Files"
"28702"="C:\\PROGRA~1"
"28710"="C:\\PROGRA~1\\ACCESS~1"
"28720"="C:\\PROGRA~1\\ACCESS~1\\HYPERT~1"
"28730"="C:\\PROGRA~1\\COMMON~1"
"28732"="C:\\PROGRA~1\\COMMON~1"
"28740"="C:\\PROGRA~1\\COMMON~1\\MICROS~1"
"28742"="C:\\PROGRA~1\\COMMON~1\\MICROS~1"
"29000"="C:\\PROGRA~1\\INTERN~1"
"29001"="C:\\Program Files\\Internet Explorer"
"29002"="C:\\PROGRA~1\\INTERN~1"
"29400"="C:\\PROGRA~1\\INTERN~1\\CONNEC~1"
"29401"="C:\\Program Files\\Internet Explorer\\Connection Wizard"
"29402"="C:\\PROGRA~1\\INTERN~1\\CONNEC~1"
"29800"="C:\\PROGRA~1\\NETMEE~1"
"29801"="C:\\Program Files\\NetMeeting"
"29802"="C:\\PROGRA~1\\NETMEE~1"
"30000"="C:\\PROGRA~1\\OUTLOO~1"
"30001"="C:\\Program Files\\Outlook Express"
"30002"="C:\\PROGRA~1\\OUTLOO~1"
"30100"="C:\\WINDOWS\\system"
"30400"="C:\\PROGRA~1\\Plus!\\Themes"
"30600"="C:\\PROGRA~1\\MESSEN~1"
"30601"="C:\\Program Files\\Messenger"
"30602"="C:\\PROGRA~1\\MESSEN~1"
"30800"="C:\\PROGRA~1\\WINDOW~1"
"30801"="C:\\Program Files\\Windows Media Player"
"30802"="C:\\PROGRA~1\\WINDOW~1"
"30810"="C:\\PROGRA~1\\MOVIEM~1"
"30811"="C:\\Program Files\\Movie Maker"
"30812"="C:\\PROGRA~1\\MOVIEM~1"
"30900"="C:\\WINDOWS\\APPLIC~1"
"30901"="C:\\WINDOWS\\Application Data"
"30902"="C:\\WINDOWS\\APPLIC~1"
"30910"="C:\\WINDOWS\\APPLIC~1\\MICROS~1"
"30911"="C:\\WINDOWS\\Application Data\\Microsoft"
"30912"="C:\\WINDOWS\\APPLIC~1\\MICROS~1"

-----------

Thanks to all

Nzo
0
 
hewittgCommented:
Glad you got what you needed.  See, some still respond even though no points, LOL.

Seriously.
Glad you are fixed.

Glenn
0
 
OttaCommented:
Zero points?  Kewl!  :-)
0
 
DmitriyCommented:
Had exact same problem.  Had to reformat and reinstall the whole enchilata.
0
 
Computer101Commented:
Otta,
The proposed answer has nothing to do with the question.  

Proposed answer rejected.
Thank you
Computer101
Community Support Moderator
0
 
OttaCommented:
An Experts Exchange "moderator" is closing my account
for alleged infractions, so this is my last post.

> Click the button below to discontinue.

I will be doing that, in a few moments,
so I won't be reading any replies to this message.

Goodbye.   ... Otta
0
 
Computer101Commented:
Hello all,
I am Computer101, a moderator from Experts-Exchange and also an expert within this topic area. This question has been open a long time.  What I am going to do is allow feedback from the questioner and experts.  If it is not resolved, I will delete or accept an answer based on the info I have been given, Experts, feel free to offer input.  I will monitor these questions for a period of 3-5 days and come back and evaluate.  I will have another moderator (who is also an expert in this topic area) look at the question also to ensure we do the right thing for this question.

Thank you
Computer101
Community Support Moderator
0
 
laxatifCommented:
I had the same problem on more than one machine running WinME. I found that there are one or more .INF files in c:\windows\inf that were corrupted. They are LAYOUT*.INF.

After I renamed them and rebooted, I was once again able to access the Windows Setup tab, and the rundll error does not appear.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 3
  • 2
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now