[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Out of Office Assistant will not automatically forward external e-mail

Posted on 2001-08-07
25
Medium Priority
?
1,530 Views
Last Modified: 2008-02-01
I am trying to setup the Out-of-Office Assistant to
automatically forward all incoming internal and external
email to an external account for someone going on
maternity leave.  We are using Outlook 2000 and Exchange
Server (v5.5).  I have already cleared the check
boxes Disable Out of Office responses to the Internet
and Disable Automatic Replies to the Internet on my Exchange server and restarted those services. The
problem is that it will never forward external email to an external account.  Internally generated email
will
successfully forward every time. Any and all help will be
greatly appreciated.
0
Comment
Question by:culture123
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 8
  • 4
  • +3
25 Comments
 
LVL 2

Expert Comment

by:ThaiTran
ID: 6359414
Use Cleansweep Tool to reset the permission of your mailbox rules. It will work for you.

http://support.microsoft.com/support/kb/articles/Q174/0/45.asp

Just remember after you install cleansweep, highlight your Inbox folder, then Go to Tools \ Cleansweep.
0
 
LVL 56

Expert Comment

by:andyalder
ID: 6359459
You can't just type a SMTP address for it to forward to you have to pick the recipient out of the GAL.

Create a custom recipient with the correct SMTP address using Exchange admin GUI, run the rules or out of office assistant under Outlook or the alternate recipient option under exchange admin and select the recipient you just created.
0
 
LVL 56

Expert Comment

by:andyalder
ID: 6359560
http://support.microsoft.com/support/kb/articles/Q255/6/97.ASP is the server based method, the rules wizard method is similar. The main thing to note is that although the program allows you to type a SMTP address into the field it does not then popup a warning saying that it will not work. There is also a minor bug under certain circumstances it does not work unless Exchange is at SP4.
0
Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

 
LVL 1

Expert Comment

by:piercenie
ID: 6359609
culture123 - It sounds to me as if you have everything set properly.  I would check the rules in OOA and see if you have something there which is causing the problem. My personal OOA Edit Rules screen has only one rule. The only boxes which contain anything on the Edit Rule dialog are:
Forward checkbox is checked, To... has the Internet address to which I want email forwarded (This must be an address stored in Outlook. Mine is in Contacts.), and the Method: dropdown is set to Standard. Be sure that the address in To... is inderlined by clicking Check Names if it is not. When you OK the rule you should get a message indicating that this rule will fire for all received messages and the rule is named All Messages. This works for me and everyone in our site who has used it. Let me know if this works.     Piercenie

0
 

Author Comment

by:culture123
ID: 6363870
Hello,

I'm sorry to say that these comments I've received have not worked.

Pls Help Thanks
JP
0
 
LVL 56

Expert Comment

by:andyalder
ID: 6364405
Check the server's registry keys as per http://support.microsoft.com/support/kb/articles/Q192/9/82.ASP
Does the server based method work?
0
 

Expert Comment

by:skyhook8
ID: 6375330
Set up a Custom Recipient for the Internet Address. Open the mailbox properties for the user. On the Delivery Options tab, select Alternate Recipient and designate the Custom Recipient. Go back and Hide the Custom Recipient from the GAL.

Did I miss something?
0
 
LVL 56

Expert Comment

by:andyalder
ID: 6375749
Yeah, you missed the fact that I said that 3 days ago. Except that I did not say hide it from the address book as he ultimately wants to run the rule with OOF.
0
 
LVL 1

Expert Comment

by:piercenie
ID: 6379575
Sorry, I forgot to mention earlier that you need to set the Out of Office Assistant to I am OUT of the Office.

Piercenie
0
 

Author Comment

by:culture123
ID: 6390187
Hello Again,

 If I create a custom recipient for the internet address
it asks me for an email address....The point of out of office services is that anyone who e-mails you gets a reply that your out of the office. So I can't create a custom recipient if I don't know who's going to email me.

PLS HELP.....

Thanks
0
 
LVL 1

Expert Comment

by:piercenie
ID: 6392249
The custom recipient is for the address to which you want OOA to forward your mail.  You must have a recipient in your GAL for the address to which you want to forward your incoming mail while you are out of the office.

piercenie
0
 

Author Comment

by:culture123
ID: 6392809
Hi again, :-)

   I would like to be able to reply to incomming external
emails. The external email sender would recieve an out of office email. I just don't want to forward the emails to someone else, I want the external  recipient to receive and out of office email.....

Thanks
0
 
LVL 1

Expert Comment

by:piercenie
ID: 6392859
culture123:  If what you want to do is have your Exchange server reply once to each incoming message (whether internal or external) stating that you are out of the office do this:  Click Tools and the Out of Office Assistant which should open the Out of Office Assistant dialog box. Click the I am currently Out of the Office button to turn on the OOA. In the text box just below the sentence "AutoReply only once to each sender with the following text:" type the message which you want to send as a reply to any messages that you receive.  The Out of Office Assistant should reply once to each sender from whom you receive an incoming message with the message that you put into the text box.  The Out of Office Assistant will use the reply address that comes in on each message just as you would if you opened the incoming message and then clicked Reply.  Did I answer the right question yet?

Piercenie
0
 

Author Comment

by:culture123
ID: 6393464
Piercenie,

Thats exactly whats not working. I've already done all that you've said, however its only replying to internal emails and not to the external ones that come in. Thats the problem I'm having, and been trying to get answers for....

Thanks
0
 
LVL 1

Expert Comment

by:piercenie
ID: 6393689
culture123:  I have gone back and read over all of your comments and it does sound as if the OOA should be working as expected. My understanding is that you are receiving email from external sources (Internet and other email domains) with no problems except that the OOA will not reply to these external messages. Internal messages (from others in your Exchange organization) are being received OK and the OOA is replying to them as expected.  Is this accurate?  How do you receive external mail into your Exchange server? Are you using the Exchange Internet Mail Connector or do individual users connect using the Internet Mail Service in the mail profile without going through the Exchange server?  Also, I don't think you mentioned which service pack your exchange is at. If you would be interested in some help outside this forum I'd be happy to do what I can to help. If we use email we could exchange some screen shots that may be helpful. You may want to check to be sure that there are no rules in the OOA dialog box that may be interfering with OOA replies, or I have seen Outlook rules for handling incoming mail that interfered with the OOA as well.

Piercenie
pierce.nienaber@auditor.hamilton-co.org
0
 

Author Comment

by:culture123
ID: 6413565
Hello,


I have a Linux Pop3 mail server which is also our smtp server. I have Exchange 5.5 with service pack 4 installed on an NT 4 server. When I select the check box "I am currently out of the office" in OOA it only replys to internal emails within the company. When someone from outside sends an email it does not reply back to the external sender......... I've tried all these suggestions with no success.....

Thanks for all your help up to now, but I really need to get this working.......


0
 
LVL 1

Expert Comment

by:piercenie
ID: 6417805
culture123: I did some more research and really could not find a good answer for you.  The only thing which I saw that may make some sense is to check all rules for the Outlook client who is out of office and be sure that no rule has in it to stop processing of any other rules.  Apparantly the OOA reply rule is the last rule processed and if there are any prior rules that stop rule processing it will keep the OOA reply from happening.  Problem with that is that it should also stop internal replies.  I would check any rules anyway just to be sure.

Is the person in question normally able to send and reply to external messages?  I'm starting to think that this is one of things where the answer is so simple that we are overlooking it.

Piercenie
0
 

Author Comment

by:culture123
ID: 6417928
Hi,

   I'm not using the rule wizard with OOA.I'm not adding any rules. I just open "Out of Assistant" and select " out of Office", and enter a few lines in the text box.

No one in the office has problems sending or receiving emails externally.

Now, OOA works well only if you don't have the exchange 5.5 service installed in outlook. This user is not in our exchange server and uses our Mail server to send and recieve emails. Outlook OOA seems to work well when you only have the mail service installed in outlook.

If someone is going to sugggest removing my users from the exchange server..... That is really really not an option....   :-)

Thanks for your patients and time
0
 
LVL 1

Expert Comment

by:piercenie
ID: 6418487
Okay, I am getting confused again.  When you say that this user is not using exchange and that OOA works fine that way does that mean that you have resolved your problem?  Or do you want this user who works fine without Exchange to use Exchange and that's the problem?  Or does this user work fine without Exchange except for the fact that OOA still will not reply to external email even without Exchange?  I keep feeling that the target is moving here.

Piercenie
0
 
LVL 2

Expert Comment

by:ThaiTran
ID: 6418602
Culture123,
  I got the same problem with OOA before. I used Cleansweep32 to clean up the rules of user mailbox and it worked again.  If you create a new email account, I believe it will work with OOA but the old email accounts.  That's why I suggested you to use cleansweep32.  See my previous comment above.

0
 

Author Comment

by:culture123
ID: 6418941
Hi
  The problem has yet to be resolved. 95% of our users  have mailboxes on our 5.5 Exchange server. These users are not able to use OOA to reply to external emails when they are out of the office, however it does work when its an internal email.

For those users (5%)who do not have a mailbox in our exchange server, and use only the mail services in outlook have used OOA with success. This means that when they are out of the office, internal and external emails are being replied to with an "out of office" email.

I'd like for my users which are on the exchange server, be able to use OOA successfully. Which means that external emails are replied to with an out of office email. This is the problem, why won't OOA reply to external emails for those users who are on the exchange server.


Thanks
0
 
LVL 1

Expert Comment

by:piercenie
ID: 6418984
I may have asked this before, but I can't see an answer here.  Do you have the Internet Mail Connector installed on Exchange or just how do you send and receive external mail on the exchange server?  Is this done using the Linux mail server somehow?
0
 

Author Comment

by:culture123
ID: 6419276
Hi

Did you guys get my last comment??? It doesn't seem to have been posted......I sent it 1 hour.
0
 

Author Comment

by:culture123
ID: 6419294
Hi,

Yes I do have the Internet Mail Connector installed on the exchange server.We receive external mail from our Linux mail server.
0
 

Accepted Solution

by:
SpideyMod earned 0 total points
ID: 8299982
PAQ'd and points refunded.

SpideyMod
Community Support Moderator @Experts Exchange
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

One-stop solution for Exchange Administrators to address all MS Exchange Server issues, which is known by the name of Stellar Exchange Toolkit.
As much as Microsoft wants to kill off PST file support, just as they tried to do with public folders, there are still times when it is useful or downright necessary to export Exchange mailboxes to PST files. Thankfully, it is still possible to e…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
Suggested Courses

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question