• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 185
  • Last Modified:

Last Modified times on files

When I change a file in Dreamweaver, it updates the "last modified" time correctly in the site window.  However, when I FTP the file (using DW) over to the remote site, it sets the last modified time back to some other time!  Usually, the time the file was created.  Sometimes (and I can't find a method to this), it's the time before the time the file was last modified.

How can I stop this?  Even if I look at the "last modified" times in Windows Explorer on my PC, they're wrong.  So DW is doing something -seriously- weird.

This is urgent.  A fix for this would be greatly appreciated.
0
Kat010897
Asked:
Kat010897
  • 3
  • 2
1 Solution
 
kpsadanCommented:
I think it is showing the remote server time. Any way just paste the below code somewhere in your page and see the date what it is showing.

<script language = "JavaScript"><!--

 function makeArray() {
 for (i = 0; i < makeArray.arguments.length; i++)
   this[i + 1] = makeArray.arguments[i];
 }

 var modifiedMonth = new makeArray('January','February','March','April',
                           'May','June','July','August','September',
                           'October','November','December');

 var modifiedDate = new Date(document.lastModified);

 document.write('Last Modified : ' + modifiedMonth[modifiedDate.getMonth() + 1] + ' ' +
                                   modifiedDate.getDate() + ', ' +
                                   modifiedDate.getFullYear());

 //--></script>

0
 
Kat010897Author Commented:
No, I'm not talking about the last modified date IN the page, I'm talking about the last-modified date associated with the FILE.  i.e. in the Site window, you have several columns: "Local Folder" "Size" etc, and one of those is "Modified".  
0
 
Snazzy_GraphicsCommented:
This is a known shortcoming with DW. There is no pref. setting for server time settings, unlike some ftp clients.

You can indeed lose updates this way, and it does get confusing if your server is in different time zone or such.

You need to fix this on the server site. You have to ask your webhost to modify their ftp server to the right time settings.

According to Macromedia Tech, DW should change the time on local files after your syncronize to match the remote server's date (which is very confusing of course).

And for that to work: "In order for for Dreamweaver's timestamp-related functions to work correctly, users must have permission (set by the Server Administrator) to create directories in the default login directory. "

There's also a particular bug with Serv-U-FTP v.2.3a, if that's what your host is running they need to upgrade.

--Snazzy
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

 
Kat010897Author Commented:
Well, that's... weird.  The server's time settings are correct.  What's happening is that I'm uploading the file, and, once I've done that, it APPEARS to have the wrong time in the remote site window.  However, if I log into a unix terminal and get a file listing, the time is correct.  

But the only way to get DW to have the right time in the remote window is to diconnect and re-connect to the site (refreshing doesn't work).  And DW has set the local file (on my PC) to have the wrong time.

Is there any way to disable DW's habit of messing with the "last modified" times on my PC?
0
 
Snazzy_GraphicsCommented:
Yep, that is weird. Haven't had or heard of that problem.

For one thing, synchronize wouldn't work right if it didn't know correct times.

For another, should just update anyway.

Two stabs in dark: is site cache off?

Are you going through some proxy?

That's weird enough I do an reinstall and see if it still happens. There's no way to turn off modified times.
0
 
Kat010897Author Commented:
Ah... I think I understand what's happening.  I think DW is reading the time on the server and synchronising the PC's "last modified" time BEFORE it copies the file across.  Which is pure madness, of course, but that's probably why the times are wrong.  

I can fix it by deleting the files on the remote before I upload the new copies.  Pain in the ass, but it works.  Thanks for your help!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now