Posted on 2001-08-08
Last Modified: 2010-04-06

When i try to press on F1 key (to get some help from delphi IDE)
i got and error message
"Preparing Help file for first use : WinHlp32 - Application Error" ...... The memory could not be "read"

Why ?

Question by:asi
LVL 27

Expert Comment

ID: 6363620
? maybe you are low on memory

Expert Comment

ID: 6363774
Have you scanned your hard drive with Scandisk yet??

Author Comment

ID: 6363783
I"m using win2000 Pro
ScreenConnect 6.0 Free Trial

Discover new time-saving features in one game-changing release, ScreenConnect 6.0, based on partner feedback. New features include a redesigned UI, app configurations and chat acknowledgement to improve customer engagement!

LVL 20

Expert Comment

ID: 6363937
Hmmm... Are you (still) using some of my packages? In that case please try to disable the package "madHelp". I don't think it's guilty, but maybe it's worth the try just to be sure...   :-/

Regards, Madshi.

P.S: Which Delphi version are you using? D6 has introduced a new help system which seems to be a bit on the weak side.
LVL 44

Expert Comment

ID: 6364345
Could be a faulty memory module or as mhieta suggested do a scandisk which actually there isn't literally a scandisk in Win2000. If you are not familiar with how to do this in Win 2000 open Control Panel > Computer Management and look under the node "Storage" and then click on "Disk management". From there right click on the disk in question and choose "Properties" then select the "Tools" tab and then click the "Check Now" button. A window will popup with two check boxes so check both of them. Chances are Win 2000 will give a message that it couldn't proceed but will give you the option to schedule it at the next restart so select OK and then reboot. If this doesn't help try grabbing that help file off of the Delphi disk and copy it over to the same directory where the one you are having trouble with.

The Crazy One

Author Comment

ID: 6364386
I just copy the delphi help directory from another computer
and the problem solved !

Expert Comment

ID: 6844658
Question(s) below appears to have been abandoned. ADMINISTRATION HAS BEEN ADVISED AND WILL BE CONTACTING YOU SHORTLY.  There are a total of 57 open questions for you, any not shown here have ZERO comments added, so you can delete them directly.

Your options are:
1. Accept a Comment As Answer (use the button next to the Expert's name).
2. Close the question if the information was not useful to you. You must tell the participants why you wish to do this, and allow for Expert response.
3. Ask Community Support to help split points between participating experts, or just comment here with details and we'll respond with the process.
4. Delete the question. Again, please comment to advise the other participants why you wish to do this.

For special handling needs, please post a zero point question in the link below and include the question QID/link(s) that it regards.
Please click the Help Desk link on the left for Member Guidelines, Member Agreement and the Question/Answer process.

Please click you Member Profile to view your question history and keep them all current with updates as the collaboration effort continues, to track all your open and locked questions at this site.  If you are an EE Pro user, use the Power Search option to find them.

To view your open questions, please click the following link(s) and keep them all current with updates.

To view your locked questions, please click the following link(s) and evaluate the proposed answer.

------------>  EXPERTS:  Please leave any comments regarding your closing recommendations if this item remains inactive another seven (7) days.
Thank you everyone.
Moderator @ Experts Exchange

P.S.  For any year 2000 questions, special attention is needed to ensure the first correct response is awarded, since they are not in the comment date order, but rather in Member ID order.

Accepted Solution

Netminder earned 0 total points
ID: 6887775
Admin notified of User neglect. Points refunded and question closed by
Community Support Moderator
Experts Exchange

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Windows Drag & Drop Location 2 100
Intraweb download file link ? 1 134
tidtcpserver connection lost handle 2 87
When i run adoquery my application freezes 26 166
A lot of questions regard threads in Delphi.   One of the more specific questions is how to show progress of the thread.   Updating a progressbar from inside a thread is a mistake. A solution to this would be to send a synchronized message to the…
Introduction The parallel port is a very commonly known port, it was widely used to connect a printer to the PC, if you look at the back of your computer, for those who don't have newer computers, there will be a port with 25 pins and a small print…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question