Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Startup command hangs up and there is no response from Oracle.

Posted on 2001-08-08
8
Medium Priority
?
1,823 Views
Last Modified: 2012-08-14
Hi! Experts
I have installed Oracle 8.1.6 on Red Hat Linux 7.1. The installation has been successful and now I want to create database. The problem it is giving me is that the startup command hangs and there is no repsonse from the server.
Well, I think that Oracle is not getting enough hardware resources because when I run $svrmgrl, it gives me an "end-of-file" error and then logs into svrmgr. But after that when I try to startup Oracle, it hangs even when I tried startup nomount.
I have 192 MB RAM in Linux server. When the Linux was fresh and there was nothing installed except Linux server, it was showing 90 MB RAM used. When I installed Oracle, the usage went to 178 MB even when Oracle server is shutdown. It seems to me that Oracle is not getting enough RAM that's why the server is not starting. Interestingly, the usage of SWAP is just 2%. It seems to me that Linux is unable to use SWAP and that's why it is using more of the RAM.
Well, that's what I have found out. Please give your comments about the problem. Is it related with Linux only or am I required to do something with Oracle also?
0
Comment
Question by:otnxmem
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +2
8 Comments
 
LVL 3

Expert Comment

by:p_yaroslav
ID: 6364273
Hello!

AFAIK....
Oracle need install on Linux 6.2.
7.1 not supported yet.

Yaroslav.
0
 

Accepted Solution

by:
venkaji earned 200 total points
ID: 6367872
Oracle in not certified for the RedHat 7.1.Oracle8i is certified for RedHat 6.1/6.2.
If you are specific about 7.1 release use SuSE Linux 7.1 with Oracle 9i.
Oracle 9i Release 1 (9.0.1) is certified on SuSe 7.1, Kernel 2.4.4 and the operating system library glibc 2.2

128 MB RAM is enough for Oracle 8i, where as Oracle 9i requires minimum of 512 MB RAM.
0
 
LVL 1

Author Comment

by:otnxmem
ID: 6368002
Thanks Venkaji for the valuable information. I am rejecting your answer for a while so that it is open for other experts for further comments. Well, I'll definitely give you points, please wait for some days.
Other experts are also requested to give their comments.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 3

Expert Comment

by:p_yaroslav
ID: 6368054
0
 

Expert Comment

by:yo_hou
ID: 6371308
I have just installed Oracle 8.1.6 on Red Hat Linux 7.1 .
Everything is normal.Ram in my computer is 256M.But I think 128m ram is enough.
The problem you met is about th version of  glibc.
For oracle 8.1.6 on red hat linux 7.1 ,you should use
glibc 2.1.3,not higher version.The point is not mentioned in the document fo oracle.Please check your version of glibc.
0
 
LVL 1

Author Comment

by:otnxmem
ID: 6372346
Thanks yo_hou for that information. It will be very kind of you if you can tell me from where can I get the exact version of glibc.
0
 

Expert Comment

by:yo_hou
ID: 6378258
You can download the version of glibc from the URL(ftp://ftp.kernel.org/pub/software/libs/glibc/hjl/sdk/2.1/).I hope it's helpful.
0
 
LVL 1

Expert Comment

by:Moondancer
ID: 7034701
Please update and finalize this old, open question.  Please:

1) Award points ... if you need Moderator assistance to split points, comment here with details please or advise us in Community Support with a zero point question and this question link.
2) Ask us to delete it if it has no value to you or others
3) Ask for a refund so that we can move it to our PAQ at zero points if it did not help you but may help others.

EXPERT INPUT WITH CLOSING RECOMMENDATIONS IS APPRECIATED IF ASKER DOES NOT RESPOND.

Thanks,
Moondancer - EE Moderator

P.S.  Please click your Member Profile, expand View Question History to navigate and update all your open and locked questions.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Truncate is a DDL Command where as Delete is a DML Command. Both will delete data from table, but what is the difference between these below statements truncate table <table_name> ?? delete from <table_name> ?? The first command cannot be …
Have you ever had to make fundamental changes to a table in Oracle, but haven't been able to get any downtime?  I'm talking things like: * Dropping columns * Shrinking allocated space * Removing chained blocks and restoring the PCTFREE * Re-or…
This video explains at a high level with the mandatory Oracle Memory processes are as well as touching on some of the more common optional ones.
This video shows information on the Oracle Data Dictionary, starting with the Oracle documentation, explaining the different types of Data Dictionary views available by group and permissions as well as giving examples on how to retrieve data from th…

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question