bindresvport error on user nfs mount

I have a "laptop" with a home directory /home/user
wich i wanna export to "i586pc". The user "user" on the "i586pc" should be able to mount the directory. I've made the following configurations :
i586pc:
/etc/fstab
laptop:/home/user    /home/user/mnt  user,noauto,rw

laptop:
/etc/exports
/home/user   i586pc   (rw,insecure)

When i'm root on i586pc its no problem to mount the dir. When i'm user at i586pc i got the errormessage bindresvport : "access denied".
Before i put the "insecure" option into /etc/exports, i got the errormessage "illegal port 1026" on the laptop.
I have SuSE 6.3/4 on the laptop and SuSE 7.0 on the i586pc.
Whats wrong, or what i could i do against ?
DennisWoodAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
jlevieConnect With a Mentor Commented:
Just to keep things simple to aid in diagnosing the problem... What happens if you su to root, then mount the volume, and then revert back to ordinary user status? Can you access files in /home/user/mnt? If you remove the "user" option from the fstab line and mount the volume can you access the files?
0
 
jlevieCommented:
Since you can mount the exported file system as root, everything is working correctly as far as NFS is concerned. The 'access denied" error is mount telling you that ordinary users aren't allowed to mount NFS volumes. If security isn't of any concern whatsoever, you could make "mount' suid to root. A better solution would be to set up sudo to allow ordinary users to mount just that file system.
0
 
DennisWoodAuthor Commented:
i tried out something simialar. i wrote a c-programm wich called "mount /home/user". after comiling i set the suid flag as owner root. the result was the mount call worked. but when i wanted to access to the dir i got the error invalid filehandle
0
 
DennisWoodAuthor Commented:
yes it worked with su, after that i made it sudo and it works great.
Mostly its the best to keep simple, but not easy
0
All Courses

From novice to tech pro — start learning today.