Solved

Delphi6 Personal Edition

Posted on 2001-08-08
16
698 Views
Last Modified: 2010-04-06
hi
i just downloaded delphi6 personal edition form borland site and installed on a system with delphi5 on and when rebooted and ran i had no components at all.

from the install packages menu ive installed the .bpls from /bin dir and got the components back but im wondering if i have them all or not as 2 of the .bpl's didnt/wont install.

"Borland Delphi CoreIDE Package"    from delphiIDE60.bpl
and
"Integrated Development Specific Components"  from vclIde60.bpl

can someone give me a list of what component tabs i should have so
i can check i have all .

I gather there is nothing at all for db stuff..

cheers Barry

ps,
i never expected the cpu components tab ,does everyone else have it?
i cant use them as i dont have a Discomp.dcu
these are the components the cpu tab has:
 TDisassemblerView;
 TFlagsView;
 TFPURegisterView;
 TDumpView;
 TAddressStatus;

note
the tabs i currently have are:

Standard,CPU,Dialogs,System,Additional,Win32,Internet,Win31,ActiveX,Samples
0
Comment
Question by:inthe
  • 4
  • 4
  • 3
  • +4
16 Comments
 
LVL 5

Expert Comment

by:Gwena
ID: 6366575
Hey! :-(
I don't have the CPU components tab
sniff :'(

I wonder if they have put up a slightly different version
than the one I downloaded... It took me 9hrs... whew
0
 
LVL 5

Accepted Solution

by:
Gwena earned 50 total points
ID: 6366577
Oh... other than the CPU tab you have all the ones I do :-)

0
 
LVL 7

Expert Comment

by:Motaz
ID: 6366921
inthe asking, who will answer then:)

I got CPU tab in Delphi 5 when I install all the package manually.
0
 
LVL 5

Expert Comment

by:Gwena
ID: 6367036
Hi Motaz :-)
  I made a CD of the uncompressed D6P download... and it autostarted and installed automatically... Maybe that's why I have no CPU tab...hmmm  Maybe I should try it again manually.
0
 
LVL 20

Expert Comment

by:Madshi
ID: 6367049
Here is what is contained in my D6 professional, if you look at "components -> configure palette". Well, it's in German, hopefully it will help nevertheless:

Standard, Zusatzlich, Common Controls, Win32, System, Datenzugriff, Datensteuerung, dbExpress, BDE, ADO, Interbase, Internet, FastNet, QReport, Dialoge, Win 3.1, Beispiele, COM+

The tabs "Common Controls", "dbExpress" and "FastNet" are not visible as tabs, don't know why.

Regards, Madshi.
0
 
LVL 1

Expert Comment

by:BlackDeath
ID: 6367512
hi madshi, hi all.

say, mad - do you run it parallel to d5?

grrreetinx,

BlackDeath.
0
 
LVL 20

Expert Comment

by:Madshi
ID: 6367642
Hi BlackDeath, nice to see you once again...  :-)  I run D4, D5 and D6 parallel, all professional version.

Regards, Madshi.
0
 
LVL 2

Expert Comment

by:egono
ID: 6367653
listening - I just downloaded the Delphi 6 Personal Edition and had no time to install it, maybe it's better to wait until someone solves inthe's problem :-)
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 
LVL 17

Author Comment

by:inthe
ID: 6368370
the initial problem seems to have been a messed up registry after reverting to reg from a few days ago and reinstalled it worked fine.
actually madshi's components were the only ones that showed up originally and i hadnt even installed them into d6 they were just there, i guess that was cause you put them in registry in the right place .. gwena has gave what i needed.i found out that the cpu components are used internally so no use to me anyway and it seems i have all the rest of this editions comps.
looks like i have to get pro version ,as i could do with the dbexpress and ado stuff.

blackdeath,
(hello stranger from these parts ;-)
if you were wondering ,the different versions run fine in parallell.only annoying prob is the jit message on starting them,about would i like to change the debugger to blah as its currently set to blahblah.
heh like im gonna say no ?
0
 
LVL 1

Expert Comment

by:BlackDeath
ID: 6368463
you won't would u <G>

can't u get rid of it?

i dunno, mayb via registry?

there's a setting for borland/debugging/5.0/jit debuggers
and under clsid section for bordbk50.dll as inprocserver
and an entry for ijit attach debugger

and so on.

i've never fumbled around w/ this, but mayb you can modify this in any way, dunno.

just an idea.

apparently quite stupido, eh?

harrharr.

anyway, have a nice day, guys & c ya,

BlackDeath.
0
 
LVL 20

Expert Comment

by:Madshi
ID: 6368578
My packages install into D4-6 automatically, regardless of whether the specific Delphi versions are installed or not. Maybe that is the reason for your problems, Barry? Maybe D6 doesn't install itself correctly, if the package registry key is already existing before D6 installation? Hmmm...   :-(   I'll have to check that out... It would be no good D6 installation routine, IMHO...

Regards, Madshi.
0
 
LVL 17

Author Comment

by:inthe
ID: 6368661
>>>reason for your problems

i doubt it,but i can test by installing d6 on my laptop on which your d6 ones arent yet installed <shame on me though winobj is still there ;->


>> package registry key is already existing before D6 installation

my thoughts exactly so im not sure for this test though should i install your comps first or afterwards?
0
 
LVL 5

Expert Comment

by:Gwena
ID: 6370215
Hi Inthe :-)

 WoW!  me getting points answering a Q for inthe...who whoulda thought it possible :-)
0
 
LVL 20

Expert Comment

by:Madshi
ID: 6371511
>> my thoughts exactly so im not sure for this test though should i install your comps first or afterwards?

I would say: Install D6 first, then my comps, if D6 then has all packages, it's probably my fault...   :-(
0
 
LVL 17

Author Comment

by:inthe
ID: 6374472
i did it that way and it worked fine.
can test the other way (yours first then d6)and let you know next week
0
 

Expert Comment

by:DrugDealer
ID: 7308064
gotta say some: uuuuuuuuuuuuuuuuuummmgh....... WHY YOU PEOPLE ALWAYS USE /PERSONAL/ stuff? why don't you use ENTERPRISE or at least Professional? but not Personal. Personal is free. and you can't use the Upgrade Packs either.
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

The uses clause is one of those things that just tends to grow and grow. Most of the time this is in the main form, as it's from this form that all others are called. If you have a big application (including many forms), the uses clause in the in…
In my programming career I have only very rarely run into situations where operator overloading would be of any use in my work.  Normally those situations involved math with either overly large numbers (hundreds of thousands of digits or accuracy re…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now