Solved

NIC configured but not working

Posted on 2001-08-10
19
307 Views
Last Modified: 2010-08-05
I have a realtek PnP NIC that can also be set as Jumperless.
I installed it in Linux RH7. the card gets configured properly by IsaPnP and ifconfig shows it working. but I cannot get any packet to the kernel.
I can send packets though. This i observed on the other box using tcpdump. the other box gets arp requests but no inbound traffic is observed on my machine.

however, if i set up the card as jumperless, it works fine...why
0
Comment
Question by:kiranghag
19 Comments
 
LVL 51

Expert Comment

by:ahoffmann
ID: 6371846
what does tcpdump on your machine tell you?
Simply use a ping to test.
Sounds that you have a routing problem.
0
 
LVL 4

Expert Comment

by:kannabis
ID: 6373674
linux doesn't have 100% ISA PnP compatibility.  If it works for you, then great, if not, leave it on jumperless
0
 
LVL 40

Expert Comment

by:jlevie
ID: 6375518
Being able to send data out an ethernet interface on Linux but not being able to receive data is generally caused by an interrupt conflict. The NIC drivers can send small amounts of data (like ping packets) without using an interrupt. However, the driver will only pull data from the card when it sees an interrupt.

You check for interrupt conflicts by looking at the contents of /proc/interrupts, /proc/pci, and the output of 'dmesg | grep -i irq'. My guess is that you'll find some other device trying to use the IRQ assigned to the NIC. Finding the interrupt conflict is easy, fixing it can be difficult. First of all make sure that PnP mode is disabled in the BIOS. Neither Linux nor NT is very happy with the BIOS trying to make decisions about how the devices get set up and the OS would prefer to do it itself (oh yeah, win95/98 is perfectly happy with PnP mode disabled). Sometimes that's all that is required to resolve the conflict. If that doesn't work, more drastic measures ad called for. In your case you have a relatively easy solution at your disposal. Change the card to 'jumper configured' and set it to an IRQ that isn't in use. If the BIOS allows, also specify that IRQ as being reserved for ISA use.
0
 
LVL 10

Author Comment

by:kiranghag
ID: 6378572
ahoff - its not pinging

jl- there is no interrupt conflict.

also my other two cards work fine with same settings

0
 
LVL 40

Expert Comment

by:jlevie
ID: 6378616
Are you certain there isn't an interrupt conflict? So far in each and every case I've seen a NIC send data and not be able to receive anything it's been an IRQ conflict. And you do have to look at all three of the items I mentioned. Not everything that uses an interrupt is shown in /proc/interrupts.
0
 
LVL 10

Author Comment

by:kiranghag
ID: 6399642
the cards are now connecting but shows all zeros MAC address in ifconfig. this is known as the HOWTO says that the ifconfig may do it but kernle knows it properly. but then tcpdump also shows all zeros transmitted as the MAC address to an ARP reply.

and even if this is known, why it should happen as the thing was shown preoperly before this.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 6399711
That sort of sounds like some sort of a driver problem where the driver isn't able to read the MAC from the card. If it were my system I'd replace the card with something else that works properly. Have you tried putting the card into 'jumper config mode' and see if the problem is related to ISAPnP? Do you have PnP mode disabled in the BIOS? A number of odd problems with PnP cards seem to dissappear with PnP turned off in the BIOS.
0
 
LVL 10

Author Comment

by:kiranghag
ID: 6439458
well, the card was showing all the details properly before some time. i just chaged from jumperless to pnp and problem seem to start. i again reverted back to previous settings, but nope
0
 
LVL 40

Expert Comment

by:jlevie
ID: 6445205
Do you mean that you changed from jumper config'd to PnP, and vice versa? To my way of thinking jumperless and PnP are the same. When the card is manually configured via jumpers are you sure that it is set to use a free IRQ? To tell what IRQ's are in use you have to look at the output of 'dmesg | grep -i irq', and the contents of /proc/pci, and the contents of /proc/interrupts. From all of that data you can determine exactly what IRQ's are being used, and by what. And you do have to look at all of those sources of information.

Also if you have multiple NIC's in the system of the same type, you'll need to make specific aliases for each of the cards in /etc/modules.conf. See the Ethernet HowTo (http://www.redhat.com/mirrors/LDP/HOWTO/Ethernet-HOWTO.html) for more information.
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 
LVL 10

Author Comment

by:kiranghag
ID: 6447148
no, i dont; agree that pnp and jumperless are the same. pnp means complient to pnp standard that is found on most isa and almost all pci cards. jumperless is meant for configuring irq settings thurgh driver. but for jumperless mode, io address has to be supplied. in case of pnp, the card negotiates both, irq and base address settings.

am i wrong anywhere?
0
 
LVL 40

Expert Comment

by:jlevie
ID: 6447210
My understanding is a bit different. PnP and jumperless are the same in that either the BIOS (if PnP mode is enabled) or the system will configure the card. The alternative mode, that some cards have, is to manually configure the card via jumpers. I'd have to look at the driver code carefully, but I don't remember any code in the drivers that will set the card on Linux. That can be done with isapnp, but I don't think that the options settable in modules.conf 'configure' the card. They just tell the driver what IRQ and/or IO port the card is using.
0
 
LVL 10

Author Comment

by:kiranghag
ID: 6452696
i think i am right, coz when u put a card in jumperless mode, the isapnp will not detect it and hence will not allocate the resorces in the PnP intended manner. in the jumperless mode, u can just specify the base address, it will not be detected automatically, but once u set it, it will automatically set the interrupt.
when a card is in pnp mode, it will automatically inform pnp manager abt the required resources.
so main diff is pnp contacts manager and in jumperless manager contacts card.


Kiran
http://kiran7.freeservers.com

0
 
LVL 40

Expert Comment

by:jlevie
ID: 6452887
Okay, that does sound about right. But in both of those cases assignment of the interrupt can be problematical. Both depend on some process determining what IRQ to use and the rules for windows (the larger market) and Linux are different. In windows it is acceptable to have more than one card sharing an IRQ. Linux doesn't support that and a NIC that shares an interrupt with some other device won't work.

So when the card was set to jumperless it was able to figure out what IRQ was free and use that. I'm guessing that when the card was in PnP mode you had the BIOS PnP mode enabled and that process set the card up such that a resource conflict resulted. Usually, if you disable PnP mode in the BIOS. Linux can sort things out and set up the PnP cards so that there isn't a resource conflict.
0
 
LVL 10

Author Comment

by:kiranghag
ID: 6455431
okay, but now i can transmit and recieve. though the system reports mac address as all zeroes. it used to come right before, now what.

0
 
LVL 40

Accepted Solution

by:
jlevie earned 50 total points
ID: 6460981
I suspect that the card actually isn't using a MAC of all zero's. And you could check that easily enough with a tcpdump trace of any traffic to/from the card. It sounds more like the driver isn't able to read the data from the card. And to figure out why that would be the case with the card in this mode it would be necessary to look at the driver code.

If a tcpdump of traffic for that card does show a MAC of all zeros, then I'd say that the card isn't working quite right when in jumperless mode. That could be a fault in the card, or more likely a result of the OS not setting it up quite correctly. I don't have easy access to any RealTech cards so it's a little difficult to experiment.

That card should work correctly in PnP mode, providing that you solve any resource conflicts that occur.
0
 
LVL 10

Author Comment

by:kiranghag
ID: 6463011
yes, the card doesn;t actually uses all zeros as MAC. though the kernel wont report it. it was coming before this, why not now
0
 
LVL 40

Expert Comment

by:jlevie
ID: 6469462
Yes, but didn't you change the config from PnP to jumperless between when it did and didn't work? For ifconfig to report an erroneous MAC it would seem that the driver isn't accessing the right area of memory where the device registers are mapped. That might tend to imply that the card isn't actually where the system thinks it is. Note that the card still might work in that configuratio, provided that enough of the card config matches what the system is looking for. Another possibility would be that the card itself didn't map all of its data to the correct place. Or possibly that the driver just isn't prepared to use the card when it's in that mode (possibly some register bits are different and the driver code doesn't know what to do).
0
 
LVL 10

Author Comment

by:kiranghag
ID: 6473937
well, the card is Compexen2000  a perfect NE2000 clone,
and more thaan that, it used to work before. i 'll try to cahgen the modes and see again.
0
 
LVL 1

Expert Comment

by:Moondancer
ID: 6870223
ADMINISTRATION WILL BE CONTACTING YOU SHORTLY.

Question(s) below appears to have been abandoned. Your options are:
 
1. Accept a Comment As Answer (use the button next to the Expert's name).
2. Close the question if the information was not useful to you. You must tell the participants why you wish to do this, and allow for Expert response.
3. Ask Community Support to help split points between participating experts, or just comment here with details and we'll respond with the process.
4. Delete the question. Again, please comment to advise the other participants why you wish to do this.

For special handling needs, please post a zero point question in the link below and include the question QID/link(s) that it regards.
http://www.experts-exchange.com/jsp/qList.jsp?ta=commspt
 
Please click the Help Desk link on the left for Member Guidelines, Member Agreement and the Question/Answer process.  http://www.experts-exchange.com/jsp/cmtyHelpDesk.jsp

Please click you Member Profile to view your question history and keep them all current with updates as the collaboration effort continues, to track all your open and locked questions at this site.  If you are an EE Pro user, use the Power Search option to find them.

To view your open questions, please click the following link(s) and keep them all current with updates.
http://www.experts-exchange.com/questions/Q.20100775.html
http://www.experts-exchange.com/questions/Q.20106489.html
http://www.experts-exchange.com/questions/Q.20108558.html
http://www.experts-exchange.com/questions/Q.20112800.html
http://www.experts-exchange.com/questions/Q.20112805.html
http://www.experts-exchange.com/questions/Q.20153440.html
http://www.experts-exchange.com/questions/Q.20153425.html
http://www.experts-exchange.com/questions/Q.20166318.html
http://www.experts-exchange.com/questions/Q.20166323.html
http://www.experts-exchange.com/questions/Q.20173364.html
http://www.experts-exchange.com/questions/Q.20178675.html
http://www.experts-exchange.com/questions/Q.20240317.html
http://www.experts-exchange.com/questions/Q.20255724.html
http://www.experts-exchange.com/questions/Q.20174818.html
http://www.experts-exchange.com/questions/Q.20274289.html
http://www.experts-exchange.com/questions/Q.20276351.html


To view your locked questions, please click the following link(s) and evaluate the proposed answer.
http://www.experts-exchange.com/questions/Q.20117550.html

PLEASE DO NOT AWARD THE POINTS TO ME.  
 
------------>  EXPERTS:  Please leave any comments regarding your closing recommendations if this item remains inactive another seven (7) days.  Also, if you are interested in the cleanup effort, please click this link http://www.experts-exchange.com/jsp/qManageQuestion.jsp?ta=commspt&qid=20274643
 
Thank you everyone.
 
Moondancer
Moderator @ Experts Exchange

P.S.  For any year 2000 questions, special attention is needed to ensure the first correct response is awarded, since they are not in the comment date order, but rather in Member ID order.
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now