• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 446
  • Last Modified:

Event viewer

I keep geting this under "System log":
DISK -The driver detected a controller error on \Device\Harddisk0\DR0.
 
ATAPI - A parity error was detected on \Device\Ide\IdePort0.

What is this about?
0
Bosanac
Asked:
Bosanac
  • 4
1 Solution
 
darrenburkeCommented:
To resolve this issue, change the transfer mode for the controller:
 
1. Right-click My Computer, and then click Manage.
 
2. Double-click System Tools in the right pane, and then double-click Device
  Manager.
 
3. Double-click IDE ATA/ATAPI Controller in the right pane, and then
  double-click the appropriate controller.
 
4. On the Advanced Settings tab, click PIO Only in the Transfer Mode box.
 
5. Click OK, close the Computer Management window, and then reboot the computer.
0
 
dew_associatesCommented:
Right out of the knowledge base, but not necessarily the fix to this problem.

Bosanac,

Is your motherboard ATA66 or 100 capable?
Is your hard drive ATA66/100 capable?

If so, you can enable this in Windows 2000, including DMA, you need not enable PIO mode only.

1. The easiest way is to make sure that your motherboards Bios is Windows 2000 compliant, which means it should have a Bios dated March 1999 or later.

Next, make sure that you have a driver set for that motherboard, which includes IDE BUS drivers that is are also compliant, and install then pursuant to the motherboard manufacturers recommendations.

Next, make sure that you have applied Service Pack 2, as this provides ATA66 support. Windows 2000 does not (at the moment) support ATA100.

NOTE: If you are using an ATA66/100 motherboard and drive, you must use an 80 wire ATA66/100 compliant IDE cable.

2. Another method is to make a registry change to enable ATA66 support, but this applies to Intel chipset based boards only. If you have VIA etc, let me know. Here's the MSKB article for your references.

http://support.microsoft.com/support/kb/articles/Q247/9/51.ASP?LN=EN-US&SD=gn&FR=0&qry=ATA66&rnk=1&src=DHCS_MSPSS_gn_SRCH&SPR=WIN2000

It would be helpful to know your hardware setup, such as motherboard make model etc.

Dennis

0
 
dew_associatesCommented:
Bosanac, how are you doing with this?
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

 
BosanacAuthor Commented:
this is beyond my knowledge...
I have VIA chipset and the blue cable that I linked my disks.Added registry...enable udma as spec. in MicroSoft but then get all errors...****.
What is primary ide i.e secondary ide chnl...god knows...
got service pack 2...
0
 
dew_associatesCommented:
Okay not a problem, I can walk you through the steps.

First, tell me two things. What motherboard are you using, and which version or set of VIA 4-in-1 drivers are you using, if you know?
0
 
dew_associatesCommented:
Bosanac?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now