Solved

eth0 kernel module installation

Posted on 2001-08-10
9
336 Views
Last Modified: 2013-12-15
ok,
during setup i screwed up and didn't setup the network correctly.  So now I have no eth0.  I enabled it in modules.conf and set it up in rc.config, but on boot it says

DHCLIENT: The device eth0 is not available at the moment.
DHCLIENT: Please check if the driver is setup correctly.

What did i miss? or What do I need to do to get my ethernet controller up?
0
Comment
Question by:loss4words
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 5

Expert Comment

by:paulqna
ID: 6374391
You do have the "network" script in the rc2 directory ? Check filename or permissions there please...

or try :
# network start eth0
0
 
LVL 40

Expert Comment

by:jlevie
ID: 6375528
Those error messages may imply that you've specified the wrong driver. You can tell if the driver matches the device (since you have it in modules.conf) by looking to see if the driver loads with 'lsmod'. If you don't see the driver listed, then you may not be using the right one. If kudzu ran and detected the device it will have loaded the correct driver. However, the network config will still be trying to use the driver you specified. You can fix that problem and correctly configure the NIC with linuxconf or netcfg. What card have you got and what driver are you trying to use?
0
 
LVL 8

Expert Comment

by:akshayxx
ID: 6388118
if its a default installation then its definetly the problem with your driver.. ( if u havent deleted any files by mistakes.. either the startup script in /etc/rc.d directory or the driver )
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 2

Expert Comment

by:ifincham
ID: 6392235
Hi,

When you say you enabled it in /etc/modules.conf what did you put in that file ? It should be 'alias eth0 modulename' where modulename is the appropriate driver for your nic. Are you sure you chose the right one ? Also, what card is it and is it pci/isa plug-and-pray, etc. ?

Regards
0
 

Expert Comment

by:qexp
ID: 6409901
you can try 'rmmod' to remove the wrong driver
and 'insmod' with eth
or you may try modprobe eth
0
 

Expert Comment

by:qexp
ID: 6409917
if u have kudzu running then easier way would be to
remove the network card boot the machine (it will remove
any associated config...) then again fix the card and
reboot
0
 

Expert Comment

by:CleanupPing
ID: 9086719
loss4words:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
LVL 2

Expert Comment

by:fciii
ID: 9668157
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:

PAQd and points forfeited

Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

fciii
EE Cleanup Volunteer
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 9710038
PAQed - no points refunded (of 100)

Computer101
E-E Admin
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This is the error message I got (CODE) Error caused by incompatible libmp3lame 3.98-2 with ffmpeg I've googled this error message and found out sometimes it attaches this note "can be treated with downgrade libmp3lame to version 3.97 or 3.98" …
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

697 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question