Icons only appear as the file type they open with.

I seem to have crossed switches sometime back with my icon files. Right now they're set to "open" using Microangelo Studio. When I open a file search on all icons they all have the same appearance (studio file). Now, when I do the same on my wife's desktop (we each have our own desktop running Windows 98) each icon shows up as it should (an entity unto itself). When I clicked the "properties" on each of these icons, they all use the same MicroAngelo Studio file to "open with". Since we're using the same computer & OS (but different desktops) & all of her icons (in all programs) appear normal & mine don't, how can I remedy this without starting over with a new desktop? I've spent quite an extensive amount of time configuing taskbars & folders etc. & would hate to loose all of my valuable hours that went into this creation.
Many thanks to anyone who can help solve this one *SS*
Gary56Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
LongbowConnect With a Mentor Commented:
Hi again,

open Windows Explorer
Menu View Then click Folder Options
Go in the File Type Tab
Search for the word "icon"
Remove it and you will check all .ico files lose their icon.

Shutdown in ms-dos mode as said above.

Run scanreg /FIX
With scanreg /RESTORE you may lose your last modifications.
I just do the test and have my icons back.
Happy ;-)

Longbow
0
 
rcm9445Commented:
When did this happen?
You could try a scanreg /restore and see if it fixes it.
Go to start->shutdown->restart in ms-dos mode.
At the dos prompt type scanreg /restore,
Select a date that the icons were opening properly and reboot.
It basically restores the registry back to that date.
0
 
LongbowCommented:
Hi Gary56,

Uninstall MicroAngelo to know if your system is back
 to the original state.

Or open Windows Explorer
Menu View Then click Folder Options
Go in the File Type Tab
Search for the word "icon"
Remove it and you are no more able to open them with
 Micro Angelo.

Oups, forget it for now.
Just tried it and have no more icons for my .ico files
 :-(((

Trying to come back to the previous state...

Longbow
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
mgrattanCommented:
Download the TweakUI utility from Microsoft's web site and run it.  On the Repair tab, select the Rebuild Icons option and click the Repair Now button.  Done!
0
 
DragonSlayerCommented:
Hi Gary, perhaps you could check this out.

Start your registry editor (Start -> Run -> Regedit)

Open the key

HKEY_CLASSES_ROOT\icofile\DefaultIcon

Make sure the (Default) entry for this key is %1

If it is not, then replace it with %1


PS: Please back up your registry first.
0
 
Gary56Author Commented:
Hello Longbow & thank you!! This did indeed lead me to a solution, Thank You. Gary
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.