problem with CD drive

Posted on 2001-08-11
Last Modified: 2013-12-28
I have just upgraded my system from a 166 to a 800 and now whenever I go into Windows it will not detect my CD drive. When in DOS it detects it fine and even worked when I installed WIN 98, however when I was close to the end of the installation and entering the GUI for the 1 time and it begins to load up device drivers the CD drive disappeared and so I could not install the drivers. I have checked in My Computer and it does not show up there either.

The CD drive is set as slave and my HDD as master. The system worked fine before the upgrade and I am using a standard CD drive, not a CDRW.

Any Ideas??
Question by:comdisk
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +5
LVL 63

Accepted Solution

SysExpert earned 200 total points
ID: 6376189
Windows does nor require special drivers for CD's of any kind.

It will cause problems if you loaded DOS drivers.

1) Rename both the autoexec.bat and config.sys and see if this solves the problem.

2) If not, try to download the newest IDE drivers for your specific motherboard.

I hope this helps !
LVL 10

Expert Comment

ID: 6376322
I would first comeup in safemode (hold F8 down when starting too boot up) and then select #3 and come up in safemode. Right-click my computer and go too properties, then device manager. Delete any cd-roms you have here, also check other devices, are your secondary and primary controllers loaded properly etc. Delete any ghost items and reboot. It sounds like either you have a controller driver problem or a little crash occurred and you have more then one cd-rom trying too load and the resultant is none will load. :>) Dave
LVL 14

Expert Comment

by:Don Thomson
ID: 6376353
If you just upgraded your MB  - Which you would have to do to go from a 166 P1 to a PIII   then you need to boot into safe mode and go into the device manager.   Delete all item that can be delete - especially things that are duplicated.  When changing MB  I run thru the entire device manager and delete everything that it will let me delete. Then on regualr reboot - if finds all the neat P&P devices.  Make sure you load the device drivers that came with your MB first  -
Creating Instructional Tutorials  

For Any Use & On Any Platform

Contextual Guidance at the moment of need helps your employees/users adopt software o& achieve even the most complex tasks instantly. Boost knowledge retention, software adoption & employee engagement with easy solution.

LVL 30

Expert Comment

ID: 6376445
I faced such a problem when using DOS 6.22 then upgrading to Installing win98.
If CD Drive is not recognised, in the final stages of windows installation, try to add the commands for the CD drive in config.sys and autoexec.bat
Start in command prompt only
When in command prompt only: you have

You can copy from Dos files to win98 1 files then restart your computer and continue the installation.

Good luck!

Expert Comment

ID: 6376448
dos 6.22 and winders 98 don't mix
LVL 10

Expert Comment

ID: 6376455
You should also run msconfig and make sure you don't have the lines in Dos too load this, as its a waste of resources, the two files would be config.sys and autoexec.bat to look at. Dave

Expert Comment

ID: 6376461
you may also have to remove any registry based items as well related to name of the cdrom .sys file for example nec1600.sys is the cdrom driver sometimes in an upgrade and change of IDE controllers it has a different value associated with the key.  May have to do this as well

LVL 30

Expert Comment

ID: 6376463
I have Both DOS 6.22 and win98 on the same machine!  The boot menu shows another command called Old version of Dos. However, what I suggested is what I tried and worked fine for me.  (Dos6.22 + Win98SE) & (Dos6.22 and Win98)
LVL 25

Expert Comment

ID: 6376802
Condisk, it's entirely possible that machine is running in MS-DOS Compatibility Mode due to the age of the machine, eg: what is now considered legacy equipment. Here's an article that may help you.


Expert Comment

ID: 6377165
if you have ide controller conflicts (see emery800's 1st comment) you could try this quick fix (works most of the time).
go to start - run & type fdisk /mbr (space after fdisk)then click OK. reboot the machine & see if the conflict is gone.
if not go to start - run & type regedit then click OK
click on edit - find & type noide then click on find next button. delete any noide entries found & reboot.

Expert Comment

ID: 6377168
another thing to try is to put the CDrom on the secondary controller

Featured Post

Enroll in May's Course of the Month

May’s Course of the Month is now available! Experts Exchange’s Premium Members and Team Accounts have access to a complimentary course each month as part of their membership—an extra way to increase training and boost professional development.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A project that enables an administrator to perform actions within a user session context not just at the time of login but any time later on day(s) or week(s) later.
Determining the an SCCM package name from the Package ID
As developers, we are not limited to the functions provided by the VBA language. In addition, we can call the functions that are part of the Windows operating system. These functions are part of the Windows API (Application Programming Interface). U…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question