Solved

Respawning too fast error after Redhat 7.1 install

Posted on 2001-08-14
4
386 Views
Last Modified: 2013-12-15
I just installed Redhat 7.1 on my laptop.  Here are the laptop specs:
Dell Latitude CPx
Video Card: ATI Technologies Inc. RAGE P/M Mobility AGP 2x
Monitor I'm using: ViewSonic GS771
NIC: Intel Pro/100 SR Mobile Combo Adapter

After the install I rebooted the computer and the screen flashes a few times and takes me to a loging prompt.  After a few minutes I get this message,
INIT: Id "x" respawning too fast: disabled for 5 minutes.

I figured this had something to do with my video card/monitor.  I then tried changing monitors but that didn't help.  I then tried going into Xconfigurator and changing video card/monitor settings, but that did not help.  

I'm fairly new to Linux so if any of you have any ideas, please provide detailed steps for things I could try.  

thanks


0
Comment
Question by:jcollins1
4 Comments
 
LVL 2

Accepted Solution

by:
olidel earned 100 total points
ID: 6391308
Hi,

   It looks like that when you try to start X, it doesn't work. In your /etc/inittab you probably set your default running level at 5, That means that the init daemon is trying to run X but it cannot because the video driver is not working and it retries every 5 minutes. So I advice you to reconfigure your /etc/inittab with the runlevel 3 (you should find a line similar to this : "id:5:initdefault", just replace 5 by 3)   so you will be able to boot normaly without this message. After that you can configure your video card from the command line and when you will be OK with the video card you will be able to swith back to runlevel 5.

Hope this help.

Bye
0
 
LVL 2

Expert Comment

by:ifincham
ID: 6392207
Hi,

You could also hit ctl-x at the graphical boot screen and type 'linux 3' at the boot: prompt so it looks like :

boot: linux 3

then press enter and it should stop at run-level three.

In the inittab file there will be a line something like :

x:5:respawn:/etc/X11/prefdm -nodaemon

If you're using gnome it probably points to gdm (kde - kdm or even xdm). You may need to find the process-id file and delete it - e.g. /var/run/gdm.pid . If its still there the system thinks its already running.

Rgds
0
 
LVL 5

Expert Comment

by:paulqna
ID: 6392625
You might also want to look for any UNIX domain sockets under the /tmp directory and /var. You can use the command command: 'find /tmp /var -type s -ls' to look for them.

You'll normally find a couple of them under /var for things like the printer (might also be under /dev) and gpmctl (console mouse and cut/paste support) as well as one or two sockets for your X server(s). Those would normally be in the /tmp/.X11-unix/ directory and be named X0, X1, etc. (If you've never run multiple concurrent X sessions then you'll only see X0 under there).

You probably don't have to do anything with those sockets. However, it might make sense to blow away the one's under /tmp. X will (re-)create those as necessary.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 6397078
I've seen several X related problems immediately after a 7.1 install, which I attribute to the 'as shipped' version of Xconfigurator. In all cases so far, it appeared that X was properly configured during installation but the X server would fail when the system rebooted after the install.

When I install a RedHat system I never configure X during the install, but rather wait until the system is up and I've applied all of the applicable RedHat updates. In the case of 7.1 those happen to include an updated version of Xconfigurator. So far updating the system and configuring X, post-install, has worked every time.

To fix your problem I'd recommend that you edit /etc/inittab and comment out the prefdm line that spawns X (run level 5 and typically the last line in the file). Well that or take the system to runlevel 3 with 'init 3'. The get and apply all applicable updates with 'rpm -F some update' and re-configure X with the new Xconfigurator.
0

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Daily system administration tasks often require administrators to connect remote systems. But allowing these remote systems to accept passwords makes these systems vulnerable to the risk of brute-force password guessing attacks. Furthermore there ar…
I am a long time windows user and for me it is normal to have spaces in directory and file names. Changing to Linux I found myself frustrated when I moved my windows data over to my new Linux computer. The problem occurs when at the command line.…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…

823 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question