?
Solved

100MB network collisions

Posted on 2001-08-15
5
Medium Priority
?
262 Views
Last Modified: 2013-12-23
Hi,

I have a 100mb hub with 2 machines connected to it. They're both on 100mb full-duplex - other one is 3Com Fast Etherlink and the other is an Intel EtherExpress.

The other machine is Win98SE and other is FreeBSD-4.3-STABLE. The problem is that whenever I try to transfer anything from one machine to other, it only flashes collision light and only 10k/sec data is transferred at max.

Any basical hints for this?

     ~/Acidia
0
Comment
Question by:acidia
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 40

Accepted Solution

by:
jlevie earned 300 total points
ID: 6397148
You've got a link speed/mode negotiation problem, which is quite common with some of the lessor expensive hubs. With a 100Mbps hub you'll need to ensure that both systems are using 100Mbps half-duplex (hubs can't do full-duplex, only switches can do that AFAIK). On the FreeBSD box you can use ifconfig to set the port speed and mode and the driver tab on windows should have an option for setting speed/mode.
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 6397382
listening ..
0
 

Author Comment

by:acidia
ID: 6403525
Thanks - that must be the reason (since it autodetects itself to full, and it works via cross-over _FAST_) - but how to set to half-duplex?

I've tried this :
ifconfig fxp0 media 100baseTX mediaopt half-duplex

but it says :
ifconfig SIOCSIFMEDIA: Device not configured

But it sure is configured ... :
ifconfig -au :
fxp: flags .....
inet 192.168.1.3 netmask ... blah blah

It's there...

0
 
LVL 40

Expert Comment

by:jlevie
ID: 6404388
To set an Intel ExpressPro Nic to 100Mbps HDX use:

ifconfig fxp0 media 100baseTX

You'd only include a mediaopt argument if you were trying to set FDX on an interface that was running in HDX mode. Although there'd be no ereason to do so in your case, the manpage for that NIC (man fxp) will show you all of the permissible settings.
0
 

Author Comment

by:acidia
ID: 6408819

Thanks - I'll put this as an answer since I think this is the problem. I can't seem to get those to go half-duplex, but they work via cross-over with full so that _has_ to be the problem.

I'll get a switch darnit :).

(btw I have another question about NIC's in BSD - I'll put it in the same group as this, and I think you could answer it also so please check :))

   ~/A
0

Featured Post

Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Make the most of your online learning experience.
This article explains the fundamentals of industrial networking which ultimately is the backbone network which is providing communications for process devices like robots and other not so interesting stuff.
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
Suggested Courses

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question