Solved

Error processing object when trying to add global group to local PC group

Posted on 2001-08-15
17
213 Views
Last Modified: 2010-04-13
Help: I am trying to give a user local administrtive rights to his PCs.
They are running Win2K Pro and are logging into a Win2K AS server SP2
I created a Global Security Group on the server called WksAdmin as called for in MS article# Q125782.
I added the User IDs in question to this group.

The problem occurs when I log into the workstation PC as Adminsitrator to add the WksAdmin Global Group to the local PCs Administrator group.

I get the following error message:
"Processing of Object WksAdmin failed for the following reason: The specified Domain either does not exist or could not be contacted."

The PC is on the same network as the Win2K AS server which is the Domain Controller. My users are able to successfully login to the Domain from the PC as well.

Why is this happening and/or what am I doing wrong?

Thanks,

Claude H.
0
Comment
Question by:claude4
  • 5
  • 4
  • 4
  • +3
17 Comments
 
LVL 1

Expert Comment

by:mdavisjr
ID: 6389296
I usually just go Administrative Tools-Computer Management, users and groups.
Then go to groups, Administrators and add the person who will be using the machine to the local administrators group.
0
 
LVL 1

Expert Comment

by:mdavisjr
ID: 6389311
Oh, and what you need to do is login as a Domain Admin to the domain in order to add the global group in to the local Administrators group.  Domain admins automatically have Administrator privileges on machines.  You're logging in to the machine as Administrator, but you're not logging into the domain...so it's not finding the domain.
0
 

Author Comment

by:claude4
ID: 6389382
Hi, Actually I did log into the domain as the Domain Adminsitrator on the local PC in question and get the error I defines above when I try to add the global group to the local administrators group.

Help, Thanks

Claude H.
0
 
LVL 10

Expert Comment

by:Longbow
ID: 6389507
Hi,

Remove the computer from the domain and add it again.
Is SP2 installed ? It may perhaps fixe this.

Hope it helps.

Longbow
0
 
LVL 1

Expert Comment

by:mdavisjr
ID: 6389715
Hmm, SP2 could possibly fix it...it's strange that it's saying it can't find the domain though...otherwise I'd think that you setup the group wrong somehow.
0
 

Author Comment

by:claude4
ID: 6389767
SP2 is installed on the win2k AS server but not on the local PC, I will apply it there and see what happens.

I will also try removing the PC from the domain  by deleting it from the Active Directory Users and Computers tool and then re joining it. That 2 may work.

I believe that I am doing the groups correctly, I suspect its one of those tough to resolve, "under the hood" issues.

Any other ideas?
0
 

Author Comment

by:claude4
ID: 6448724
Sorry for the long delay in getting back. I tried removing the computer from the domain, deleting the reference to the copmputer in the Win2K AS's Active Directory of Computers & Users then rejoined the PC to the domian. The results where the same when I tried to add it the local Administrators group to any global group.

Yet the PC can see and userts can login to the domain just fine.

Claude H.
0
 
LVL 10

Expert Comment

by:Longbow
ID: 6463172
If it is solved for you wich answer is the correct one ?
0
Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 
LVL 1

Expert Comment

by:mdavisjr
ID: 6464250
No, you misunderstand...he's saying that the problem is still there.  The users could always login to the domain, it's just giving them the error:  
"Processing of Object WksAdmin failed for the following reason: The specified Domain either does not exist or could not be contacted."
0
 

Author Comment

by:claude4
ID: 6464304
Yes, I am still having the problem as I described initially above.

Thanks for trying to help.

Claude H.
0
 
LVL 10

Expert Comment

by:Longbow
ID: 6464318
Thanks mdavisir
I really misunderstood :-(
Nobody perfect ;-)
0
 
LVL 5

Expert Comment

by:cempasha
ID: 8444446
Hi claude4
This question is still open and needs to be closed. If any of the comments above helped you, please accept it as an answer. If not please send an update about your issue so that the question can be finalised. Thank you

*** PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER ***

Pasha

Cleanup Volunteer
0
 
LVL 1

Expert Comment

by:netwiz562
ID: 8860050
------CLEAN UP------

No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:

RECOMMENDATION: Delete/Refund

Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

Rajiv Makhijani
EE Cleanup Volunteer
0
 
LVL 10

Expert Comment

by:Longbow
ID: 8911440
No comment
0
 

Accepted Solution

by:
claude4 earned 0 total points
ID: 8924815
Hi,

2 years later and this is still open. My apologies for not closing this myself. I was able to determine the cause of the error on my own, wuite some time ago. In short I had to make sure the Win2K server DNS was properly setup to be "Integrated" with the Active Directory, once that was done in the DNS services management applet, I was able to set the preferred DNS server in each of my work stations to the IP address of the server, the 2nd & 3rd DNS IP addresses wehre set to external (INternet) DNS servers and voila, I was able to add the Global security group WKSAdmin: to each PCs local Administrators group giving the user administrative rights to their respective PCs and keep the domain secure.

Asked and ansewed.

Now if only I know how to close this out?

Can the moderator help.

Thanks all,

CLaude H.
0
 

Expert Comment

by:rigathor
ID: 9495697
Hi all, I've just found a second cause for this problem that I thought I'd post for posterity.

I had a Win2k SP3 server with the same symptoms.  When I ran IPCONFIG /ALL the "DNS Suffix Search List" section was missing.  I knew from a previous issue that this was because the DHCP client service was disabled - apparently it ties in with the DNS client in Win2k.  So once again the cause was DNS issues but on the client this time.

Solution was to start and stop the DHCP client service.  The "DNS Suffix Search List" section immediately re-appeared (which helps a lot with name resolution) and I was able to add groups and users through the GUI again (previously had to use "net localgroup" from the command line - maybe it just uses WINS).

Hope this helps someone sometime.

Cheers,
Ricgathor.
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
Moving applications to the cloud or switching services to cloud-based ones, is a stressful job.  Here's how you can make it easier.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now