Solved

Why does'nt know my nameserver his own name ?

Posted on 2001-08-15
15
214 Views
Last Modified: 2010-03-18
I have a named server 8.2.3 on linux 7.0 running. It is for my small local network and its works fine,but just when i make nslookup (on a client) i got the error message "can't find servername for 192.168.1.100" it's the ip of my server. His name is also written in his /etc/hosts. The /etc/named.conf looks like foolow :

  // Config file for caching only name server   options {
          directory "/var/named";           // Uncommenting this might help if you have to go through a
          // firewall and things are not working out:           // query-source port 53;
  };   zone "." {
          type hint;
          file "root.hints";
  };   zone "0.0.127.in-addr.arpa" {
          type master;
          file "pz/127.0.0";
  };

Whats wrong ?
0
Comment
Question by:DennisWood
15 Comments
 
LVL 17

Expert Comment

by:dorward
Comment Utility
I don't know anything about nameservers, but I do want to point out that Linux is currently up to version 2.4.8 - presumably you mean Red Hat 7.0?
0
 

Author Comment

by:DennisWood
Comment Utility
sorry suse 7.0 with kernel 2.2.16
0
 
LVL 51

Expert Comment

by:ahoffmann
Comment Utility
you're missing in named.conf:

zone "192.168.1.100.in-addr.arpa"

and the corresponding zone for your domain, like

zone "your.dom"
0
 

Author Comment

by:DennisWood
Comment Utility
sorry that it took so long but i didn't get an emailnotification.What do i have to set for options for the two zones ? Can i make in the zone "my.dom" entries for the hosts under this domain ? Like libre.my.dom and www.my.dom ? Where libre is in the local network and www.my.dom is outside ?
0
 
LVL 51

Expert Comment

by:ahoffmann
Comment Utility
libre.my.dom with type master and www.my.dom with type slave. In options section you need a forwarders = { IP-address; } .
0
 

Author Comment

by:DennisWood
Comment Utility
sorry, i don't understand this ?
0
 

Author Comment

by:DennisWood
Comment Utility
the name of the nameserver (192.168.1.100) should be i586.ennis.de, the name of the machine in lan (192.168.1.3) should be libre and the machine on internet www.ennis.de with ip 195.20.225.8.
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 51

Expert Comment

by:ahoffmann
Comment Utility
options {
        forwarders = { IP-of-server-to-get-www.my.dom-from; };
        # .. your options here
};

# .. your other zones here

zone "libre.my.dom" {
        type master;
        file "db.libre.my.dom";
};
zone "www.my.dom" {
        type slave;
        file "db.www.my.dom";
};

# assuming 192.168.1.0/24 as libre.my.dom
zone "1.168.192.in-addr-arpa" {
        type master;
        file "db.192.168.1";
};
# assuming xxx.yyy.zzz.0/24 as libre.my.dom
zone "zzz.yyy.xxx.in-addr-arpa" {
        type slave;
        file "db.xxx.yyy.zzz";
};
0
 

Author Comment

by:DennisWood
Comment Utility
thanx a lot, know my localnetwork works. The last problem is i don't know the nameserver to get www.ennis.de, so i don't know the forward ip. Could i just put there the ip of a namesserver in root.hints ? Additional i don't know what to write into db.www.my.dom. Isn't it enough if i have a forward ip to write there forward only instead of file "db.www.my.dom" ?
0
 

Author Comment

by:DennisWood
Comment Utility
or is there a way to tell in the db.my.dom to look up all hosts that not listed here to look up with the help of other nameservers (in roots.hints ) ?
0
 
LVL 51

Expert Comment

by:ahoffmann
Comment Utility
you need to use any IP of a DNS server which knows about www.my.dom. You might use a "namesserver in root.hints", but that's not wise, better you use the primary DNS for www.my.dom (usualy a ISP).
0
 

Author Comment

by:DennisWood
Comment Utility
I don't know where to write the ip. i've taken the ip of the dns of my ips. i've written it :
1.)
- under options forwarders { ISP-DNS-IP ; }
- zone "www.my.dom" in {
   type slave;
   forward only;
  }
2.)
- zone "www.my.dom" in {
   type slave;
   file "db.www.my.dom";
  }
- in db.www.my.dom
  IN NS ISP-DNS-IP

On a nslookup www.my.dom i got always the errormessage "www.my.dom no exitent host/domain". Whats up ?
0
 
LVL 51

Accepted Solution

by:
ahoffmann earned 300 total points
Comment Utility
who is primary DNS for www.my.dom? your ISP or you yourself? You ISP must know this.
0
 

Author Comment

by:DennisWood
Comment Utility
from my ISP i got the IP 145.253.2.11., when i dial in, but i think there something wrong here is my config :
libre.ennis.de : Host in LAN
i586.ennis.de  : DNS for LAN
www.ennis.de   : Host in LAN

/etc/named.conf :
  options {
          directory "/var/named";
          forwarders { 145.253.2.11 ; };
  };   zone "." {
          type hint;
          file "root.hints";
  };   zone "0.0.127.in-addr.arpa" {
          type master;
          file "pz/127.0.0";
  };   zone "1.168.192.in-addr.arpa" in {
          type master;
         file "192.168.1.zone";
  };
  zone "www.ennis.de" in {
       type slave;
#       masters { 145.253.2.11 ; };
#       file "www.ennis.de.zone";
       forward only;
  };   zone "ennis.de" in {
          type master;
          file "ennis.zone";
}

ennis.zone : (works fine)
$TTL 2D
ennis.de.IN SOAtest   root.localhost (
1999092901; serial (d. adams)
1D; refresh
2H; retry
1W; expiry
2D ); minimum IN NSi586 i586IN A192.168.1.1
IN A192.168.1.100
libreIN A192.168.1.3
ftp             IN A            195.20.225.8
www             IN A            195.20.225.8

www.ennis.de.zone :
$TTL 2D
www.ennis.de.IN SOAtest   root.localhost (
1999092901; serial (d. adams)
1D; refresh
2H; retry
1W; expiry
2D ); minimum
IN NS 145.253.2.11
0
 
LVL 16

Expert Comment

by:The--Captain
Comment Utility
If you're running your nameserver properly, and your ISP isn't a bunch of filtering morons, you shouldn't need a 'forwarders' line.

Remove it, and give it a try.

BTW, you don't need another zone for www.ennis.de, unless you plan to add subdomains to www.ennis.de (i.e. subdomain.www.ennis.de).  Just make www.ennis.de an A entry in the ennis.de zone file.

Then go read the BOG (Bind Operator's Guide) and O'Reilly's DNS/BIND - all will be explained.

-Jon

0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Join & Write a Comment

Suggested Solutions

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now