Solved

SUN login problem

Posted on 2001-08-15
16
579 Views
Last Modified: 2013-12-27
Hi

I have a problem login to my SUN server. Whenever, I login, i get the following message:
login: login account failure: Permision denied

I am sure that my password is correct. Resetting my password doesn't work either from root.

I'm using Solaris 7.

Thanks

0
Comment
Question by:joekwchen
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
  • +7
16 Comments
 
LVL 1

Expert Comment

by:kawin
ID: 6391420
Hi,
   Are you problem occur on all user or only your user?

   Are you try "admintool" to check your account setting?

   Are you check permission of home directory of your account?

   If problem occur on your user please check content on your login in file /etc/shadow and /etc/password. It have something extra?

Kawin.
0
 
LVL 38

Expert Comment

by:yuzh
ID: 6391431
Hi  joekwchen,

     Are you runing NIS+? or the Server configured as a stand alone system.

     please check the permission of you home whatever Kawin tell you
to check.
0
 

Author Comment

by:joekwchen
ID: 6395598
Hi all,

The problem only occur on some user. As i don't have admintool as i down have openwin, how do i check. From what i see, the passwd and shadow is OK.

it seems that i have to remove the ID and recreate back then only i can login.

PLs advise. Izit something to do with pam configuration.

tqvm.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 5

Expert Comment

by:paulqna
ID: 6397074
Try to update security databases with "pwconv"... (can be made undone with "pwunconv".
0
 
LVL 1

Expert Comment

by:k.kidambi
ID: 6397207
Do you have any kind of security (like kerberos / pam etc) enabled on this box. what you can do is comment out the entries of the loginId's who has the problem and copy the same ID and then set a new password. As told by Kawin if you have any extra charecters or blank spaces in /etc/passwd or /etc/shadow files can cause the problem or if you are using security stuff you need to check your security configurations.

Post your comments here.

Kidambi
0
 
LVL 8

Expert Comment

by:akeh
ID: 6414410
You can run "pwck" to check that the /etc/passwd is correct.
0
 

Author Comment

by:joekwchen
ID: 6427249
Have tried pwck,pwconv but still the same. I don't use kerberos. I think i used pam (izit by default) but what is the statement to lookout for and where is the file?

Many Thanks
0
 
LVL 5

Expert Comment

by:paulqna
ID: 6428343
Does the user has read/execute permissions on his home directory?
0
 
LVL 2

Expert Comment

by:jonke
ID: 6456979
Does this happen if you are logged into the box already and you su - to the user, or only when logging in remotely?

0
 
LVL 1

Expert Comment

by:msnr
ID: 6460202
IF you have nis settup,
ask the user to login with oldpassword.

cheque the slave name in nis sever, if you are not using broadcast mode.

0
 

Author Comment

by:joekwchen
ID: 6462793
Hi,
msnr, I don't have nis installed

jonke, I did not use su to the user, it is just a simple logon (either thru console or telnet).

paulgna, yes the user has read/write permission.

Thanks a lot.

Hope to here more opinion.
0
 
LVL 2

Expert Comment

by:jonke
ID: 6463360
But do you get the error when you log in as root and su - to the user? DO you get the same error?
0
 
LVL 2

Expert Comment

by:khaled022498
ID: 6622111
- Check that you have created a defualt directory for this user

- Check Premissions on your home directory to be (+r +w +x)

- Check that you have permission on execute your shell.
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 6622358
listening ..
0
 

Author Comment

by:joekwchen
ID: 6623581
Hi all,

Regarding the problem above, it seems that when i type the following command, the user can login again.
usermod -f 0 -l xxx

I suspect when the account is created, the user never logon for a period of time. What does -f 0 means? Does it means by setting to zero, the account will never get inactive?

tqvm.
0
 
LVL 1

Accepted Solution

by:
msnr earned 100 total points
ID: 6623798
f0 means, account will not be deactivated...
its active forever even he doesnt change password.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

My previous tech tip, Installing the Solaris OS From the Flash Archive On a Tape (http://www.experts-exchange.com/articles/OS/Unix/Solaris/Installing-the-Solaris-OS-From-the-Flash-Archive-on-a-Tape.html), discussed installing the Solaris Operating S…
Introduction Regular patching is part of a system administrator's tasks. However, many patches require that the system be in single-user mode before they can be installed. A cluster patch in particular can take quite a while to apply if the machine…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question