Solved

How do I stop separate DHCP service offering IPs to the wrong clients ?

Posted on 2001-08-16
11
234 Views
Last Modified: 2010-05-18
Bit of a bizarre one this so here goes:

Main network in the office has a DHCP server offering IP's etc to all clients. No problem.

We have a Norton Ghost server that is connected to the office LAN on the first NIC card and gets its IP address from the Office address space.  

The Ghost server also has a secondary NIC card which is connected to a hub, and the prospective ghost clients are also connected to that hub, to create a separate LAN.

Now, the Ghost Server is running DHCP on a different IP range, so that any ghost clients connected to the hub automatically receive an IP address from the Ghost Server, so we can multicast images etc..

The problem is, when office clients ask for a new IP address, occasionally the Ghost Server is quickest to respond and so the office client ends up with an IP address which is in the wrong range and therefore breaks... SO...

How can I configure the Ghost Server DHCP, to only give out IP addresses to clients that have requested them on the second NIC card ?  -- Is is possible to bind the DHCP client to a particular NIC card ?

Any suggestions gratefully received!
0
Comment
Question by:grayp1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
11 Comments
 
LVL 1

Expert Comment

by:JconleyMCSE
ID: 6392986
Listening....
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 6393088
I think that you need to disable the DHCP  server stuff on the first NIC and leave it on the second only.

You may need to switch the order of the NICs since ghost may default to using the first.

I would also check the symantec site's knowledge base !

I hope this helps !
0
 
LVL 5

Expert Comment

by:vsamtani
ID: 6393160
Why is the ghost server machine connected to the main office LAN at all?

If it's only so it can get an IP address, you would be better off setting a static IP address on the ghost server and then disconnecting it from the office lan completely.

I suspect that I'm missing something, though. More detail would help.

Vijay
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 

Author Comment

by:grayp1
ID: 6393462
Thanks to all who've replied so far!

To fill in the gaps:
The first NIC card is connected to the Office Lan so we can access the Internet for drivers and the like, plus copy files from the servers to the newly ghosted machines.

At the moment we're just disconnecting the Office lan from the 1st NIC card, which obviously solves the problem, but if there is a way of having the two networks joined without DHCP problems, then thats what i'd prefer.. (lazy..;))
0
 
LVL 17

Expert Comment

by:mikecr
ID: 6393605
Your basically screwed. I believe you will not be able to get around this. DHCP runs as a service on NT and binds to all network adapters located in it. If you were running Windows 2K you can go into the properties of the scope and bind it to the IP of a specific interface but you cannot do that on an NT machine as it is not supported. The only way I can think of to do this would be to put some type of router in between it and the network and have it drop the DHCP acks that it passes.
0
 

Author Comment

by:grayp1
ID: 6393807

Thanks Mikecr.. It is running Windows2k (sorry for not mentioning earlier)

I checked the Properties for the Scope and its binding to Local Connection 2, which is correct.. so why is it servicing requests for Local Connection 1 ??

0
 
LVL 17

Expert Comment

by:mikecr
ID: 6393832
Are both of the boxes checked currently in there or just for the IP of your set up network?
0
 

Author Comment

by:grayp1
ID: 6393840

just the one box, with the IP address of the network.
0
 
LVL 17

Accepted Solution

by:
mikecr earned 100 total points
ID: 6393862
Since it is showing a local area connection and not an IP address, this is probably why. Assign a static IP to the NIC on the setup network for the same subnet that you are passing DHCP on. It sounds like what is happening is that both NICs in this box are set up for DHCP. They are getting an IP address from your regular network on both of them. Since these IP's are in the same subnet, the DHCP broadcasts are making it to your server and it is servicing the requests. By changing the IP address of the NIC on the setup network, you can bind to that subnet the DHCP traffic and not send it out over the whole network.
0
 

Author Comment

by:grayp1
ID: 6396621
Thanks Mikecr.
0
 
LVL 17

Expert Comment

by:mikecr
ID: 6396766
No problem....
0

Featured Post

Don't Cry: How Liquid Web is Ensuring Security

WannaCry is just the start. Read how Liquid Web is protecting itself and its customers against new threats.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will inform Clients about common and important expectations from the freelancers (Experts) who are looking at your Gig.
This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Suggested Courses
Course of the Month9 days, 7 hours left to enroll

624 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question