Solved

New joystick for RedHat Linux 7.0 not working....

Posted on 2001-08-16
2
490 Views
Last Modified: 2013-12-15
Hi,

I have an new intel RedHat Linux 7.0 system and a soundcard in it. I am not able to use the sound card or my new joystick. I am sure that the drivers aren't set properly for these devices.

My joystick is a Logitech Wingman Extreme Digital 3D. My sound card (I think) is a SB Live!.

I have already tried to rebuild the RedHat kernel with drivers enabled for these devices. That doesn't seem to have any effect.

What steps should I take to get the joystick working?

Where can I find the drivers required for this joystick for the RedHat 7.0 system?

Thanks in advance!
0
Comment
Question by:baigmz
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
2 Comments
 
LVL 2

Expert Comment

by:ifincham
ID: 6395902
Hi,

Have you tried using the config utilities in the redhat joystick rpm ? This is where to find the rpm if you don't have it to hand --> http://www.mirror.ac.uk/sites/ftp.redhat.com/pub/redhat/linux/7.0/en/os/i386/RedHat/RPMS/joystick-1.2.15-5.i386.rpm

Redhat has got a module called joy-logitech which is for logitech joysticks (although maybe not all ?).

Rgds
0
 
LVL 2

Accepted Solution

by:
ifincham earned 100 total points
ID: 6396778
Hi,

Just a bit more detail if you don't get anywhere with the joystick rpm..

A first joystick would use /dev/input/js0 (aka /dev/js0 via a soft link).

You may have to create the device files 'by hand' :

cd /dev
mkdir input                    (if /dev/input directory does not exist)
mknod input/js0 c 13 0         (make char13 device node /dev/input/js0)
ls -s input/js0 js0            (make link to it as /dev/js0)

Then you need to load the necessary modules :

/sbin/modprobe joydev         (joystick support module - may already be compiled into kernel)
/sbin/modprobe ns558          (assuming on game port)
/sbin/modprobe adi            (actual logitech driver

You could try to make them load on demand by adding the following to /etc/modules.conf

alias char-major-13 joydev ns558 adi

See also --> http://www.suse.cz/development/input/index.html

For the audio, try to do 'cat /proc/pci' and that should tell you whats attached to the pci bus - i.e. to identify your card more accurately. Then have a look at --> http://www.alsa-project.org .

Rgds

0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
The purpose of this article is to demonstrate how we can use conditional statements using Python.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question