Solved

CRPEngine&CRPEJob can't talk to Informix v9.21

Posted on 2001-08-16
4
263 Views
Last Modified: 2010-08-05
Hi folks,
I am using seagate crystal report v7.0
Please read the folloing code:

crpEngine->Open();
/* assuming I have a correct info in logoninfo struct */
crpEngine->LogOnServer("pdsodbc.dll", &logoninfo));

CRPEJob *job = crpEngine->OpenJob("C:\demo.rpt");
job -> start();  /* operation failed */
                 /* reason: cannot open SQL server */

<=================================================>
Above code works well with sybase and oracle. I does not work with Informix server. Did I miss anything???
0
Comment
Question by:zollen
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 12

Accepted Solution

by:
DRRYAN3 earned 300 total points
ID: 6394637
Try using PESetNthTableLogonInfo instead of LogOnServer.  I'm not a C programmer and cannot provide an example, but sometimes it is necessary to set the logon info for each table in the report.

DRRYAN3
0
 
LVL 12

Expert Comment

by:DRRYAN3
ID: 6434133
zollen

Did the suggestion work?  How about some feedback?

DRRYAN3
0
 
LVL 12

Expert Comment

by:DRRYAN3
ID: 6523832
This question has been open for some time now.  Please return and either
1.  Accept an answer
2.  Post a comment stating that you need more information
3.  Ask Community Support to delete the question if you feel the information here has no value to you or anyone else.
4.  Ask Community Support to PAQ the question because your question was not answered but you feel the information here may be of some value to others.

Community Support is here:  http://www.experts-exchange.com/jsp/qList.jsp?ta=commspt and you can leave a message by posting a zero point question.  Be sure to reference the question ID, found in the Address bar of your browser.

Thanks
DRRYAN3
0
 

Expert Comment

by:ComTech
ID: 6529269
Answer accepted by:

ComTech
Community Support Moderator
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hot fix for .Net Crystal Reports 10.2.3600.0 to fix problems with sub reports running on 64 bit operating systems ISSUE: Reports which contain subreports fail with error "Missing Parameter Value" DEPLOYMENT SERVER OS: Windows 2008 with 64 bi…
Hello everyone, Hope you find this as helpful as we did. We have on the company I work for an application built in Delphi V with Crystal Reports 8. We all know that Crystal & Delphi can be temperamental sometimes and the worst thing is, nearly…
Attackers love to prey on accounts that have privileges. Reducing privileged accounts and protecting privileged accounts therefore is paramount. Users, groups, and service accounts need to be protected to help protect the entire Active Directory …

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question