[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

Why does the Code Explorer ALWAYS open!

Posted on 2001-08-17
5
Medium Priority
?
290 Views
Last Modified: 2010-04-06
Even if I close the Code Explorer and/or undock it and/or kick the pc in fustration, the code explorer ALWAYS appears.

Even when I don't want it too.

For 10 whole points at Grade A, how the hell do I get rid of it!!!! (NOTE : To get the points, it has to stay gone when I reload Delphi).

Oh.

Using Delphi 5 (Build 6.18) Update Pack 1 on Win98SE (4.10.2222 A).

Regards,

Richard Quadling.
0
Comment
Question by:Richard Quadling
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 1

Expert Comment

by:pede
ID: 6397485
Tools/Environment options/Explorer :o) Check it out!

0
 
LVL 40

Author Comment

by:Richard Quadling
ID: 6397512
Nope!

None of the settings in the group "Explorer options" are checked.

Regards,

Richard.
0
 
LVL 1

Accepted Solution

by:
pede earned 40 total points
ID: 6397654
I removed mine that way. 'Automatically show explorer' is checked by default so it should be checked now, unless you removed it yourself. Try checking 'Automatically...' and close/open your source window, then uncheck it, and do the same thing again... Nothing else I can think of if this doesnt help.

0
 
LVL 40

Author Comment

by:Richard Quadling
ID: 6530060
I found the problem.

Somehow, the default for the state of the code explorer was saved in a default configuration which was loaded when Delphi loads (in the delphi/bin directory).

I always double-click a .DPR or a .BPG file.

Delphi then loads with the default of Code Explorer open. Then it loads the project. The config file for the project does NOT have any settings for the explorer and leaves it alone.

Even if I turn the explorer on, quit, reload, turn off explorer, save, quit, etc. No change.

Removing the default config file from Delphi/bin solved the trick!

0
 
LVL 40

Author Comment

by:Richard Quadling
ID: 6815980
Long time in coming!

Thanks.

Richard.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Have you ever had your Delphi form/application just hanging while waiting for data to load? This is the article to read if you want to learn some things about adding threads for data loading in the background. First, I'll setup a general applica…
In my programming career I have only very rarely run into situations where operator overloading would be of any use in my work.  Normally those situations involved math with either overly large numbers (hundreds of thousands of digits or accuracy re…
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question