• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 306
  • Last Modified:

XDM failing to start x session

I have a working X. I am trying to get xdm to play nice and failing.

XDM gives teh GUI login acts normal if i type the wrong password or UID. But if i use teh correct UID and Password the screen goes black then restarts the login GUI. Ever thing looks right. Any one have any idea on where to start the Debug, or have seen this befroe?
0
Barn_Owl
Asked:
Barn_Owl
1 Solution
 
xberryCommented:
Before we start our troubleshooting:

> GUI login acts normal if i type the wrong password or UID.

Does it give you it's 'normal' "Wrong password, authentication failed" message or does it literally give to undenied access to your account ?
Which, with a wrong password would indeed be quite unusual.
0
 
Barn_OwlAuthor Commented:
"Wrong password, authentication failed" was what i was getting. on a lark i set my xinitrc to excutable and it started working. I am not sure that that is really secure though.
0
 
xberryCommented:
> On a lark i set my xinitrc to executable

That's pretty standard !  The default for my /etc/X11/xinit/xinitrc.d
has always been set to '-rwxr-xr-x' .  
Since xinitrc is a scriptfile it has to be executable, don't you think so ?

> I am not sure that that is really secure though.

What are you afraid of ?  xinitrc isn't in any way related to your password settings. Actually 'xinitrc' is run via the file 'Xsession', which itself is only
executed AFTER a successful login authentication.

0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
Barn_OwlAuthor Commented:
I always get a little edge when setting a system file to excutable when i don;t know what i am doing :). As I don't use XDM for my logins normally and if you start an Xsession with startx command it has never been excutable before.
0
 
xberryCommented:
You have of course the choice to copy the global 'xinitrc' file & set it up
as local ~/.xinitrc file in your HOME directory. Local configuration files have priority against global settings when you run X. So you only need to set your local file executable. Thus you don't have to expose your global file to a possible risk.

 
0
 
CleanupPingCommented:
Barn_Owl:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
majorwooCommented:
PAQ'd and points refunded.

majorwoo
EE Page Editor
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now