Solved

Pls teach me how to configure for LAN networking !!!

Posted on 2001-08-20
15
333 Views
Last Modified: 2010-04-20
Hi experts,
(sorry, but I'm really very new to Linux)

I'm having a pc installed with Linux Redhat 7.1 (I supposed I'd installed all the Redhat packages which took up about 2.7GB of disk space).

I also have 2 NIC cards :-
(1) D-link DFE-550TX PCI Fast-Ethernet NIC
(2) D-link DGE-500SX PCI Gigabit-Ethernet NIC

and also a Cisco 5505 series switch with :-
(1) a 24 port Fast-Ethernet module
(2) a three port Gigabit-Ethernet module

Can expert(s) pls explain to me (pls give in details) how to step-by-step configure the drivers, setup the LAN connection for both the NIC cards.

Pls help (assume I'm a real Linux-dummy)

10 Q

0
Comment
Question by:shchong2
  • 8
  • 5
  • 2
15 Comments
 
LVL 17

Expert Comment

by:psimation
Comment Utility
It's really very simple, specially if you make sure that you have network cards that are supported by Linux by default. Most 3COM and Intel cards are supported as well as most of the Realtek chips.
Normally, the best indication that you have one of these supported ards are tha fact that KUDZU detects it at boot time right after you installed the cards in the system. At that time, you will also be able to configure the networking (IP, Netmask, gateway etc.). If you cards are not automatically deteted, there are various reasons for it, and it does not necessarily mean that the cards won't work. You might just need to load drivers and or configure manually. It might also be due to IRQ conflicts that the cards are not detected.
I will start with the IRQ's since this is the most probable and easiest to see.From your command line or a terminal window, issue the command: eth0      Link encap:Ethernet  HWaddr 00:A0:C9:67:2D:59  
inet addr:192.0.0.2  Bcast:192.0.0.63  Mask:255.255.255.192
UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
RX packets:45892 errors:0 dropped:0 overruns:0 frame:1
TX packets:47528 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
Interrupt:11
cat /proc/interruptsYou should now see a list of all devices on your system along with the IRQ it is using. If you don't see your card(s) here, or you see them and they are using the same irq as another, you can try to change the irq it's using by changing the irq for that pci slot in the BIOS or try moving the card to another slot.

Now, if you can't see your card in the list at all, it's possible you have a totally unsupported card, or even an ISA card (the old ones with the T-piece connector); if you have those cards, throw it away and buy a PCI card (trust me, save yourself the trouble of trying to configure it...) If you REALLY cannot go without the ISA card, post a comment and I'll give you the whole 10 000 000 wird setup instructions for those.

Now, If your lan cards are listed in cat /proc/interrupts but your networking is still not working, do the following.
Issue the following command; ifconfig

You should see something like this:
eth0      Link encap:Ethernet  HWaddr 00:A0:C9:67:2D:59  
          inet addr:192.0.0.2  Bcast:192.0.0.63  Mask:255.255.255.192
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:45892 errors:0 dropped:0 overruns:0 frame:1
          TX packets:47528 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          Interrupt:11

eth1      Link encap:Ethernet  HWaddr 0D:A0:D2:34:2D:91  
            inet addr:192.0.0.3  Bcast:192.0.0.63  Mask:255.255.255.192
           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
           RX packets:45892 errors:0 dropped:0 overruns:0 frame:1
          TX packets:47528 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          Interrupt:10

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4021 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4021 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0

You should note that your first LAN card is eth0 and the second one is eth1. If you cannot see any athx devices here, use "netconf" from a command line and configure the cards one by one. MAke sure that you tick the "enabled" box in the device tab, or tha card will not work by default.

After that, and a reboot to make sure all the gremlins are dead, you should already be able to ping other machines on the network on the same subnet as your machine.
If you want to link your Linux box to windows machines, you need to install SAMBA and configure it.
 
I have an entire section devoed to setting up samba on my website at www.linuxhelp.co.za, just follow the "networking" link, should have you sharing printers and files in no time...
0
 
LVL 17

Expert Comment

by:psimation
Comment Utility
It's really very simple, specially if you make sure that you have network cards that are supported by Linux by default. Most 3COM and Intel cards are supported as well as most of the Realtek chips.
Normally, the best indication that you have one of these supported ards are tha fact that KUDZU detects it at boot time right after you installed the cards in the system. At that time, you will also be able to configure the networking (IP, Netmask, gateway etc.). If you cards are not automatically deteted, there are various reasons for it, and it does not necessarily mean that the cards won't work. You might just need to load drivers and or configure manually. It might also be due to IRQ conflicts that the cards are not detected.
I will start with the IRQ's since this is the most probable and easiest to see.From your command line or a terminal window, issue the command: eth0      Link encap:Ethernet  HWaddr 00:A0:C9:67:2D:59  
inet addr:192.0.0.2  Bcast:192.0.0.63  Mask:255.255.255.192
UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
RX packets:45892 errors:0 dropped:0 overruns:0 frame:1
TX packets:47528 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
Interrupt:11
cat /proc/interruptsYou should now see a list of all devices on your system along with the IRQ it is using. If you don't see your card(s) here, or you see them and they are using the same irq as another, you can try to change the irq it's using by changing the irq for that pci slot in the BIOS or try moving the card to another slot.

Now, if you can't see your card in the list at all, it's possible you have a totally unsupported card, or even an ISA card (the old ones with the T-piece connector); if you have those cards, throw it away and buy a PCI card (trust me, save yourself the trouble of trying to configure it...) If you REALLY cannot go without the ISA card, post a comment and I'll give you the whole 10 000 000 wird setup instructions for those.

Now, If your lan cards are listed in cat /proc/interrupts but your networking is still not working, do the following.
Issue the following command; ifconfig

You should see something like this:
eth0      Link encap:Ethernet  HWaddr 00:A0:C9:67:2D:59  
          inet addr:192.0.0.2  Bcast:192.0.0.63  Mask:255.255.255.192
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:45892 errors:0 dropped:0 overruns:0 frame:1
          TX packets:47528 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          Interrupt:11

eth1      Link encap:Ethernet  HWaddr 0D:A0:D2:34:2D:91  
            inet addr:192.0.0.3  Bcast:192.0.0.63  Mask:255.255.255.192
           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
           RX packets:45892 errors:0 dropped:0 overruns:0 frame:1
          TX packets:47528 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          Interrupt:10

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4021 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4021 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0

You should note that your first LAN card is eth0 and the second one is eth1. If you cannot see any athx devices here, use "netconf" from a command line and configure the cards one by one. MAke sure that you tick the "enabled" box in the device tab, or tha card will not work by default.

After that, and a reboot to make sure all the gremlins are dead, you should already be able to ping other machines on the network on the same subnet as your machine.
If you want to link your Linux box to windows machines, you need to install SAMBA and configure it.
 
I have an entire section devoed to setting up samba on my website at www.linuxhelp.co.za, just follow the "networking" link, should have you sharing printers and files in no time...
0
 
LVL 17

Expert Comment

by:psimation
Comment Utility
My word!
Sorry about the double posting!
AND, sorry for just starting to answer the question without reading it properly! I only saw now that your cards are both PCI, BUT, your second one is a gigabit card.
Firstly, I have just checked on my 2.4.7 kernel, gigabit card driver support is disabled by default, and furthermore, I don't see any mention of that particular gigabit (nor the fast-etherlink) in the list of modules. It *might* mean that it is not supported by Linux yet, but I think your safest bet would be to check D-Link's website to see if they might not have drivers for those cards. It seems like even if you do get drivers, you might need to recompile or install a newer kernel on your pc. I also have a couple of things about compiling an installing kernel's on my website for incase you need to do it...
0
 
LVL 17

Accepted Solution

by:
psimation earned 300 total points
Comment Utility
It's really very simple, specially if you make sure that you have network cards that are supported by Linux by default. Most 3COM and Intel cards are supported as well as most of the Realtek chips.
Normally, the best indication that you have one of these supported ards are tha fact that KUDZU detects it at boot time right after you installed the cards in the system. At that time, you will also be able to configure the networking (IP, Netmask, gateway etc.). If you cards are not automatically deteted, there are various reasons for it, and it does not necessarily mean that the cards won't work. You might just need to load drivers and or configure manually. It might also be due to IRQ conflicts that the cards are not detected.
I will start with the IRQ's since this is the most probable and easiest to see.From your command line or a terminal window, issue the command: eth0      Link encap:Ethernet  HWaddr 00:A0:C9:67:2D:59  
inet addr:192.0.0.2  Bcast:192.0.0.63  Mask:255.255.255.192
UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
RX packets:45892 errors:0 dropped:0 overruns:0 frame:1
TX packets:47528 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
Interrupt:11
cat /proc/interruptsYou should now see a list of all devices on your system along with the IRQ it is using. If you don't see your card(s) here, or you see them and they are using the same irq as another, you can try to change the irq it's using by changing the irq for that pci slot in the BIOS or try moving the card to another slot.

Now, if you can't see your card in the list at all, it's possible you have a totally unsupported card, or even an ISA card (the old ones with the T-piece connector); if you have those cards, throw it away and buy a PCI card (trust me, save yourself the trouble of trying to configure it...) If you REALLY cannot go without the ISA card, post a comment and I'll give you the whole 10 000 000 wird setup instructions for those.

Now, If your lan cards are listed in cat /proc/interrupts but your networking is still not working, do the following.
Issue the following command; ifconfig

You should see something like this:
eth0      Link encap:Ethernet  HWaddr 00:A0:C9:67:2D:59  
          inet addr:192.0.0.2  Bcast:192.0.0.63  Mask:255.255.255.192
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:45892 errors:0 dropped:0 overruns:0 frame:1
          TX packets:47528 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          Interrupt:11

eth1      Link encap:Ethernet  HWaddr 0D:A0:D2:34:2D:91  
            inet addr:192.0.0.3  Bcast:192.0.0.63  Mask:255.255.255.192
           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
           RX packets:45892 errors:0 dropped:0 overruns:0 frame:1
          TX packets:47528 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          Interrupt:10

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4021 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4021 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0

You should note that your first LAN card is eth0 and the second one is eth1. If you cannot see any athx devices here, use "netconf" from a command line and configure the cards one by one. MAke sure that you tick the "enabled" box in the device tab, or tha card will not work by default.

After that, and a reboot to make sure all the gremlins are dead, you should already be able to ping other machines on the network on the same subnet as your machine.
If you want to link your Linux box to windows machines, you need to install SAMBA and configure it.
 
I have an entire section devoed to setting up samba on my website at www.linuxhelp.co.za, just follow the "networking" link, should have you sharing printers and files in no time...
0
 
LVL 2

Expert Comment

by:ifincham
Comment Utility
Hi,

Looks like neither of those cards use drivers that ship with the standard kernel. However you can download drivers from --> http://www.dlink-intl.com/Technical/linux.htm .

The problem is that you'll need to compile and install them by hand. The DFE 550TX driver is called 'sundance' and the DGE 500SX driver is called 'dgelin'. There is also another version of the DFE 550TX driver called 'dlh5x'.

Firstly download the driver sources from the above site.
The easy one is the dgelin where they provide a makefile.
Just download the file and put in in a subdirectory :

$cd $HOME
$mkdir dfe
$cd dfe
$cp /usr/download/0001115.exe $HOME/dfe   (copy downloaded file from its download location - wherever you put it0
$unzip 0001115.exe
$cd linux
$make
$uname -r    (make note of kernel version - e.g. 2.4.2)
$su          [enter root password]
#cp dlh5x /lib/modules/2.4.2/net  (where 2.4.2 is whatever you found with the uname -r command)
#netcfg      (graphical config - go to eth0 or eth1 - whichever is the correct one for this card - and select the driver - also set an ip address & subnet mask - for example 172.16.16.1 255.255.0.0 save & exit)
#cd /etc
#mc           find file modules.conf and edit with F4

[add these next two lines to /etc/modules.conf]

alias eth1 dgelin                         (eth0 if appropriate)
options dgelin speed=1000 duplex=full

For the other card its very similar except you don't get the Makefile...

$cd [another subdirectory with unzipped source files]
$gcc -DMODULE -Wall -Wstrict-prototypes -O6 -c sundance.c
$gcc -DMODULE -D__KERNEL__ -DEXPORT_SYMTAB -Wall -Wstrict-prototypes -O6 -c pci-scan.c
$su
#cp sundance.o /lib/modules/2.4.2/net/
#cp pci-scan.o /lib/modules/2.4.2/net/
#netcfg    (as before now for other card - make it 172.16.16.2 mask 255.255.0.0 & select sundance driver)

then add to /etc/modules.conf :

alias eth0 sundance
install sundance insmod sundance

Save everything & reboot

Hopefully they should now work

Regards


 










0
 
LVL 2

Expert Comment

by:ifincham
Comment Utility
Hi,

Just an addendum to the above.. If you download the 550Linux.tar file you uncompress it as follows :

$mv /usr/download/550Linux.tar $HOME/dfe
$tar xvf 550Linux.tar

Rgds
0
 

Author Comment

by:shchong2
Comment Utility
Hi ifincham

     I'd download both the "550linux.tar" and "0001115.exe" files from the dlink site. Following the steps written in the readme file, as well as what you've told me above, I encountered some problems :-

(p/s : I have the root access)
(p/s : Typing uname -r gave "2.4.2-2smp")

=======================
* For the 0001115.exe
=======================
(1) I have unzip the file, then go into the folder called "linux"
(2) Then type "make", but error appeared as follow :
   gcc -D__KERNEL__ -DMODULE -02 ..............
   ............................................
   ..... -DSERIALIZE_TX -c -o dgelin.o dgelin.c

   In the file included from dgelin.c:353:
   /usr/include/linux/modversions.h:1:2: #error Modules
   should never use kernel-headers system headers,
   /usr/include/linux/modversions.h:2:2: #error but headers
   from an appropriate kernel-source
   make: *** [dgelin.o] Error 1
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:shchong2
Comment Utility
Hi ifimcham,

=======================
* For the 550linux.tar
=======================

(1) After extract the file using "tar xvf", I obtained
    a lists of files which includes "sundance.c" ,
    "pci-scan.c" , etc..

(2) Then I type
    $gcc -DMODULE -D__KERNEL__ -DEXPORT_SYMTAB -Wall -Wstrict-prototypes -O6 -c pci-scan.c

   which gave me a file called pci-scan.o

(3) But when typing
   $gcc -DMODULE -Wall -Wstrict-prototypes -O6 -c sundance.c

   errors occurred as follow!!!

sundance.c: In function 'netdev_open':
sundance.c:645: structure has no member named 'tbusy'
sundance.c:646: structure has no member named 'interrupt'
sundance.c:656: structure has no member named 'start'
sundance.c: In function 'netdev_timer':
sundance.c:716: structure has no member named 'tbusy'
sundance.c:716: structure has no member named 'tbusy'
sundance.c: In function 'start_tx':
sundance.c:812: structure has no member named 'tbusy'
sundance.c:841: structure has no member named 'tbusy'
sundance.c: In function 'intr_handler':
sundance.c:870: structure has no member named 'interrupt'
sundance.c:873: structure has no member named 'interrupt'
sundance.c:944: structure has no member named 'tbusy'
sundance.c:948: structure has no member named 'tbusy'
sundance.c:949: 'NET_BH' undeclared (first use in this function)
sundance.c:949: (Each undeclared identifier is reported only once
sundance.c:949: for each function it appears in.)
sundance.c:973: structure has no member named 'interrupt'
sundance.c: In function 'netdev_close':
sundance.c:1224: structure has no member named 'start'
sundance.c:1225: structure has no member named 'tbusy'



pls help !!!!!!!
thankx
0
 

Author Comment

by:shchong2
Comment Utility
pls help on the above 2 problems :

first -
For the 0001115.exe (posted above)

second -
For the 550linux.tar


pls help
thank you very much

:)
0
 

Author Comment

by:shchong2
Comment Utility
can someone pls help ?
0
 

Author Comment

by:shchong2
Comment Utility
pls help !
:)
0
 

Author Comment

by:shchong2
Comment Utility
pls help !
:)
0
 

Author Comment

by:shchong2
Comment Utility
Hi, I finally made the Fast-Ethernet card work.
But not yet try out the Gigabit card.

Anyway, your explaation is really detailed and helps he so much

Really thankx you very much, psimation.

Btw, I wonder why the website "www.linuxhelp.co.za " is not acessible ? I really wish to take a look at the site.

:) and thankx alot
0
 

Author Comment

by:shchong2
Comment Utility
Hi, I finally made the Fast-Ethernet card work.
But not yet try out the Gigabit card.

Anyway, your explaation is really detailed and helps he so much

Really thankx you very much, psimation.

Btw, I wonder why the website "www.linuxhelp.co.za " is not acessible ? I really wish to take a look at the site.

:) and thankx alot
0
 
LVL 17

Expert Comment

by:psimation
Comment Utility
schong2, glad to have been of help.
We did have a couple of line problems during the day, but they seem to be sorted out now, so you should be able to access the site now.
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
This video discusses moving either the default database or any database to a new volume.
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now