• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 354
  • Last Modified:

Disconnected Network drives

Hi,

I'm using W2k Pro in a normal NT Domain. We are mapping the network drives by the login script.
net use U: \\server\share /persistant:no

If I take a look at "My Computer", the mapped shares are shown sometimes as disconnected. (red cross)

Why?
0
kuehn
Asked:
kuehn
1 Solution
 
egonoCommented:
IMHO it's because you have not accessed the drive U: before you look at "My Computer". If you access the drive the red cross should disappear.

regards
0
 
kuehnAuthor Commented:
Well, after I have accessed the drive, it is not marked with a cross, but after a while, it is marked again.

Why is it like this? Is it a feature??
0
 
SteveGTRCommented:
DISABLING AUTODISCONNECT

Windows NT uses two different autodisconnect parameters: one for disconnecting RAS connections and another for disconnecting LAN connections. The RAS Autodisconnect parameter is well-documented in the Windows NT Server Remote Access Service Manual, but the LAN version is undocumented. You can find the LAN Autodisconnect parameter in the Registry at:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

The autodisconnect function disconnects idle sessions after a set number of minutes. You can set the number of minutes at a command prompt using the Net Config Server command. For example, to set the autodisconnect value to 30 minutes: Net Config Server /autodisconnect:30. The valid value range of this REG_DWORD value is -1 to 65535 minutes at the command line. To disable autodisconnect, set it to: -1. Setting autodisconnect to 0 doesn't turn it off and results in very fast disconnects-within a few seconds of idle time. (However, the RAS autodisconnect parameter turns off if you set it to a value of 0.) It's preferable to modify the LAN autodisconnect directly in the Registry. If you modify autodisconnect at the command line, Windows NT might turn off its autotuning functions. The valid value range, if you edit the LAN
autodisconnect parameter in the Registry, is 0 to 4294967295 (Oxffffffff). If you configure the autodisconnect option to -1 at the command prompt, autodisconnect is set to the upper value in the Registry. This is approximately 8171 years, which should be long enough to be the equivalent of turning autodisconnect off.
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
kuehnAuthor Commented:
Thanks,

This is solution looks good.
0
 
SteveGTRCommented:
Question: Then why the "B" grade?
0
 
kuehnAuthor Commented:
Because, if I map later a Networkdrive manually, the drive has a red cross.

And I have used -1 and after 5 hours, there are some red crossed connection.
0
 
nicmosCommented:
I have this problem too, except the drive which is being dropped is to a Novell server, any ideas?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now