Unixware 7.1.1 keymap

My terminal charcters doesnt work correctly.

I get '[A$<200>' key when I try to use the 'arrow up' key (when I try to get the 'history').

I dont know what is the best shell for the Unixware (is it cshell or kshell?).

I get a strange prompt every line, (instead of getting the username only).

Thanks!

frida_harushAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
ahoffmannConnect With a Mentor Commented:
traditional (AT&T, Sun) csh does not support these keys. Dot. Probably you have a UNIX systems which uses tcsh as csh (symbolic link) like Linux.
You might map the keys using loadkeymap, would be hard :-(
0
 
ahoffmannCommented:
> I get a strange prompt every line, (instead of getting the username only).

this sounds like you have set the PROMPT variable to something that your shell doesn't support.

Which shell do you use (echo $SHELL) ?
Which one do you prefer: csh, tcsh, ksh?
0
 
frida_harushAuthor Commented:
currently I work on cshell.
I read that it is prefered to work with ksh in SCO Unixware 7.1.1 is it correct?.
I used my Digital Unix .cshrc file and it didnt helped...
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
ahoffmannCommented:
csh is ok :-)
What's prefered on Unixware doesn't matter: this is UNIX, and so the user's choice .
Any .cshrc should work (some errors just may occour if it is a .cshrc designed for tcsh).
I assume that you have a variable setting for prompt in your .cshrc which causes the strange behaviour, please check.

In csh you cannot use up, down, etc. keys, except you manage to define an alias (woulod be hard).
0
 
frida_harushAuthor Commented:
I have UNIX (not UNIXWare) systems where all the keys work correctly (including the up and down keys).
I looked at "stty" command in Unix, but I didn't find any part about "up" and 'doun" keys.
is there a key mapping by "stty"?
0
 
mrn060900Commented:
try setting

ksh
TERM=vt100;export TERM

then try the cursor keys...

or you could try using

h j k l .... the real mans cursor keys ;-)

Regards Mike
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.