Solved

Webclass Data Access Error 800a9c68

Posted on 2001-08-22
13
1,164 Views
Last Modified: 2007-11-27
Using PDW internet package option, I've deployed a webclass application that uses a odbc connection to access a SQL 7.0 database.  I also created a standard package that contained mswcrun.dll & msvbvm60.dll and it loaded correctly.  I've also manually registered c:\program files\common files\designer\mswcrun.dll & c:\winnt\system32\msvbvm60.dll.  NT is on SP6.  The IUSR user has been set as part of the administrator group.

The problem is this:  When I browse to the site, the custom webclass login screen appears correctly, but after I type a valid loginid & password I get the following error:  webproj error '800a9c68', Application-defined or object-defined error,  /webproj/webprojlogin.asp, line 13.  When I check the Event Log I see 2 errors: #1 is application defined or object-defined error.  #2 is run-time error '430': Class does not support automation or does not support expected interface.

300 points and a big thanks if you can get me though this.
0
Comment
Question by:GCummings
  • 7
  • 6
13 Comments
 
LVL 70

Expert Comment

by:Éric Moreau
ID: 6415953
0
 

Author Comment

by:GCummings
ID: 6415987
I've previously look through at least one of the kb articles and just re-read them but it didn't seem to quite nail my problem.
0
 
LVL 70

Expert Comment

by:Éric Moreau
ID: 6415995
Error 430 may be an incorrect version of ADO on your server. What is on line 13?
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 

Author Comment

by:GCummings
ID: 6416053
I believe Line 13 is referencing the Webclass code that triggers the asp.  I did find an article that specifically references my problem.  I loaded ado21 (ga) from the web onto the server (ado21 is set in the reference to my weclass app) but I get the same results.  The article is somewhat confusing though, specifically where is says "Install the correct MDAC on the users computer (which i did on the server) and change the install program to redistribute the correct version":
 http://support.microsoft.com/support/kb/articles/Q248/4/04.ASP
0
 
LVL 70

Expert Comment

by:Éric Moreau
ID: 6416072
Do you have a more recent version of ADO on your development PC?
0
 

Author Comment

by:GCummings
ID: 6416077
I believe Line 13 is referencing the Webclass code that triggers the asp.  I did find an article that specifically references my problem.  I loaded ado21 (ga) from the web onto the server (ado21 is set in the reference to my weclass app) but I get the same results.  The article is somewhat confusing though, specifically where is says "Install the correct MDAC on the users computer (which i did on the server) and change the install program to redistribute the correct version":
 http://support.microsoft.com/support/kb/articles/Q248/4/04.ASP
0
 

Author Comment

by:GCummings
ID: 6416082
No I should though, Are you suggesting downloading the latest ado and seeing if that works, I think thats probably a good idea at this point.
0
 

Author Comment

by:GCummings
ID: 6416086
No I should though, Are you suggesting downloading the latest ado and seeing if that works, I think thats probably a good idea at this point.
0
 
LVL 70

Accepted Solution

by:
Éric Moreau earned 300 total points
ID: 6416090
I suggest that you install at least ADO 2.5.
0
 

Author Comment

by:GCummings
ID: 6416096
Thats the one I'll do.  On a side note, I also just figured out that if I hit refresh on my browser (I was checking to see if any new post were done) - then it repost MY last reply again -  thus the duplicate messages.
0
 
LVL 70

Expert Comment

by:Éric Moreau
ID: 6416106
Use the "Reload question" button at upper right to refresh the display.
0
 
LVL 70

Expert Comment

by:Éric Moreau
ID: 6424909
Any news?
0
 

Author Comment

by:GCummings
ID: 6428703
Yes.  I got it working!  Using Ado25 was a better choice than 2.1 and I think it did get me through to my next error. The main problem was a security issue between the Web Server and the Sql Server (it was set-up to have NT Authenticate only and needed SQL Server & NT Authenticate)...  Thanks for the input, the 300pts is yours.  
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

The debugging module of the VB 6 IDE can be accessed by way of the Debug menu item. That menu item can normally be found in the IDE's main menu line as shown in this picture.   There is also a companion Debug Toolbar that looks like the followin…
Since upgrading to Office 2013 or higher installing the Smart Indenter addin will fail. This article will explain how to install it so it will work regardless of the Office version installed.
Get people started with the process of using Access VBA to control Excel using automation, Microsoft Access can control other applications. An example is the ability to programmatically talk to Excel. Using automation, an Access application can laun…
This lesson covers basic error handling code in Microsoft Excel using VBA. This is the first lesson in a 3-part series that uses code to loop through an Excel spreadsheet in VBA and then fix errors, taking advantage of error handling code. This l…

791 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question