Solved

ms-dos compatibility mode?

Posted on 2001-08-23
10
243 Views
Last Modified: 2008-03-06
if I go to controlpannel then system then performance, I see ms-dos compatibility mode...that is what virtual memory, c: is in...

I have been told this is why my teac cdrw will not burn any cds.

any ideas?
0
Comment
Question by:bebonham
10 Comments
 
LVL 16

Accepted Solution

by:
Kyle Schroeder earned 50 total points
ID: 6419781
See these pages at Microsoft for help in resolution.  Try the suggestions, if they don't work, let us know and we can try some other ideas.

http://support.microsoft.com/support/kb/articles/Q130/1/79.ASP
http://support.microsoft.com/support/kb/articles/Q151/9/11.ASP

-d
0
 
LVL 32

Expert Comment

by:jhance
ID: 6419810
Most likelt you are loading CDROM.SYS (or another CDROM driver by another name) in your CONFIG.SYS file as well as MSCDEX in your AUTOEXEC.BAT file.  There is NO NEED for either of these in WIN32 and that includes Win95, Win98, and WinME.  

Edit your CONFIG.SYS and AUTOEXEC.BAT to remove these.  If you have a line like:

DEVICE=C:\WINDOWS\CDROM.SYS
or
DEVICEHIGH=C:\WINDOWS\CDROM.SYS

comment it out with a REM at the beginning of the line:

REM DEVICE=C:\....

Similarly, if you have:

LH C:\WINDOWS\MSCDEX.EXE ...

put a REM at the beginning:

REM LH C:\....

This will take care of your MSDOS compat problem.
0
 
LVL 8

Author Comment

by:bebonham
ID: 6419838
I had already whacked all that stuff before asking...

ended up deleting autoexec.* and config.* as I was getting frustrated...

anyways.... I am going home for today, and I just moved, so no internet at home...I'll get back to y'all tomorow.

Thanks,

Bob
0
 
LVL 2

Expert Comment

by:ramses
ID: 6419990
What have you installed/removed PRIOR of receiving this situation?

Even when both CDROM.SYS or simular cd-driver AND MSCDEX.EXE are loaded, windows will stil not put you in compatibilty mode.

AUTOEXEC.BAT and CONFIG.SYS are not the only files that can point to a driver/program that will put you in compatibility mode, some entrys in WIN.INI, and I believe SYSTEM.INI can also force compatibility mode

Even some devices in your computer can cause this.  For example and old harddisk that does not support 32-bit functions...

Best is to remember what programs/devices you have installed PRIOR to receiving this error.

This can help you out:

Solution 1: determine software cause
Restart your pc and when you see "Starting Windows" or something like it, press the F8 keys multiple times until you see the "Windows Startup Menu"

Select the mode "Safe Mode without networking" or something resembling that option.

Windows will then boot without loading AUTOEXEC.BAT, CONFIG.SYS, and will only load drivers essential to running windows, like display, keyboard, mouse,...

Open system propertys and see if it says compatibility mode.  If it doesn't, you know it's a software cos, and you'll have to determine what caused it.  To do that, restart the pc and open the "Windows Startup Menu", as described above and choos Logged to file C:\...

Let windows load completaly, open the file with wordpad (it will be too large for Notepad) and perform a search for the (sub) word FAIL

If you recognize any of the drivers you have added, put a remark (usually ; before it, in autoexec.bat, just add :: before it), restart windows, and check if it solved

Solution 2: Determine Hardware cause
Start windows, open the control pannel, then system propertys or just press WIN+BREAK, then click on the Device Manager Tab, and look for an entry with an exclamation mark or an 'X' next to it.

Click on the entry, then click on the button Properties.  You will then get a window with a "Device Status" text displayed.  Read it.  If that helps, perform the requested steps.  If that don't, check the "Disable in this hardware profile" checkbox.  Press OK, OK, restart windows, and try again to see if the problem is solved.  If not, open the Device Manager again, and remove the item in question.  Restart windows, and windows will automatically reinstall that device (if it still exists in your pc).

If all that doesn't answer your problems, maybe it's time to get some free fysical help from a computer guru in your neighbourhood.  Most of us enjoy working on/with pc's soo much we'll be happy to help.  And all it will cost you is a pizza, some coke (coca-cola), and maybe a pack of smokes... :-)


Ramses says RooOOOOar!

0
 

Expert Comment

by:CyberPup
ID: 6420160
This issue pops up on occasion in my shop.  If you have already cleared all the DOS drivers from loading, then you can do this to clear it up usually.  Run regedit and search for the key PCIDualIDE and change its value from 0 to 1 or vice versa.  In other words, swap the value.  Close regedit and restart.  That should clear it up.
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 
LVL 10

Expert Comment

by:HDWILKINS
ID: 6420918
I think dogztar probably answered your question.  Look at the second URL and use REGEDIT to look for an entry called NOIDE.  Once this is set on in the registry, your stuck in DCM even if you pull out the offending hardware.

His URLs also mention device drivers, etc., but I'd bet that the problem was caused by the CDR having a conflict with the drive.  You might try putting the CDR on the secondary controller and then delete the NOIDE.

HW
0
 
LVL 8

Author Comment

by:bebonham
ID: 6422067
there is no NoIDE entry in my registry...

I checked win.ini, system.ini, I made bootlog.txt and there were no fail

there are no warnings or disabled devices in device manager.

any other ideas?
it is w98 second edition, so it is not the large ide problem...
0
 
LVL 2

Expert Comment

by:ramses
ID: 6422078
What piece of hardware did you install prior to having this error?
0
 
LVL 8

Author Comment

by:bebonham
ID: 6422160
the cdrw,,,was the last thing


but...it is resolved...I came across a post on some board that said "start in safe mode, then remove all cd,hd, fd controlers,drives, etc."

so I did, then I rebooted, then it reinstalled some stuff, and without any other fussing at all, the msdos compat went away, and the cdrw started working.
0
 
LVL 8

Author Comment

by:bebonham
ID: 6422163
thanks to everyone
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

The Rasberry PI is a low cost piece of hardware that you can have a lot of fun with through experimenting and building/working on projects like media players, running a low cost computer, build data loggers etc. - see: https://www.raspberrypi.org
In this article we have discussed the manual scenarios to recover data from Windows 10 through some backup and recovery tools which are offered by it.
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now