DELETE key is not working inside a webbrowser control!

Hi,

I have created an activex control with a dialog box and inside that I have a webbrowser control. The input box inside the browser takes all the keys except the DELETE key! Even the backspace is working! Does anyone come across similar problem?
Deoes it have something to do with the browser control?

Please help me!!
If anyone wants I can send my sample code

Thanks.

kunjachanAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Computer101Connect With a Mentor Commented:
PAQed - no points refunded (of 200)

Computer101
E-E Admin
0
 
ShaunWildeCommented:
I'll have a look send to shaun_wilde@hotmail.com
0
 
kunjachanAuthor Commented:
I sent it to ur id. Please see the code.
0
 
ShaunWildeCommented:
> Deoes it have something to do with the browser control?

no - this is one of the keystroke problems that is known about when using MFC and webbrowsers controls - its all related to the messages not making it to the correct controls

I suggest you have a look at the following articles

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnmind99/html/faq0499.asp
http://www.microsoft.com/Mind/0499/faq/faq0499.htm
http://support.microsoft.com/support/kb/articles/Q165/0/74.ASP
http://support.microsoft.com/support/kb/articles/Q175/5/02.ASP



If I get time I'll have a go at fixing it
0
 
Roshan DavisCommented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:

PAQ'd and pts forfeited

Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

Roshan Davis
EE Cleanup Volunteer
0
All Courses

From novice to tech pro — start learning today.