setting IRQ manually


Here's my configuration:
PII 350 - 384 RAM - 26 Gb
running SuSE 7.1 with 2.4 kernel
2 network cards: D-Link 528 (eth0 for internet connection, dhcp) and an additional 3Com 3c905 (eth1 for dmz, fixed IP)

I want to use this pc as a gateway for an older win95, but
I first was unable to get 'm to work, both of 'm: I just got eth0 was not activated... same for eth1.
Had no idea what so ever why this happened (before I installed the second card, SuSE was perfectly able to install and configure my card for internet connection).

Finally I found what the error was: IRQ conflict with my MS natural keyboard-USB-hub (don't ask :)
Another odd thing I noticed was that during startup, not one of the cards could be started, but I did get online with my eth0 after I got in KDE (no idea why).

So here's my question: how can I manually set the IRQ for those 3 devices (hub, eth0 and eth1)?  Disabling the usb-hub is not an option, since my keyboard and mouse are usb (well, keyboard 50/50).

I checked the IRQ settings in the SuSE control panel and I have plenty of IRQ's left to use.

If it's possible to give a detailed explanation (when it comes to really really fiddling with linux, I'm a semi-noobie :)

And what IRQ's are safe to use (*keeps in mind the standard irq's for keyboard etc*)

tnx in advance!

Who is Participating?
jlevieConnect With a Mentor Commented:
I suspect that there aren't as many free IRQ's available as you think. On a typical IDE system with USB active you probably have at most 2 free IRQ's and if sound or a modem is intalled... well each of those takes an IRQ. To truly see what IRQ's are in use you need to look at 'dmesg | grep -i irq', the contents of /proc/interrupts and /proc/pci. Using what you see in each of those build a list of all used IRQ's and I think you'll see what I mean.

I'd suggest looking at ways to free up one or more IRQ's for use by the NIC's. Possibilities include using a USB mouse and disabling the PS/2 port, disabling one or both of the COM ports, and possibly the parallel port (and using a USB printer). Oh yes, also make sure that PnP mode is disabled in the BIOS (if you BIOS allows that). Frequently that is all that is required to solve an IRQ problem. And sometimes moving the PCI cards to different slots helps.
NicalyaAuthor Commented:
will check that, tnx, although I find it odd, since my win2k server has no problem what so ever with my irq's...

will post back ...
NicalyaAuthor Commented:
will check that, tnx, although I find it odd, since my win2k server has no problem what so ever with my irq's...

will post back ...
The design of the drivers on a Windows OS allows for more than one device using the same IRQ. That slows down I/O on the devices sharing the IRQ, which is why Linux drivers don't work that way.
NicalyaAuthor Commented:
sorry bout the late response,

In the meanwhile I have fallen back to a normal ps/2 mouse, disabling the usb hub (clearing up that double irq)

Just in case I'll ever need to reverse it again, I'll try your answer.

tnx a lot!

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.