Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 475
  • Last Modified:

attrib syntax...

Hi.
Not sure if this is the right place to ask a DOS question, but here goes...

I'm trying to recursively change the file properties in a directory (it came off a CD-ROM so all the files are 'read-only' in a directory tree). I'm trying this but it ain't working -

ATTRIB [-R] [[C:\][MYDOCU~1\DECCA\DOCROOT\]] [/S]

I'm getting the error

'Parameter value not allowed - [-R]

the directory is C:\MYDOCUMENTS\DECCA\DOCROOT\ and I want to change the properties of all files within that and nested directories...

The machine is running Win98 if that matters...

anyone any ideas?

Ian
0
cath
Asked:
cath
  • 5
  • 3
1 Solution
 
jhanceCommented:
Leave out the [].  So the command is:

ATTRIB -R C:\MYDOCU~1\DOCROOT\ /s
0
 
jhanceCommented:
By the way.  A hint on syntax.  When you see the documentation give parameters in [] like:

ATTRIB [-R]...

It means that the parameter is OPTIONAL.  So you can leave it out if it's not necessary.  The ATTRIB command for example says:

ATTRIB [+R | -R] ...

That means that you can have:

ATTRIB
ATTRIB +R
ATTRIB -R

and all are legal syntax.  Note that this command does not require ANY parameters so you can issue:

ATTRIB

This will just display the settings for all the files in the current directory.
0
 
cathAuthor Commented:
I'm getting 'path not found' when I do this:

ATTRIB -R C:\MYDOCU~1\DECCA\DOCROOT\ /s

and yet the path (unshortedned to 8.3) is

c:\my documents\decca\docroot\

yet if I put that into the ATTRIB string (ie include the space after 'my' and the full string for 'documents') I get 'parameter value not allowed' - I guess cause it doesn't like the space.

any ideas?

DOS, God love it, huh?

Ian

0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
jhanceCommented:
Then try it like:

ATTRIB -R "c:\my documents\decca\docroot" /s
0
 
cathAuthor Commented:
nope, says 'File not found - c:\my documents\decca\docroot

I tried it with a trailing \ as well (ie ..\docroot\)

and got path not found...

annoying...

any ideas?

Ian
0
 
jhanceCommented:
You are trying the name wrong.

Either you have the name itself wrong or you are not typing it is as you have said.  Either way, it's wrong.

Try the:

DIR /X

command and make sure you have the correct SHORT FILE NAME for this folder.  Are you 100% that there is not a filename extension at the end?  A folder (as well as a file) can be named like "filename.xxx".  So your folder might be named:

C:\My Documents\DECCA\DOCROOT.000

or something.  It's easy to miss the filename extension since the DIR command leave a space.
0
 
cathAuthor Commented:
well I can't see a filename extension on the end of the directory...

I do DIR /P

and I get a list of directories of which one is

MYDOCU~1

so then I try

ATTRIB -R "C:\MYDOCU~1\DECCA\DOCROOT" /s

and then I try

ATTRIB -R "C:\MY DOCUMENTS\DECCA\DOCROOT" /s

and neither works. Both times I get 'File not found...'

I mean what _is_ it with DOS? This is so easy in Linux...

I appreciate your help, though... ;-)

Ian
0
 
jhanceCommented:
OK, then try...

ATTRIB -R C:\MYDOCU~1\DECCA\DOCROOT\*.* /s
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now