• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 252
  • Last Modified:

Grp policies...

Hi,

I still have NT4 servers and I have more and more W2K
workstations.
In NTConfig.pol (default computer/System WinNT) I have checked "Do not display the last connected user".
It doesn't work with the wkstations running W2K.

Is there any tip ??? (except setting each station
manually).

Thanx
WW
0
wwalschaerts
Asked:
wwalschaerts
  • 3
  • 2
1 Solution
 
elischCommented:
Is the NTConfig.pol located in the winlogon directory on your PDC/BDCs?  If not, you will need to use group policy on the W2k stations and set it manually on each station.  Win2k doesn't use local .pol files like NT 4.

The best option for manual configuration is a program called: Multi-remote registry change.  You can find it at: http://www.eytcheson.com ...Its a pretty handy tool.  You can create a single registry import file and push it out to a large group of machines.

cheers
0
 
wwalschaertsAuthor Commented:
Hi,

Yes NTconfig.pol has the correct location... it works
fine with the workstations running NT4...
WW
0
 
elischCommented:
Can you give me more information about your network?  I'm assuming its an NT4 domain.  Is it multiple sites?  How many BDCs do you have?

It may be that the Win2k machines are connecting to a BDC that doesn't have the Policy in the netlogon directory.  The NT 4 machines will work because the registry key was set the first time they logged in with the policy in effect.  Even if the NTConfig.pol file was gone the NT 4 machines would still have the right settings.

cheers
0
 
elischCommented:
Ok, I got it figured out now.  On the Win2k boxes there is 2 places where you can see the Dontshowlastusername.

The first place is HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon....however, when I went in and set that to 1 it didn't work...usernames were still displayed.

So I found a second place:  HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System  When I set that to 1 it worked.  I logged out of the system and when I logged back in the previous username was not displayed.

2 solutions here...that I can think of anyway....Use the group policy snap-in for Win2k and remotely (yet manually) update each Win2k workstation.

Second solution, edit the ADM file that correlates to the section you want (dontdisplaylastusername) and add the necessary info to create another checkbox and another registry key specifically for Win2k boxes.  Once you have this, edit your NTConfic.pol file and check the box.  The redistribute the policy to your PDC and let it replicate to the BDC's.  This should then make the necessary changes on the Win2k boxes.

Well...then again, there is a third solution...use that tool I told you about in a previous post to remotely update the Win2k machines.  Would probably be easiest of all.....

Cheers,
Eli
0
 
wwalschaertsAuthor Commented:
I have spend a while to understand what to modify in the
adm file.
It is working perfectly.
Thanks a lot
WW
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now