Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 403
  • Last Modified:

JDeveloper Error - Please help!

When running a JSP application from JDeveloper, after the browser comes up and it gives the option to go to the data view - when you click on it you get the following errors:
------------
Application Error
    Error Message: JBO-30003: The application pool, MyProject4_package1_Package1Module, failed to checkout an application module instance.
    Error Message: JBO-25002: Definition package1.Package1Module of type ApplicationModule not found.
-------------
When running just the business components form with same db connection, etc.  it works just fine.  What's causing it to bomb on the web page?   (PS. It worked a few weeks ago.)

0
spike4000
Asked:
spike4000
  • 2
1 Solution
 
graf27Commented:
JBO Errors are Java Business Objects-Errors.
Your Business-Components are "package1.Package1Module"  (ApplicationModule). All the Clients needs this packages, wich are most XML-Files. Your JSP-Application ( which is a Client of your BC4J ) needs this package also.

If you create your Project with
File->New Project->Project containing new->Business Component JSP Application ...

JDeveloper will include all the needed BC4J-Files for you ( you must select your BC4J-Projekt ). You can also deploy this JSP-Application inclusive the BC4J automatically.

If you create the JSP-Project manually, you must include your BC4J-File manually.
0
 
spike4000Author Commented:
Thank you for your response.

Since I posted this question, I got it working.  Here is what I did wrong -

First I did File->New Project, choose "A Project Containing Business Components".  

Then I did File->New Project, choose "A project containing a new Business Components JSP Application".
     
The problem was that I did not change the "What is the name of the Project's Default Package" to the package name created in step 1, therefore it didn't have a view to pick up.
0
 
wchwydCommented:
I have a problem now - it looks similar with yours.

There is a "JSP error" coming out with other results of JSP code - without any compile problem, when I try to run some JSP files under JDeveloper . This error looks happened at a text area. The  error message is "java.lang.NoClassDefFoundError: webapp/container_tabs$_jsp_staticText". Have it been happened when you run your JSP files?  
0
 
spike4000Author Commented:
Sorry, so far I have not run into that specific error.  Not sure what's causing it.
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now