W2K Server, apps can't access the net, but IE can?

I'm running Windows 2000 Server.  For some reason IE can access the internet, but when I try and use "Live Update" from Symantec for example, it receives an error.  Other applications that are trying to update themselves via the net are not able to either.  I have disabled ZoneAlarm, but didn't seem to help.  Are there certain settings I need to configure?  It just seems odd that a web browser can gain access but not any other app.

Thanks,
Derek
conditAsked:
Who is Participating?
 
LongbowConnect With a Mentor Commented:
>I have disabled ZoneAlarm

When it is enable you have Internet access ?
I say this because when i disable it i don't have Internet access.

I need to start Windows with ZoneAlarm then close it.

Try uninstalling the ZoneAlarm to come back to the previous Windows Settings.
I suppose ZoneAlarm have disabled some access

Longbow
0
 
jhanceCommented:
>>it receives an error

Can you be any more specific than "an error"?

What kind of network are you on?  Are you behind a proxy server or firewall?
0
 
conditAuthor Commented:
jhance

Unfortunatly with regards to the "error" it's a Symantec error just telling me that it was not able to connect to the server for updates.  Regardless of the program that needs to connect to the internet, I receive a similar error about not being able to connect.  

I'm not using a proxy server or firewall at all.  My network is a simple W2K server based w/6 W2K workstations.
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

 
LongbowCommented:
There is a way to provide the proxy setings from your internet provider in Internet Explorer properties ?
0
 
jhanceCommented:
You did not answer my question about your network.  Let me reprase:  

How is this system connected to the internet?

It sure sounds like you have a proxy or firewall that is blocking traffic other than port 80/HTTP.
0
 
conditAuthor Commented:
jhance,

we have a DSL connection into a switcher/hub, with our VPN, W2K Server & 6-workstations all plugged into our switcher as well.  All pc's can access the internet just fine, as well as IE on the server.  The issue is when any other application on the server tries to access the net I receive that paticular applications error message for lack of net access.

is there possibly a place on the W2K server where I can verify that all ports are open?
0
 
jhanceCommented:
Yew, W2K has a IP Filter function.  It's under the TCPIP settings, Options, TCPIP Filtering, Properties.

It's also possible that your DSL router is configured to filter.  Do you have control of it's configuration?
0
 
conditAuthor Commented:
jhance,

I checked the TCP/IP settings, & all (3) options are marked "Permit All", with the "Enable TCP/IP Filtering" box is unchecked.  It would appear to me that this feature is not being used.

Regarding the DSL, I only have the DSL modem(no router) hooked-up.  My VPN is doing all my NAT translation for the internet.
0
 
jhanceCommented:
>>I only have the DSL modem(no router)

You are mistaken.  There is no such thing as a DSL "modem".  It's a misnomer.  That device is a router CSU/DSU combination device, NOT a modem.

Anyway, all of the DSL "modems" I've seen have port filtering capabilities.

But the VPN brings up another question.  How do you know your VPN is setup to pass all of this traffic?  Somewhere, traffic is being blocked.  
0
 
LongbowCommented:
http://www.experts-exchange.com/jsp/qShow.jsp?ta=win2k&qid=20175949

This will show you the ports and the owning application

Longbow
0
 
conditAuthor Commented:
geoffryn,

I checked the Live Update settings suggested in the link you posted, unfortunatly they didn't apply to me.  None of the stated files existed on my system.  Thanks for the suggestion though, it did come in handy on one of the workstations :)
0
 
conditAuthor Commented:
Longbow,

It appears that your ZoneAlarm suggestion was the one.  I uninstalled it, rather than just disableing it & it did the trick.  I do thank you for your help, it is very much appreciated.

Condit
0
 
conditAuthor Commented:
It appears that your ZoneAlarm suggestion was the one.  I uninstalled it, rather than just disableing it & it did the trick.  I do thank you for your help, it is very much appreciated.

I do want to thank Jhance for all of his excellent help, it gave me much insight into my network.

condit
0
 
LongbowCommented:
Happy ;-)

I have this problem on my Windows 98 at home
I disable it to have more resources.

Result : no internet access at all :-(

I will search WHAT it disable

If you will we continue the discussion on a private mail.
Or ask another question at EE ;-)

Longbow

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.