Solved

Connection to home network already connected to @home

Posted on 2001-08-30
5
209 Views
Last Modified: 2010-03-18
Hello:

I would like assistance connecting my Linux machine to my home network which is currently connected via hub to the @home network. Ultimately, I wish to be able to access Windows drives on all three machines from my Linux computer and to use the Linux computer via Samba as a windows file server for backup purposes.

I am somewhat familiar with route, ifconfig, and netstat and have tried a number of combinations, but have had no luck so far. Here is the satus.

3 Windows machines attached to hub
Cable modem connected to uplink port on hub

The network info for the 3 windows machines is
Hostname: XXXXX-X.yy1.nj.home.com
IPAddresses: ###.###.abc.def, ###.###.abc.deg, ###.###.abc.deh, i.e the address are the same except for last number of the four.
Netmask: 255.255.255.128 (why not a 0 instead of 128 at end?)
Default Gateway: ###.###.abc.1 (i.e same as above addresses, except 1 as last number.)

The information that I have currently got on the Linux machine is:

IPAddress: ###.###.abc.200
Routing table(destination, gateway, genmas, flags,iface):
###.###.abc.0,###.###.abc.200,255.255.255.128,UG,eth0
127.0.0.0,0.0.0.0,255.0.0.0,U,lo

I am able to ping 127.0.0.1 and  ###.###.abc.200. When I ping ###.###.abc.def, I just get the message 5 packets transmitted, 0 packets received, 100% loss. I do not get the message "network unreachable", which I have gotten on previous occasions.

Note that I do have internet access from my Windows machines and that I can ping one computer from another over the home network.

My understanding if routing tables says that if I want to reach a computer on my local network, which I guess includes the 3 windows computers and a computer of the cable company, then I should do so with a routing entry which specifies that destinations beginning with ###.###.abc should be accessed via the host, i.e with the IP address ###.###.abc.200. Is that right?

Does the hub introduce any complications?

Thanks for your help.
0
Comment
Question by:amcandrew
5 Comments
 
LVL 51

Expert Comment

by:ahoffmann
ID: 6442755
do your home computers use private (RFC) IPs, like 192.168.x.x ? Then you need to use masquerading (NAT) somehow, otherwise you cannot see these computers from outside (from internet).
0
 

Author Comment

by:amcandrew
ID: 6443347
My home computers do not use private IPs. They use IPs provided by the cable company and they can be pinged from sources external to our home network.

thanks

amca
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 6444495
what does traceroute tell you?
0
 
LVL 40

Accepted Solution

by:
jlevie earned 200 total points
ID: 6444700
It's hard to tell from the question if the Linux box is configured correctly or not. You say that the other boxes are nnn.nnn.abd.def, etc and that the Linux box is at nnn.nnn.abc.200. That's not enough information to know if everything is on the same network. Since the netmask is 255.255.255.128 there are two possible subnets, nnn.nnn.abc.0-127 & nnn.nnn.abc.128-255 and I can't tell from the question which subnet is in use. We know the IP of the Linux box and if the other systems have IP's ending in the range 127-254, then the Linux box is correctly configured. On the other hand if the other boxes have IP's ending in the range 0-126, then the Linux box isn't correctly configured and it won't work.

If all of the machines are on the same subnet, then I'd say you have a resource conflict involving the NIC card. That occurs when two or more devices try to use the same IRQ. If that occurs, the NIC will be able to send small packets, like a ping, as that can be done without requiring the use of an interrupt, but the driver won't see the interrupt for received data. The classic symptom of this (assuming correct network configuration) is that the TX count will be non-zero and the RX count will be zero. You need to look at the output of 'dmesg | grep -i irq', the contents of /proc/interrupts, and /proc/pci. If you combine IRQ assignments from all of that data you'll be able to tell if some other device is using the same IRQ as the NIC card.

Fixing a resource conflict can be difficult. The first thing I'd do is to make sure that PnP mode is disabled in the BIOS (if yours has that option). Assuming a PCI card, sometimes moving the NIC to a different slot will change the IRQ assignments. In stubborn cases with PCI cards it may be necessary to disable some on-board resource that you aren't using, like a USB or PS/2 port, a COM port, etc., to free up an IRQ. If you were to happen to be using an ISA card, you may be able to program it to a different and free IRQ or to reserve, in the BIOS, the IRQ a PnP ISA card is using for ISA use. In extreme cases I've had to change the card to a different make.

The remaining possibility is that you simply have a bad cable, hub port, or NIC card. Swapping components will tell you if that is the cause.
0
 
LVL 2

Expert Comment

by:ifincham
ID: 6446464
Hi,

Just to try an clarify the subnets a little. The 255.255.255.128 mask means that the last octet (x.x.x.0-255) is split into two (256/128) subnets. So, using 192.168.1.x as an illustrative example, you could have either :

192.168.1.1 to 192.168.1.126    (0 is subnet; 127 is broadcast)
 or
192.168.1.129 to 192.168.254    (128 is subnet; 255 is broadcast)

So, as long as all four of your boxes have ip addresses in only one of the above two ranges then they are on the same subnet and no routing is necessary. If you can't ping the winboxes maybe theres some kind of firewall issue - could the windows box be dropping icmp packets ?.

Can u ping from win to linux ? Regarding the hub, if it's a dumb hub (vs a switch) then it should just repeat everything thru every port.

Rgds


0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
how to check md5 on 100s of files on linux 6 155
Open BDS Pf 3 44
Linux : can't create transaction lock error 1 50
Linux SSH Error 9 68
I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
This video discusses moving either the default database or any database to a new volume.
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now