Solved

Crystal Reports 8.0 always ask for password

Posted on 2001-08-30
6
304 Views
Last Modified: 2012-08-13
I have a report running from a IIS 4.0 with Cold Fusion Programming. I have also a connection to a SQL server 7.0 installed on a different computer. Always. whe I run the WEB page and try to see my report ask me for a User name and Password to make the Query to the Data base. I already apply the update for the ODBC driver and a patch for the registry but none of those work.
Do you have an idea how to fix this problem?
Thanks for your help.
0
Comment
Question by:carreola
6 Comments
 
LVL 12

Expert Comment

by:DRRYAN3
ID: 6443076
Are you calling your report via html or ASP?
0
 

Author Comment

by:carreola
ID: 6446495
I'm using html. Do you have any idea?
0
 
LVL 12

Accepted Solution

by:
DRRYAN3 earned 200 total points
ID: 6453873
Try

http://<servername>/reportname.rpt?user0=username&password0=password

See http://support.crystaldecisions.com/kbase/c2002209.asp for a discussion and other links.

DRRYAN3
0
Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

 

Expert Comment

by:seasons712
ID: 6486974
do u add this code in your ASP page?

table1.SetLogonInfo [DSN}, [table_name] , [sa], [password]
0
 
LVL 12

Expert Comment

by:DRRYAN3
ID: 6523847
This question has been open for some time now.  Please return and either
1.  Accept an answer
2.  Post a comment stating that you need more information
3.  Ask Community Support to delete the question if you feel the information here has no value to you or anyone else.
4.  Ask Community Support to PAQ the question because your question was not answered but you feel the information here may be of some value to others.

Community Support is here:  http://www.experts-exchange.com/jsp/qList.jsp?ta=commspt and you can leave a message by posting a zero point question.  Be sure to reference the question ID, found in the Address bar of your browser.

Thanks
DRRYAN3
0
 

Expert Comment

by:ComTech
ID: 6529305
Answer accepted by:

ComTech
Community Support Moderator
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I hate sub reports and always consider them the last resort in any reporting solution.  The negative effect on performance and maintainability is just not worth the easy ride they give the report writer.  Nine times out of ten reporting requirements…
Hot fix for .Net Crystal Reports 10.2.3600.0 to fix problems with sub reports running on 64 bit operating systems ISSUE: Reports which contain subreports fail with error "Missing Parameter Value" DEPLOYMENT SERVER OS: Windows 2008 with 64 bi…
This Micro Tutorial will teach you how to censor certain areas of your screen. The example in this video will show a little boy's face being blurred. This will be demonstrated using Adobe Premiere Pro CS6.
Video by: Mark
This lesson goes over how to construct ordered and unordered lists and how to create hyperlinks.

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now