• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 860
  • Last Modified:

Running NetMeeting as a service

I'm trying to get NetMeeting running on an unattended server to create a sort of "virtual office".

I have set up NetMeeting as a service and it starts and stops like you would expect.

The trouble is that it doesn't answer calls!  It works fine when run as an application just not as a service.

Is there a command line option or some other way to ensure that auto answer is on?
0
calumscott
Asked:
calumscott
  • 6
  • 4
1 Solution
 
GUEENCommented:
After the install did you:
1. open netmeeting and click | tools | remote desktop sharing | run the wizard?
2. When you have completely run the wizard and finish -
right-click the netmeeting icon in the bottom right-hand corner and choose 'activate desktop sharing'
3. Reboot.
(Did netmeeting start as a service?
It should prompt user for a UN and Password then provide a logon screen.)
4. Then click | Control | Send CTRL, ALT, Delete |
and log on normal.
0
 
GUEENCommented:
You might want to check into the Netmeeting development kit:
http://www.microsoft.com/Windows/NetMeeting/Authors/SDK/default.ASP
0
 
calumscottAuthor Commented:
That would be fine only I don't want to activate Remote Desktop Sharing.  I only want Netmeeting available to "call" to use as a sort of virtual "office space".

I have got NetMeeting running as a service (using instsrv.exe and srvany.exe) but I just have to get that "service" version of NetMeeting to answer calls automatically.
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
GUEENCommented:
So you are talking about reg hacks here?
OK -
[HKEY_CURRENT_USER\Software\Microsoft\Conferencing]
 "AutoAccept"=3Dhex:01,00,00,00

  [HKEY_CURRENT_USER\Software\Microsoft\Conferencing\Policies]
 "PersistAutoAcceptCalls"=3Dhex:01,00,00,00
 "NoAutoAcceptCalls"=3Dhex:00,00,00,00
0
 
calumscottAuthor Commented:
Thanks for that,

I've just tried them locally on my machine and nothing!  When I open NetMeeting the Auto Accept Calls option is not checked.

Does this work behind the scenes or have I missed something?
0
 
GUEENCommented:
Did you reboot?
0
 
calumscottAuthor Commented:
My appologies, I got it to work.

There were two things I had to do different though.

1. Identify the actual user account in HKEY_USERS.
2. The [HKEY_CURRENT_USER\Software\Microsoft\Conferencing\Policies] bit is actually [HKEY_USERS\Software\Policies\Microsoft\Conferencing]

But all in all a good answer, thank you.
0
 
GUEENCommented:
You are welcome - I was just about to post the revised registry hack when I go this email!

Thanks,
>Bev
0
 
calumscottAuthor Commented:
no probs, you don't happen to know how to restrict who can call into NetMeeting using reg hacks or similar do you?  I'll sort you some extra points if you do!
0
 
GUEENCommented:
I'll have to look into this later this weekend -
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

  • 6
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now