• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 389
  • Last Modified:

ODBC ? OO4O error

On my web site I am accessing an oracle database using oo4o and ODBC through ASP

I keep getting this message

Unable to make connection, ORA-00020: maximum number of processes (30) exceeded

Can anyone advise.

I have messed about with the connection pooling in the global.asa file for oo4o and with connection pooling in ODBC but to no avail.

I am using oracle version 8.0.6

Paul
0
plovett
Asked:
plovett
1 Solution
 
nigelroweCommented:
What version of Oracle are you using?
0
 
plovettAuthor Commented:
using oracle 8.0.6
0
 
nigelroweCommented:
I use 8.1i and have seen this message. It concerned the DB configuration. There is a DB variable which you can change to increase this number, but I can't remember which one (there are several). Maybe you could ask your DB administrator to check this out.
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

 
plovettAuthor Commented:
Thanks nigel..

There is a connection pooling setting in the global.asa file when using oo4o

I have tried to increase this but to no avail. I will follow your advice thanks.

Paul
0
 
omerfarooqueCommented:
You could check up in the instance manager on the Oracle Enterprise Manager, for any instances that appear to be hanging. Try to end that process. These kind of errors normally come up due to some process either occupying too much of the alloted CPU usage, or forking more processes.
It would be a good idea to check up the DB activites by a DBA if the database is in prodcution.
0
 
plovettAuthor Commented:
Thanks Omer

I am going to give it a whirl now.

Paul
0
 
lavinderCommented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this

question is:
Accept a comment - omarfarooque
Please leave any comments here within the next seven days.
 
PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!
 
lavinder
EE Cleanup Volunteer

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now