imap RPM dependencies

Hello

I wanna install imap RPM package on my RH7.1.
I have the following error mesages when using rpm

error: failed dependencies:
        libcrypto.so.0   is needed by imap-2000c-1.6.0
        libk5crypto.so.2   is needed by imap-2000c-1.6.0
        libkrb5.so.2   is needed by imap-2000c-1.6.0
        libssl.so.0   is needed by imap-2000c-1.6.0

Where could I find the above dependencies and how could I find them by myself next time? Thank you.

ezleeAsked:
Who is Participating?
 
jnbkzeConnect With a Mentor Commented:
Hi Ezlee,

OK this is how you do it.
1) You try and install the package and it fails with dependancy problems.
2) Now you need to find which packages provide the files that are depended on. I can't remember (it's been a long time since I've personally experienced failed dependancies) but I think sometimes you do get the package name that it's looking for. If not, do what I've successfully done in the past I go to http://rpm.org and I copy and paste the file name listed in the failed dependancies into the search field, and it lists the packages that contain that file.
3) You download the file and install that package first (and hopefully that package doesn't have other dependacies)
4) Once you've covered the dependancies of the original app you were trying to install you go back and install the package

Hope this helps

Regards,
jnbkze
0
 
jlevieCommented:
The files you need are on your RH 7.1 CD's and the packages are:

libcrypto - openssl-devel
libk5crypto & libkrb5 - krb5-devel
libssl - openssl-devel
 
0
 
qifsCommented:
Hi, jnbkze,

Thank you for your comments.
I will give the points to you since you showed me the way to solve the problem.

But libk5crypto.so.2 and libkrb5.so.2 do not live in RH7.1 rpm, but in RH6.2 update. Hope it works.


Anyway, thank you, jlevie.
0
 
ezleeAuthor Commented:
Sorry, jnbkze,

qifs is my other acctount. I gave the points to you.
 
ezlee
0
 
jlevieCommented:
Yes those libs are included in the 7.1 packages shown in my comment. And I suspect that the ones from the 6.2 release aren't going to work properly on 7.1. Too much has changed between 6.2 & 7.1.

The latest version on imap, openssl and krb5 for 7.1 are found in the 7.1 updates, imap-2000c-10, openssl-0.9.6-9, & krb5-devel-1.2.2-5. And those are the ones you should be trying to use with RH 7.1.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.