Go Premium for a chance to win a PS4. Enter to Win


Avoid overlapping the sub reports

Posted on 2001-09-04
Medium Priority
Last Modified: 2012-06-27
When the two sub reports are placed one below the other in Main Report. The second Subreport and first sub report are overlapped. How to avoid the overlapping. All the data in the first Sub Report should be printed followed by the Second sub report

Question by:v_pushparaj
  • 2
  • 2
  • 2
  • +2
LVL 12

Expert Comment

ID: 6453685
Right click on each sub-report, select Format and make sure the check-box named Can-Grow is checked.  Resize the sub-reports to approximately the smallest amount of vertical space you anticipate them taking up and try it again.


Accepted Solution

jtreat earned 90 total points
ID: 6454393
Create a separate section for each subreport. The second section will not start until the first section has finished.
LVL 12

Expert Comment

ID: 6454514

Without going into all the gory details here, the accepted convention in the Crystal Reports area is to post your suggestions as a comment and to let the questioner select an answer from amongst the suggestions.  This may or may not be what you have experienced in other areas of EE.

Please post in the Community Support area if you have any questions about this.

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.


Expert Comment

ID: 6454737
Hello jtreat, please read the following concerning questions vs. answers.

From EE Policy:

Advice for Experts on Providing Solutions Through Comments or Answers
Experts may post solutions to your question in the form of a comment or answer, so be sure to check
every email notification as soon as it arrives. Often, an Expert posts the solution to your problem
as a comment because it is early in the collaboration process and other issues may be involved. In addition,
it is common etiquette in some topics areas to always post comments and not answers. There are several
reasons behind this thinking:

Questions do not become prematurely locked and the collaboration process is not inhibited when the question
is indexed as open for proposed solutions.
The question-asker has the power to select the best solution rather than one that is simply suggested
as an answer.
Watch out for unclear or multiple-part questions. You can send a comment to the member requesting that
they rephrase or break up the question before you submit an answer.
If you don't know the answer, leave the question for someone else.
If you are unsure of your solution, post it as a comment rather than an answer. Members can accept comments
as solutions and award points for them.
You are only responsible for providing one reasonable answer.
You may review information about a member, including their grading history, by clicking on their member
If you're having a problem with a Member, you can refer it to us.

Thank you and welcome to EE,
Community Support

Ps. I will have to reject you proposed answer.

Expert Comment

ID: 6454983
I apologize if I should have posted as a comment instead as an answer.

The subreports do need to be allowed to grow but this alone will not resolve the described issue. Fields start in the vertical position defined for that field relative to the section they are in. As the first subreport (or any field) grows vertically there is always the possibility of the field growing past the next field(s). The resolution is to insert a new section after the first field. The next field is then placed in this second section which will not start until after the first field is finished. This will allow that field to grow without affecting the following fields. This can be repeateed as often as needed.

Expert Comment

ID: 6455033
No porblem, jtreat been there myself.


Expert Comment

ID: 6455527
Hi v_pushparaj,

To simplify what jtreat have said, why not put each subreport on a different section (by inserting a new section)? This will ensure that when each subreports grows, it will not overlap the other ones.


Author Comment

ID: 6458396
Thanks, It worked. Now it is not overlapping


Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hot fix for .Net Crystal Reports 10.2.3600.0 to fix problems with sub reports running on 64 bit operating systems ISSUE: Reports which contain subreports fail with error "Missing Parameter Value" DEPLOYMENT SERVER OS: Windows 2008 with 64 bi…
Hello everyone, Hope you find this as helpful as we did. We have on the company I work for an application built in Delphi V with Crystal Reports 8. We all know that Crystal & Delphi can be temperamental sometimes and the worst thing is, nearly…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…
Look below the covers at a subform control , and the form that is inside it. Explore properties and see how easy it is to aggregate, get statistics, and synchronize results for your data. A Microsoft Access subform is used to show relevant calcul…
Suggested Courses
Course of the Month6 days, 23 hours left to enroll

782 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question