Solved

Word 2000 Mail Merge Headers

Posted on 2001-09-06
14
247 Views
Last Modified: 2006-11-17
I have two machines with Word 2000 and I'm having a problem on one when trying to use mail merge with a Tab Delimited TXT file as the data source.

My Data is:
Name (tab) Address (tab) City
John (tab) Elm St. (tab) MyTown

Problem is, when I create document, open data source (no separate header file) and then click "Insert Merge Field"

I see....
Name_Address_City

Instead of the expected...
Name
Address
City

This works on one machine but not the other.  If I save the TXT file as a DOC file and then use it as a data source it works correctly.

Is there an optional setting for delimiters in the header record of a TXT Merge File???  Or, what's happening??
0
Comment
Question by:trims30
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 4
  • 2
14 Comments
 

Expert Comment

by:KBMacKenzie
ID: 6462303
Hi, trims30.  I am unable to duplicate your issue.  I've checked 4 different machines in my area, and all behave in the expected manner.

Therefore, I would begin suspecting either (a) corrupt normal.dot; (b) corrupt style in the main document; or (c) other unknown issues.

On the machine where the problem is being exhibited, can you close Word and rename normal.dot to normal.old, restart Word and see if the behavior continues.  If that doesn't clear it up, then...

Use the wizard's Edit the main document option to restore to a normal word file.  Go to Format / Styles and start going one-by-one through the styles... if there are any displaying strange things (such as Asian letters), use organizer to copy the style from your new normal.dot to the document.  If that doesn't clear it up, then...

Click on Help / Detect and Repair.  Make sure you have your installation CD's with you.

HTH
0
 

Author Comment

by:trims30
ID: 6462351
KBMacKenzie:

Renamed all normal.dot files,
looked at styles and compared them to working machine
and even did the Detect/Repair!

Still same results!

Now I'm really stumped!

Lee
0
 

Accepted Solution

by:
KBMacKenzie earned 50 total points
ID: 6462516
Well, Lee -- this is a bit perplexing.

I've searched the MS Knowledge Base and came up with zip.

Are you using the identical data file on both machines?
Are they both running the same version of Word 2000 (such as one is SR1(a) and the other is SR2)?
Where was the text file created?

Maybe where it's messing up:
At the open file explorer window where you select the text file, mark the box that says Select Method (near the open button) -- this should give you another dialog that may be of use (play and be creative!)

I'm fresh out of ideas.  Please post if you come up with a solution.

Thanks.
Karen
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 

Author Comment

by:trims30
ID: 6462716
Karen:
Same version of Office 2000 on both machines.  As a matter of fact, I found a third machine in the office that does exactly the same thing ie; A_B_C  for merge fields!

I'm puzzled too!

Thanks for your input,

Lee
0
 
LVL 44

Expert Comment

by:bruintje
ID: 6468203
Hi trims30,

Guess this has to do with the tab between teh names in your textfile, could you try to make a new textfile with just one row of data and put the tabs in by hand?

I'm not sure about this but from above it seems like word encounters a unicode problem with some sign and converts it to a _

:O)Bruintje
0
 
LVL 44

Expert Comment

by:bruintje
ID: 6468204
btw where does this file come from?
0
 

Author Comment

by:trims30
ID: 6468525
bruintje:

The Merge Data File in my example is created in Word and saved as Text File. If I save as a DOC file it will work correctly.

If I create the file in Notepad, WordPad, or Excel, I also get the same results when using tab delimited header row.

If I use commas rather than tabs it also works correctly.

Somehow word is interpreting TABS in the Header as Underscore characters....

Beleive it or not!
0
 

Author Comment

by:trims30
ID: 6468548
bruintje:

Another curiosity is that if I use MSQuery to open the Tab Delimited TEXT file (either via WORD or Excel-Get External Data) I have the same results  "A_B_C" as my single field name rather than:
A
B
C

Lee
0
 
LVL 44

Expert Comment

by:bruintje
ID: 6468595
funny i see this happening here also, the data is correctly displayed in a table in the document, but the header is being underscored.....
0
 

Author Comment

by:trims30
ID: 6468644
bruintje:
Glad you could duplicate the problem.

Now all we need is an answer as to why it happens.

Lee
0
 

Author Comment

by:trims30
ID: 6468906
Eureka!  I found the answer!


The ODBC Text driver can't convert tab-delimited text files.

There is a way to work around this problem:

Use a comma-delimited text file.

Specify the Text Files conversion method when attaching the data source.

To specify the Text Files conversion method
In the Mail Merge Helper, click Get Data, and then click Open Data Source.

Click your data source, select the Select method check box, and then click Open.

In the Confirm Data Source dialog box, click Text Files, and then click OK.

Important
If there is a Text Files via ODBC option, don't choose it. Click the Text Files option.


In all fairness, Karen MacKenzie had mentiond exactly that but offered no explanation..

"At the open file explorer window where you select the text file, mark the box that says Select Method
(near the open button) -- this should give you another dialog that may be of use (play and be creative!)"

0
 

Author Comment

by:trims30
ID: 6468907
Eureka!  I found the answer!


The ODBC Text driver can't convert tab-delimited text files.

There is a way to work around this problem:

Use a comma-delimited text file.

Specify the Text Files conversion method when attaching the data source.

To specify the Text Files conversion method
In the Mail Merge Helper, click Get Data, and then click Open Data Source.

Click your data source, select the Select method check box, and then click Open.

In the Confirm Data Source dialog box, click Text Files, and then click OK.

Important
If there is a Text Files via ODBC option, don't choose it. Click the Text Files option.


In all fairness, Karen MacKenzie had mentiond exactly that but offered no explanation..

"At the open file explorer window where you select the text file, mark the box that says Select Method
(near the open button) -- this should give you another dialog that may be of use (play and be creative!)"

0
 

Author Comment

by:trims30
ID: 6468919
Thanks to everyone for their help!

While Karens answer was not specific enough to rate an "A" I atleast gave it a "Good" rating.



At the open file explorer window where you select the text file, mark the box that says Select Method
(near the open button) -- this should give you another dialog that may be of use (play and be creative!)

By then selecting TEXT File , the tab delimited file opens correctly.
0
 
LVL 44

Expert Comment

by:bruintje
ID: 6468940
glad you found an answer :O)Bruintje
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article descibes how to create a connection between Excel and SAP and how to move data from Excel to SAP or the other way around.
Access developers frequently have requirements to interact with Excel (import from or output to) in their applications.  You might be able to accomplish this with the TransferSpreadsheet and OutputTo methods, but in this series of articles I will di…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question