[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 487
  • Last Modified:

Samba problem

Hi,

I've got a weard problem i've got a samba server but it isn't recognized by a windows 95 PC. The weard thing is
The Windows PC get it's IP from my Linux DHCP server, so it has an connection.

I can ping both ways but the samba server isn't recognized.

Does anyone had this prblem before?

thanks in advance

fcco
0
fcco
Asked:
fcco
  • 6
  • 3
  • 2
  • +3
1 Solution
 
ahoffmannCommented:
on W98: did you see it using
   net view \\linuxserver
0
 
dilligaffuqCommented:
Can you see the samba share from the linux box it's self?

smbclient -L \\linuxserver


Do you have other machines on the network that can or can't see it?

dill
0
 
fccoAuthor Commented:
Hi,

dilligaffuq : Yes i can see it on the linux server, and that's the only one.

ahoffmann : Netview brings up nothing exept the winPc itself.

I think it has something with nmbd but don't know what

fcco
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
ahoffmannCommented:
ok, then please post result of
   ipconfig -all
from w98, and
   egrep -i 'workgroup|netbios|master|browse|secure' /etc/smb.conf
   ps ax|grep mbd
from linuxbox
Can you ping linuxbox from w98?
0
 
dilligaffuqCommented:
Also, check /var/log/samba/log.smb  or where ever you smaba log file is.  See if it actually tried to get into the linux box and was stopped for some reason without kicking an error back to windows.
0
 
ifinchamCommented:
Hi,

To check if its a netbios name resolution issue, just do the net view command using the ip address of the samba server - e.g. 'net view \\172.16.16.1' .

Rgds
0
 
fccoAuthor Commented:
Hi,

Had not much time so sorry for the late reply,

Ahoffmann:
egrep -i 'workgroup|netbios|master|browse|secure'
/etc/smb.conf

returns:

Workgroup: groep1
Netbios name = gr1
prefered master = yes
domain master = yes

--------------------
ps ax|grep mbd

returns:

784  ?     S  0:00  nmbd
789  pts/0 S  0.00  grep mbd

----------------------


dilligaffuq:

My user name = gr1ws1 , IP = 192.168.80.43
Servername = gr1, IP = 192.168.80.34

Most common errors in my log file:

samba.log:

gethostbyaddr failed for 192.168.80.43

Denied connenction for 192.168.80.43

file unit: information only reguested 10000 open files 1014 are available

samba.log.gr1ws1:

username gueist is invalid for this system

--------------------------------------------
ifincham:

net view doesn't comes up with anything so theres probebly something wrong with the netbios name resulation.

------------------------------------

This is my smb.conf file i've configured it with SWAT

[global]

  client code page = 437
  workgroup = groep1
  netbios name = gr1
  security = share
  encryp passwords = yes
  min password length = 1
  map to guest = bas user
  log file = /var/log/samba-log.%m
  os level = 200
  preferd master = yes
  dns proxy = no

[homes]

  comment = Home directories
  path = /home/%u
  writeable = yes
  create mask = 0750

[public]

  comment = public
  path = /home/public
  writeable = yes
  guest ok = yes

-----------------------------------

Thanks in advance

fcco

0
 
ahoffmannCommented:
there is no smbd running, or will it be started by inetd?
0
 
fccoAuthor Commented:
Hi,

it start's with inetd and it is running

0
 
jscartCommented:
Do you have ipchains active?
0
 
fccoAuthor Commented:


no

thanks

fcco
0
 
kathotiaCommented:
You will get the answer to your problem at www.pcquest.com
There is a full article with necessary step by step configuration on SAMBA and WIN95.
0
 
jscartCommented:
run netstat -an on the linux box

what's listening on ports 137,138,139

if the services is there, run ipchains -L
if anything shows up other than:


Chain input (policy ACCEPT)
Chain forward (policy ACCEPT)
Chain output (policy ACCEPT)

you'll have to open the ports on your linux box.
and double check the obvious. Workgroup name
and try changing the smb domain options to:

domain master=no
preferred master=no

0
 
fccoAuthor Commented:
0
 
fccoAuthor Commented:
Nobody realy gave me an answer but you were the best help therefore i give you the points,

Thank you all,

fcco
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 6
  • 3
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now