Solved

Help Me To Access Internet AND Get Away From M$ Windows!

Posted on 2001-09-09
18
253 Views
Last Modified: 2010-07-27
I am a Linux newbie and have just installed eDesktop 2.4 from Caldera's OpenLinux. My machine is an eMachine i366 with 96meg RAM.  In Windows I am connected to cable through an ethernet network card (using DHCP).

My problem is when I open up Netscape and try to go to an internet site, it gives me an error message that says, "Warning: the following hosts are unknown:
     home.netscape.com
     home6.netscape.com
     internic.net"

From Webmin I was able to establish the following:
1. There is no PPP account.
2. There is no DHCP server.

My default server name in my Linux machine is MyName.nodomain.nowhere.

When I typed ifconfig, I got:
Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UPLOOKBACK RUNNING MTU:3924 METRIC:1

I don't know a lot about networking and even less when it's in Linux.

Please help and thanks!
0
Comment
Question by:limva
  • 9
  • 5
  • 4
18 Comments
 
LVL 40

Expert Comment

by:jlevie
ID: 6470532
If all you see is the loopback interface in the output of ifconfig, then there's no ethernet card configured. That might be becasue you haven't told the system to enable the NIC and to use DHCP or the system may not have the correct drivers for your NIC. What NIC card is in the machine?
0
 

Author Comment

by:limva
ID: 6473346
Sorry for the delay in replying, jlevie.

I looked in the control panel in Windows and it tells me that I have a 3Com Etherlink III ISA (3C509/3C509b) in ISA mode.  I hope that means anything.

0
 
LVL 40

Expert Comment

by:jlevie
ID: 6475081
Okay, since it is a 509b the card is probably in PnP mode. It might work that way if PnP mode in the system BIOS is disabled (it your BIOS allows that). Alternatively you can get a diagnostic program from http://www.scyld.com/diag/3c5x9setup.html or from 3Com's site (http://support.3com.com/infodeli/tools/nic/3c509/3c5096.1.htm) that can be used to take the card out of PnP mode and give it a fixed IRQ & I/O port that isn't being used by anything else. You'll want to look at the output of 'dmesg | grep -i irq', the contents of /proc/interrupts, and the contents of /proc/pci to make a list of what IRQ's are currently being used by other devices. From that list you can pick a free IRQ to use on the 3c509. Note that you may also need to tell your system BIOS to reserve the IRQ that you use for the card for 'Legacy' or ISA use. To avoid all the problems that PnP cards cause I always manually set the IRQ for any cards that have that capability. I think that when you get the PnP issue sorted out that your system will be able to see the network.
0
 
LVL 1

Expert Comment

by:swapsthegreat
ID: 6492638
hi,

     An easy way out is to use the netconf utility. if it is not installed you'll have to install the linuxconf rpm. in netconf you can specify your protocol as dhcp. enter the name of the netdevice as eth0 and go to the kernel module field and press ctrl-x . it will give u a list of cards. select your card and accept. if it asks you to make changes then click do it. i dont think ull need to restart.

0
 

Author Comment

by:limva
ID: 6494171
Hi swapsthegreat, thanks for your comment.  I've lost access to my Linux drive after I had to reinstall Windows in my C drive.  I'll try your solution after I get back into my Linux drive - hopefully in the next couple of days... :)
0
 

Author Comment

by:limva
ID: 6495528
Hello swapsthegreat, I just got back into my Linux drive. I went to Webmin (I think Webmin will be easier on me), and to Network Configuration, then to Network Interfaces.

The only interface showing as now active is:
Name: lo
Type: Loopback
IP Address: 127.0.0.1
Netmask: 255.0.0.0
Status: Up

Interfaces Activated at Boot Time:
Name: eth0
Type: Ethrnet
IP Address: From DHCP
Netmask: 255.255.255.0
Activated at boot? Yes

The second interface showing is lo, which has the same configuration as lo above.  The next interface is:

Name: plip0
Type: PLIP
IP Address: 10.0.0.1
Netmask: Automatic
Activate at boot? Yes

I don't know if the above info are useful to you or to anybody.  An interesting thing I noticed is that eth0 is not included in the list of active interfaces, but only those activated at boot up.

0
 

Author Comment

by:limva
ID: 6495532
A comment to jlevie: I don't think the ethernet card was missed by linux because it was detected at bootup.  I'm not saying that in an authoritative manner because I know very little about networking :)
0
 
LVL 40

Expert Comment

by:jlevie
ID: 6496424
According to what webmin shows the NIC is visible to the system and it is configured. Now we know that it isn't visible in the output of 'ifconfig -a' because it isn't negotiating a DHCP assigned IP. The likely cause of the failure for the card to get a DHCP assignment is what I addressed in my previous comment. 3c509b cards work fine with Linux when they aren't in PnP mode, but I think I've only seen a few cases where they worked when in PnP mode.
0
 
LVL 1

Expert Comment

by:swapsthegreat
ID: 6496710
hi

if u dont have netconf u can manually configure your card as follows:

edit /etc/sysconfig/network-scripts/ifcfg-eth0 file

Leave the ip address and net mask field blank
and set
ONBOOT="yes"
BOOTPROTO="dhcp"
save the file
and make it executable using chmod +x ifcfg-eth0
ull need to reload ur network
go to ur / directory
and type /etc/rc.d/init.d/network reload

tell me if it doesnt work
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:limva
ID: 6498813
Thanks to both of you for your comments.

Swapsthegreat, I went into the ifcfg-eth0 file and found the following:

#!/bin/sh
#>>>Device type: ethernet
#>>>Variable declarations:
DEVICE=eth0
IPADDR=192.168.1.2
NETMASK=255.255.255.0
NETWORK=192.168.1.0
BROADCAST=192.168.1.255
GATEWAY=192.168.1.1
ONBOOT=yes
DYNAMIC=dhcp
#>>>End variable declarations

Do I clear the IP address and the netmask?
0
 
LVL 1

Expert Comment

by:swapsthegreat
ID: 6499779
hi

     yes clear both and comment out the network,gateway and broadcast fields. I'm sendin u my file so that u get a better idea.i think u have mistyped the dynamic= field in ur posting. heres my file

DEVICE="eth0"
IPADDR=""
NETMASK=""
ONBOOT="yes"
BOOTPROTO="dhcp"



u leave the ipaddr and mask blank because it is dynamically assigned by ur isp.




0
 

Author Comment

by:limva
ID: 6500281
No, there was no "BOOTPROTO=" field in my file, only "DYNAMIC=".  I'll try your suggestion and I'll let you know what happens.  Thanks!
0
 

Author Comment

by:limva
ID: 6500415
No, there was no "BOOTPROTO=" field in my file, only "DYNAMIC=".  I'll try your suggestion and I'll let you know what happens.  Thanks!
0
 

Author Comment

by:limva
ID: 6500599
Hi swapsthegreat, I cleared out the IP address and the netmask and rebooted the system.  It still couldn't find anything on the internet.  I did not clear network, broadcast or gateway though.

I should also mention to jlevie that my NIC is not PnP but legacy.
0
 
LVL 40

Accepted Solution

by:
jlevie earned 25 total points
ID: 6501509
If the NIC is an ISA card, did you tell the BIOS to reserve that IRQ for ISA use? And more importantly have you checked to see if there is a resource conflict, per my earlier comment?
0
 
LVL 1

Expert Comment

by:swapsthegreat
ID: 6502135
hi

     i dont think the problem is with card detection. ull obviously have to comment out the gateway and broadcast fields and try again
0
 

Author Comment

by:limva
ID: 6503571
I deleted the 3 other fields (NETWORK, BROADCAST and GATEWAY) but it still didn't work.

I noticed something though when the system is booting up.  When it comes to DHCP Servers, it says "skip".  So maybe the DHCP Server is not being initialized when the systems boots.  If that is so, how do I get it to initialize?

0
 
LVL 1

Assisted Solution

by:swapsthegreat
swapsthegreat earned 25 total points
ID: 6505909
type netconfig
it will ask u whether to enable networking
select yes
then it will give an ip configuration screen
select Use DHCP by pressing space
reboot and try
lemme kno
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now