Access Data to Oracle, ODBC problem

I built a VB script that will load data from Access to Oracle on a daily basis.  I am trying to automate this but the problem I have is that the ODBC driver version 8.01.06.00 does not provide a password field to be saved in the DSN file.  Everytime the program runs, it asked for a password.  How can I fix this problem?  I tried to update the ODBC.INI registry to include the password but this didn't work.
gizman2Asked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
atulnConnect With a Mentor Commented:
Hi,

To save the passwword in DSN file. U have to manually open the open the file and add following data in the file and save it. To open the DSN file U can use the notepad.

Note that Name of the Server is the host string U entered to connect to the oracle. UseID and Password U enter as it is without any quotes.

[ODBC]
DRIVER=ORACLE ODBC DRIVER
UID=userIDForOracle
PWD=PasswordToconnectToOracle
SERVER=NameOfServer

E.g.

DRIVER=ORACLE ODBC DRIVER
UID=SCOTT
PWD=TIGER
SERVER=MYORACLE
0
 
RMZCommented:
hi
open your odbc
and chane user to youruser/password
---rmz---
0
 
gizman2Author Commented:
I take it that the DSN file that you are talking about is not the same file in the ODBC.INI registry?  If you are talking about a different file, where can I find it?
0
 
gizman2Author Commented:
This answer is good for the older version of DSN.  The newer version, which use Microsoft Jet Engine, can be opened at the registry.  I found out that we cannot add PWD to this registry to be valid.  The rest of it gets complicated but the workaround is to modify the query on the Access side to include the PWD.  This method works.  Thanks for the help.

0
 
atulnCommented:
Hi,

  The example I gave in my first solution relates with the FileDSN. The FileDSN U can carry with U at Installation time very easily or add in Installation kit. That makes it simple to use and easy to handle. Infact I should have mentioned this in my first mail. One more thing rather than using normal DSN keyword for connection U have to use

FILEDSN="PHYSICAL PATH OF DSN FILE"

I hope this is clear and this will solve your problem. Don't go into complexity of changing registry entry.

Regards,
Atul
0
All Courses

From novice to tech pro — start learning today.