Samba and WindowsME, I see shares on linux machine but cannot access


I am having difficulty getting Samba to work. My objective is to be able to
access a directory on my linux computer from a Windows computer on the same
network. I have installed the samba rpm and am able to get the smbd and
nmbd daemons to work. I am also able to ping my windows computer from the
linux computer and vice versa. In the smb.conf file I have set up the
following service:

[alec]
comment = /home/alec
browseable = yes
read only = no
create mode = 0750
directory = /home/alec

where /home/alec is the directory on the linux machine that I wish to
access from the Windows computer.

The linux computer appears in Network Neighborhood underneath the name of
the workgroup (that`s good). When I double click on the computer name, I
then see a folder named "alec", which is the name of the service.
When I double click on the folder, I am prompted for a password. I then
enter the password for the user named alec on the linux computer and it is
rejected. I have tried all other possible passwords, with no luck. I am
able to log in to the user "alec" with the password set for the
account.

I have set up another user on the linux machine with the same name as on my
Windows machine, e.e. Alec McAndrew. I have assigned this user the same
password on the linux machine as on the Windows computer. I have the
following entry in the smb.conf

[homes]
comment = Home directory
browseable = yes
read only = no
crate mode = 0750

I am able to see this service underneath the linux computer in , but when I
click on it I get the message: "the share name was not found".

Please note that in the networking properties the computer has the name
BC854431-G, given to me by the cable company for purposes of gaining access
to the Internet via cable modem. I have also read that NetBios names may be
relevant, but I am not sure what that name is or exatly what the relevance
might be to the above difficulties that I am having.

Thanks for anyone`s help.
amcandrewAsked:
Who is Participating?
 
BlackDiamondConnect With a Mentor Commented:
amcandrew,

Try using the smbpasswd utility to set the smb password for that user.  If the user is not there yet, you may need to add an entry to the /etc/samba/smbpasswd file (and make sure to alias the smb username to the local user name).  Keep in mind that smbd does the authentication from the tokens that are created by smbpasswd (and stored in the smbpasswd file) not from the /etc/passwd file (where your normal authentication is done).  You are essentially creating 2 different users with the same name.

As for the home share, I don't see a path statment in what you listed above.  Don you have the path in your config?
0
 
kannabisCommented:
You also must enable "encrypted password" sections in the smb.conf file

encrypt passwords = yes, just before the:

smb passwd file = /etc/samba/smbpasswd, like BlackDiamond suggested.
0
 
swapsthegreatConnect With a Mentor Commented:
try adding this line to your [alec] share

public = yes

It wont ask for a password then.

As for the  [homes] it doesnt work for me as well
i guess maybe u need to specify a path for all home directories separately
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
amcandrewAuthor Commented:
1. By using guest ok = yes I have gained access from my Windows machine

2. I have not yet had success with the following: [homes], creating a user on the linux_machine with the exact same user name as my user name on the Windows machine, and entering the same password in smbpasswd program as I use when I log on to Windows. (I gather that the Unix password may be different)  I wasn't sure what BlackDiamond meant by aliasing, but I can say that I used the same user name when setting up the Samba password file and when I look in the smbpasswd file, I see the proper user name and UID.
0
 
CleanupPingCommented:
amcandrew:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
troopernCommented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
Split between BlackDiamond & swapsthegreat.
Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

troopern
EE Cleanup Volunteer
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.