Solved

linux web and ftp server

Posted on 2001-09-11
5
143 Views
Last Modified: 2013-12-16
refer to http://www.experts-exchange.com/jsp/qManageQuestion.jsp?ta=linux&qid=20181417

Dear sir,

    I've installed RH 7.1 , with ftp and web server.However, I found that if I access the web server and ftp server from localhost, it is okay. But the computers on the network cannot access it.(I type the ip address of the server).Do you know what's the problem?
    BTW, in which file can I modify the init level such that when I boot into the Red Hat, I will go into graph mode instead of text mode?Thanks!
0
Comment
Question by:hpchong7
  • 3
  • 2
5 Comments
 
LVL 4

Expert Comment

by:newmang
ID: 6476038
1) The runlevel is set in the /etc/inittab file.
In this file you will find a line reading  as follows :

id:3:initdefault:

Change the 3 to a 5 and the system will now boot into the GUI.

2) How does your system resolve host names? I found on my system that telnet & ftp did not accept external connections until I added an entry for my network DNS host.

Cheers - Gavin
0
 
LVL 2

Author Comment

by:hpchong7
ID: 6476647
Dear Gavin,
   May be I am the same as your case!!!Where do I add entry for my network DNS host?Thank you so much!
0
 
LVL 4

Accepted Solution

by:
newmang earned 0 total points
ID: 6478062
hpchong

The easiest way is to run linuxconf (as root) then select the networking section and then the name server section

The manual way to do it is to create (or modify) the /etc/resolv.conf file and add the following lines:

search domain.name.one domain.name.two
nameserver my.dns.ip.address

where the first line defines the domain names to use and the second defines the ip address of your DNS host.

You may also have to edit the /etc/nsswitch.conf file to ensure that the hosts: line includes the dns parameter.

linuxconf is the easier way to go about it.

Cheers - Gavin
0
 
LVL 2

Author Comment

by:hpchong7
ID: 6478329
I found that inside my etc/resolv.conf file:

search localhost.localdomain
nameserver  x.x.x.x

while inside /etc/nsswitch.conf file:
hosts:files dns
is already exists,

But I still cannot accept external web,ftp and telnet connection.........
0
 
LVL 2

Author Comment

by:hpchong7
ID: 6478525
Dear Gavin,

  At last I found it's the problem of the linux firewall, which block all external access by default!Anyway, thank you very much for your help which taught me a lot!
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Guacamole cut and paste issue 3 72
mcrypt_create_iv() is deprecated 4 151
Coding C# in Linux 8 65
SonarQube on Linux vs Windows 3 27
Over the last ten+ years I have seen Linux configuration tools come and go. In the early days there was the tried-and-true, all-powerful linuxconf that many thought would remain the one and only Linux configuration tool until the end of times. Well,…
Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question