Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

"send to:" on form properties is grayed out

Posted on 2001-09-11
11
Medium Priority
?
176 Views
Last Modified: 2013-12-24
FrontPage 2000.  I have created a form and want the results sent via email.  Server extensions are installed and running fine (I get no messages about them NOT being installed).  The web works fine.  But for some reason when I go into the form properties, my only option is "send to other".  I have no way to enter an email address or filename.  I've done this successfully before with no problem.  I'm baffled.  I can ping the SMTP server OK from the webserver.  Any ideas?  I've uninstalled and reinstalled the Server Extensions a couple of times to no avail.

TIA, Dennis
0
Comment
Question by:Dennis_Todd
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
11 Comments
 
LVL 7

Expert Comment

by:ClassyLinks
ID: 6476448
I've run into this before with another user.

When you open the form properties, choose options and fill in the E-mail Results from there.

HTH
0
 

Author Comment

by:Dennis_Todd
ID: 6477162
Yeah, I had seen that work before too; unfortuantely, because the "send to" radio buttons has the "send to other" button checked.  If you click options, a "Options for Custom Form Handler" dialog appears which is totally different than the usual dialog that allows you to enter email info, etc.
0
 
LVL 7

Expert Comment

by:ClassyLinks
ID: 6477183
Can you post some html so that I can see what's going on from here?
0
Simplify Your Workload with One Tool

How do you combat today’s intelligent hacker while managing multiple domains and platforms? By simplifying your workload with one tool. With Lunarpages hosting through Plesk Onyx, you can:

Automate SSL generation and installation with two clicks
Experience total server control

 
LVL 7

Expert Comment

by:ClassyLinks
ID: 6477187
OR...

What happens when you go into the HTML and REMOVE whatever is in the "action" for the form?  Does that re-enable the options in the dialog box?
0
 

Author Comment

by:Dennis_Todd
ID: 6477318
I removed the "action" but it had no effect.  Here's the html for the page:

<html>

<head>
<meta http-equiv="Content-Language" content="en-us">
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
<title>Contact Us!</title>
<meta name="GENERATOR" content="Microsoft FrontPage 4.0">
<meta name="ProgId" content="FrontPage.Editor.Document">
<meta name="Microsoft Theme" content="pstmdrn 111, default">
<meta name="Microsoft Border" content="tlb, default">
</head>

<body>
<p><img border="0" src="images/contact_us_computer.gif" width="207" height="228" align="right"></p>
<h3><font face="Comic Sans MS">Suggestions?</font></h3>
<h3><font face="Comic Sans MS">Comments?</font></h3>
<h3><font face="Comic Sans MS">Stuff you'd like to see us doing?</font></h3>
<h3><font face="Comic Sans MS">Stuff you'd like to see us STOP doing?&nbsp;</font></h3>
<h3><font face="Comic Sans MS">Something you'd like help with?</font></h3>
<h1>Enter it here....</h1>
<form method="POST" onsubmit="return FrontPage_Form1_Validator(this)" target="_blank" name="FrontPage_Form1" language="JavaScript">
  <table border="0" width="100%" bgcolor="#C0C0C0">
    <tr>
      <td width="50%">Your name (<i><font color="#FF0000">required</font></i>):</td>
      <td width="50%"><!--webbot bot="Validation" S-Display-Name="Name"
        B-Value-Required="TRUE" I-Minimum-Length="1" I-Maximum-Length="128" --><input type="text" name="Name" size="37" maxlength="128"></td>
    </tr>
    <tr>
      <td width="50%">Your email address (<i><font color="#FF0000">required</font></i>):</td>
      <td width="50%"><!--webbot bot="Validation" S-Display-Name="email address"
        S-Data-Type="String" B-Allow-Letters="TRUE" B-Allow-Digits="TRUE"
        S-Allow-Other-Chars="@._" B-Value-Required="TRUE" I-Minimum-Length="1"
        I-Maximum-Length="128" --><input type="text" name="email" size="37" maxlength="128"></td>
    </tr>
    <tr>
      <td width="50%">&nbsp;</td>
      <td width="50%">&nbsp;</td>
    </tr>
    <tr>
      <td width="50%">Your message (<i><font color="#FF0000">required</font></i>):</td>
      <td width="50%"><!--webbot bot="Validation" B-Value-Required="TRUE"
        I-Minimum-Length="1" --><textarea rows="8" name="Message" cols="33"></textarea></td>
    </tr>
  </table>
  <p><input type="submit" value="Submit" name="B1"><input type="reset" value="Reset" name="B2"></p>
</form>
&nbsp;</body>

</html>
0
 
LVL 7

Expert Comment

by:ClassyLinks
ID: 6477882
I copied your code into my FP....sure enough when I opened the page, the option was grayed out.....but when I clicked on Send to, it let me put in anything I wanted.

Are you not able to do that?
0
 

Author Comment

by:Dennis_Todd
ID: 6478041
interesting.  Not all.  I try to click, but the radio buttons (except for "send to other") are completely grayed out as well as the text boxes.  I can click and type all over the place, but nothing happens.  Is your "send to other" radio button checked?  Mine is checked and the combo box next to it lists:  "Custom ISAPI, NSAPI, CGI or ASP script".  Maybe because those settings are there, it won't let me select anything else.  That's certainly why I don't get a normal dialog box in response to clicking the options box:  I'm getting options specific to sending to a script...

Thanks for keeping at it!!

D
0
 
LVL 7

Expert Comment

by:ClassyLinks
ID: 6478171
Ok...try this.....(don't forget to paste it into notepad before you paste into FP to get rid of the formatting)

<head>
<meta http-equiv="Content-Language" content="en-us">
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
<title>Contact Us!</title>
<meta name="GENERATOR" content="Microsoft FrontPage 4.0">
<meta name="ProgId" content="FrontPage.Editor.Document">
<meta name="Microsoft Theme" content="pstmdrn 111, default">
<meta name="Microsoft Border" content="tlb, default">
</head>

<body>
<p><img border="0" src="images/contact_us_computer.gif" width="207" height="228" align="right"></p>
<h3><font face="Comic Sans MS">Suggestions?</font></h3>
<h3><font face="Comic Sans MS">Comments?</font></h3>
<h3><font face="Comic Sans MS">Stuff you'd like to see us doing?</font></h3>
<h3><font face="Comic Sans MS">Stuff you'd like to see us STOP doing?&nbsp;</font></h3>
<h3><font face="Comic Sans MS">Something you'd like help with?</font></h3>
<h1>Enter it here....</h1>
<form method="POST" onsubmit="return FrontPage_Form1_Validator(this)" target="_blank" name="FrontPage_Form1"
language="JavaScript">
 <!--webbot bot="SaveResults" S-Email-Address="eehelp@classylinks.ca"
 S-Email-Format="TEXT/PRE" -->
 <table border="0" width="100%" bgcolor="#C0C0C0">
   <tr>
     <td width="50%">Your name (<i><font color="#FF0000">required</font></i>):</td>
     <td width="50%"><!--webbot bot="Validation" S-Display-Name="Name"
      B-Value-Required="TRUE" I-Minimum-Length="1" I-Maximum-Length="128" --><input type="text" name="Name"
size="37" maxlength="128"></td>
   </tr>
   <tr>
     <td width="50%">Your email address (<i><font color="#FF0000">required</font></i>):</td>
     <td width="50%"><!--webbot bot="Validation" S-Display-Name="email address"
      S-Data-Type="String" B-Allow-Letters="TRUE" B-Allow-Digits="TRUE"
      S-Allow-Other-Chars="@._" B-Value-Required="TRUE" I-Minimum-Length="1"
      I-Maximum-Length="128" --><input type="text" name="email" size="37" maxlength="128"></td>
   </tr>
   <tr>
     <td width="50%">&nbsp;</td>
     <td width="50%">&nbsp;</td>
   </tr>
   <tr>
     <td width="50%">Your message (<i><font color="#FF0000">required</font></i>):</td>
     <td width="50%"><!--webbot bot="Validation" B-Value-Required="TRUE"
      I-Minimum-Length="1" --><textarea rows="8" name="Message" cols="33"></textarea></td>
   </tr>
 </table>
 <p><input type="submit" value="Submit" name="B1"><input type="reset" value="Reset" name="B2"></p>
</form>
&nbsp;</body>


Can you make changes now?
0
 

Author Comment

by:Dennis_Todd
ID: 6480543
That did it!  I tested it all the way through sending and receiving the email.

It still REALLY annoys me, though, that the dialog box doesn't work properly.  I wonder what criteria FrontPage is using to decide whether or not to gray the edit boxes???  Obviously (since the functionality is now working for me) I've got the extensions configured properly, but it's as if FrontPage is disallowing the email feature because it doesn't think things are setup properly.

At any rate...thank you SO much!!  You've posed everything as comments so I can't award the points.  If you'd like to send one more message as an answer, I'll award you the points--you certainly desserve them!

Thanks again,

Dennis
0
 
LVL 7

Accepted Solution

by:
ClassyLinks earned 200 total points
ID: 6480574
Glad it is working for you.

Forms are not an extension function.  Try a detect & Repair (from the help menu).

You should see a button in the blue section of each of my comments that says "Accept Comment as Answer".

Click on one of them and you will be able to grade my responses.

FYI  99% of experts will never propose and "Answer" because it takes the question off the active list and limits the amount of input you are going to get. 8-)
0
 
LVL 7

Expert Comment

by:ClassyLinks
ID: 6483253
Thanks for the A.

Come back any time 8-)
0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When deciding to adopt any help desk solutions many factors should be explored before taking decisions. This will change from business to another but in general there are some kind of rule of thumb. Here are some quick tips: Do we need only ticket…
Introduction In this tutorial, I'll explain how to create an animated progress meter in a wireframe prototype developed using Axure RP 7.0 - a leading prototyping tool for designing web sites and software. (For more information about Axure and gett…
The purpose of this video is to demonstrate how to create a Printer Friendly PDF on a WordPress Page. This will be demonstrated using a Windows 8 PC. Tools Used are Photoshop, Awesome Screenshot” Google Chrome Extension, and SmallPDF.com Log…
The purpose of this video is to demonstrate how to properly insert a Vimeo Video into a WordPress site or Blog. This will be demonstrated using a Windows 8 PC. Go to your WordPress login page. This will look like the following: mywebsite.com/wp…

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question