Solved

Weird FDD Problem

Posted on 2001-09-13
22
402 Views
Last Modified: 2010-04-27
I recently installed Windows 2000 on this machine. Everything went peachy, and all my hardware worked fine except for my FDD. For some reason when I try to access a disk, after about 30 seconds, the machine tells me the disk is not formatted and asks if I would like to format it. If I dont reply 'no' within about 5 seconds, my machine just reboots, no "Your settings are being saved ..." etc, just *boom*, screen goes blank and the machine begins to reboot. If I do quickly press 'no', then everything is fine, BUT if I try and access the FDD again, then the machine reboots almost immediatly upon double clicking the FDD icon in my computer. What could be POSSIBLY causing this ?

For the record ..
- The FDD isnt faulty, it worked fine under Windows ME, and still works fine if I boot my machine using a boot disk and access the drive then.
- THe disks Im using are formatted, and do have things on them.
- My hardware consists of:
    Epox D3VA Mainboard
    Intel Celeron 466 MHz Processor
    128 MB RAM
    Creative Labs Riva TNT2 Ultra using the latest detonator drivers from nVidia
    Xitel Storm Platnium Sound Card
    Adaptec AHA-152x SCSI Host Adapter

Any sort of help would be MUCH appreciated, even articles on problems that seem to be related to this one.

Does anyone think it would be worthwhile reinstalling the OS (hopefully a last resort) ?

I found this article on Microsoft's support pages, and even though its quite old, and only says its for NT I did try it, but with no success.
http://support.microsoft.com/support/kb/articles/Q141/8/31.ASP

Regards,
DARK LiGHT
0
Comment
Question by:darklight
22 Comments
 
LVL 16

Accepted Solution

by:
Kyle Schroeder earned 150 total points
ID: 6479678
Have you tried updating your BIOS?  The page doesn't mention floppy drive problems specifically, but frequently other fixes are made.  The Microsoft KB article mentioned conflicts between BIOS and video cards...

http://www.epox.com/html/english/support/motherboard/bios/d3va.htm

-d
0
 
LVL 7

Expert Comment

by:WiZaRd
ID: 6479833
got a spare FDD cable ?
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 6480121
I would also suggest checking the device manager for shared IRQ's. If anything else is sharing the FDD IRQ, you could be having problems.

ALso - Get the newest BIOS and Load default settings after documenting your present settings.

Last options.

A) Check that you have win2k comparible hardware using the Win2k HCL list.

b) Clean out the CMOS RAM totally and try a new install or instal into a seperate directory.

c) Try turning off Plg N Pray in the BIOS and set things up manually.

I hope this helps !
0
 
LVL 16

Expert Comment

by:Kyle Schroeder
ID: 6480223
Have you tried updating your BIOS?  The page doesn't mention floppy drive problems specifically, but frequently other fixes are made.  The Microsoft KB article mentioned conflicts between BIOS and video cards...

http://www.epox.com/html/english/support/motherboard/bios/d3va.htm

-d
0
 
LVL 16

Expert Comment

by:Kyle Schroeder
ID: 6480225
Oops...sorry about the DP.
-d
0
 
LVL 13

Expert Comment

by:magarity
ID: 6480226
"The FDD isnt faulty, it worked fine under Windows ME, and still works fine if I boot my machine using a boot disk and access the drive then."

Assuming this is correct, the initial focus should be on the software/operating system.  Is this Win2k installation up to date with all fixpacks and critical updates?
0
 
LVL 31

Expert Comment

by:rid
ID: 6480324
FDD also uses a DMA channel. Check for resources conflicts.
Regards
/RID
0
 
LVL 16

Expert Comment

by:Kyle Schroeder
ID: 6480739
Just a note for everyone...this board is a dual CPU Via based system....

darklight:
Are you using 2 CPUs on the board?  Have you installed the Via 4-in-1 drivers?  This shouldn't affect the floppy drive, but it does smooth out various other problems.  As rid said, check for hardware resource conflicts (Start/Run/WinMSD, click the Hardware section, then Hardware Resources, then Conflict/Sharing).

-d
0
 
LVL 16

Expert Comment

by:Kyle Schroeder
ID: 6480742
Try removing the sound card...I believe it uses an Aureal Vortex2 chipset, which has some problems in Win2K.  Also by default it uses to IRQs, one for standard Windows sounds, one for SB compatability (at least it does in Win98....).

-d
0
 
LVL 3

Expert Comment

by:Gothmog
ID: 6480949
What manafacturer does the fdd belong to?
0
 

Author Comment

by:darklight
ID: 6481244
Dogztar and Sysexpert: I would flash the bios but it requires me to put the update on a bootable diskette, which I cant do atm ;) I could just restart the computer and use a WinME boot disk, but then I couldnt access the NTFS partition's. Is there another way of doing this ?

WiZaRd: Yes I do have another FDD cable if you think that is the problem.

Sysexpert: I did check the compatibility list and everything is covered .. Im not running any printers/scanners etc off the machine, so there wasnt much to check.

Magarity: Yes, I got all the updates including service pack 2 for win2k not long after I installed it.

rid: Ive checked Start/Run/winmsd/Hardware Resources/Conflicts/Sharing and in the list doesnt show up with anything about the FDD

dogztar: Im only running the one Celeron in the machine at this point and no I havent installed the 4-in-1 drivers from VIA, should I, or is this only if I'm running 2 CPU's ? I also did discover the problem with my sound card under 2k, but it is apparently only on systems running a VIA chipset based mainboard (me ;P), There has been a fix posted which Ive applied and seems to have worked for now, so would the sound card still be to blame?

Gothmog: Panasonic *I Believe*, I bought it about 1 - 1.5 years ago.


My FDD is running on IRQ 6, and nothing else seems to be running on this IRQ.

There are 4 other IRQ's being shared though ..

IRQ 4: Com Port 1 + Com Port 3

IRQ 10: Microsoft ACPI-Compliant System + VIA Rev 5 or later USB Universal Host Controller

IRQ 16: nVidia Riva TNT2 Ultra Video Card + HPT370 Raid Controller (on board)

IRQ 18: Realtek RTL8139 Family PCI Fast Ethernet NIC + Vortex 2 Sound Card

In the DMA section of winmsd, it says my FDD is using channel 2

Regards,
DARK LiGHT
0
Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

 
LVL 63

Expert Comment

by:SysExpert
ID: 6481379
Get a bootable diskette from www.bootdisk.com.
Boot to WINME DOS mode and create the BIOS diskette. THen you can update your BIOS.

ALso I would get the VIA drivers.

I hope this helps !
0
 

Expert Comment

by:dacopel
ID: 6482843
is your fdd correctly identified in BIOS, presumably 3.5" 1.44.
Aslo check other bios settings to ensure FDD is enabled.

worth a try

Dacopel
0
 
LVL 4

Expert Comment

by:1175089
ID: 6483399
Are you checked your system for viruses ? (Esp boot sector viruses) ??? And are you apply SP2 for Win2k?
0
 

Author Comment

by:darklight
ID: 6484420
SysExpert: I have a winme bootdisk, but my HDD is formatted using NTFS, and winme doesnt recognise this, hence I have no way of getting to the file ive downloaded from within DOS

Also, where can I get the VIA update ?

Regards,
DARK LiGHT
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 6484850
2 choices.
1) Burn a bootable CD with the all the things needed for the BIOS update.

2) Have someone else do it for you.

Roxio software and Nero both make this very easy.

See Nero.com etc.

ootable CD
 Nero and Adaptec CD creator both allow making a bootable CD and having other info on it besides.
 The best thing to do is to use the win98 bootable diskette as the floppy image, and then put a copy   of the ghost DOS files and image on the CD .
   The CD will boot from the floppy image, give you access to the CD where the ghost and image are stored.
    I tried this recently and it worked beautifully.

 From: ne0         Date: Monday, November 20 2000 - 11:27AM EST

                     Bootable CD facts - http://www.ozemail.com/~rossstew/drs/bootcd.html 
                     BOOTISO - http://www.geocities.com/SiliconValley/Way/2996/readme.html 
                     Bootable CD - http://www.cdpage.com/Compact_Disc_Variations/eltoritoi.html 
Creating a Bootable CD - http://computing.net/windowsnt/wwwboard/forum/380.html 
                     Freeware ISO/Bootable CD Tools - http://www.goldenhawk.com/freeware.htm 
http://winxp.descrypt.com/cdboot.htm
                     How to make a Bootable CD - http://www.nikko.simplenet.com/goldentime/bootcd1b.htm 

I hope this helps !

0
 

Expert Comment

by:amp072397
ID: 6789356
darklight:

Just a friendly reminder to return to your open questions.

thanks!
amp
community support moderator

2/8
0
 
LVL 16

Expert Comment

by:Kyle Schroeder
ID: 6789468
darklight:

To use the WinME boot disk to flash your bios, just clear off all the extra junk from it (ebd.cab, etc) and the autoexec.bat and config.sys files.  You don't need them.  The only files that should be on the disk are io.sys, msdos.sys, command.com, and the files for the Epox BIOS update, probably a .exe and a .bin file.  For full instructions, see this page:
http://www.epox.com/html/english/support/motherboard/Get.asp?article=1302

Download the BIOS update from the links I posted above (http://www.epox.com/html/english/support/motherboard/bios/d3va.htm)

-dogztar
0
 
LVL 1

Expert Comment

by:Moondancer
ID: 6908243
ADMINISTRATION WILL BE CONTACTING YOU SHORTLY.  Moderators Computer101 or Netminder will return to finalize these if still open in seven days.  Please post closing recommendations before that time.

Question(s) below appears to have been abandoned. Your options are:
 
1. Accept a Comment As Answer (use the button next to the Expert's name).
2. Close the question if the information was not useful to you, but may help others. You must tell the participants why you wish to do this, and allow for Expert response.  This choice will include a refund to you, and will move this question to our PAQ (Previously Asked Question) database.  If you found information outside this question thread, please add it.
3. Ask Community Support to help split points between participating experts, or just comment here with details and we'll respond with the process.
4. Delete the question (if it has no potential value for others).
   --> Post comments for expert of your intention to delete and why
   --> You cannot delete a question with comments, special handling by a Moderator is required.

For special handling needs, please post a zero point question in the link below and include the URL (question QID/link) that it regards with details.
http://www.experts-exchange.com/jsp/qList.jsp?ta=commspt
 
Please click the Help Desk link on the left for Member Guidelines, Member Agreement and the Question/Answer process for further information, if needed.  http://www.experts-exchange.com/jsp/cmtyHelpDesk.jsp

Click you Member Profile to view your question history and keep them all current with updates as the collaboration effort continues, to track all your open and locked questions at this site.  If you are an EE Pro user, use the Power Search option to find them.  Anytime you have questions which are LOCKED with a Proposed Answer but does not serve your needs, please reject it and add comments as to why.  In addition, when you do grade the question, if the grade is less than an A, please add a comment as to why.  This helps all involved, as well as future persons who may access this item in the future to seek help.

To view your open questions, please click the following link(s) and keep them all current with updates.
http://www.experts-exchange.com/questions/Q.20264773.html
http://www.experts-exchange.com/questions/Q.20125324.html
http://www.experts-exchange.com/questions/Q.20161601.html
http://www.experts-exchange.com/questions/Q.20182417.html




PLEASE DO NOT AWARD THE POINTS TO ME.  
 
------------>  EXPERTS:  Please leave any comments regarding your closing recommendations if this item remains inactive another seven (7) days.  Also, if you are interested in the cleanup effort, please click this link http://www.experts-exchange.com/jsp/qManageQuestion.jsp?ta=commspt&qid=20274643

Moderators will finalize this question if still open in 7 days, by either moving this to the PAQ (Previously Asked Questions) at zero points, deleting it or awarding expert(s) when recommendations are made, or an independent determination can be made.  Expert input is always appreciated to determine the fair outcome.
 
Thank you everyone.
 
Moondancer
Moderator @ Experts Exchange
0
 
LVL 30

Expert Comment

by:VirusMinus
ID: 7894691

Dear questionner/expert(s)

No comment has been added lately, so it's time to clean up this TA.
I'll leave a recommendation in the Cleanup topic area that this question is to be:

 - Split between: Dogztar & SysExpert

Please leave any comments here within the next seven days.

==> PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER ! <==

VirusMinus
Cleanup volunteer
0
 
LVL 16

Expert Comment

by:Kyle Schroeder
ID: 7898750
Sounds good to me....
0
 
LVL 5

Expert Comment

by:Netminder
ID: 7961598
Per recommendation, force-accepted.

Netminder
EE Admin

SysExpert: points for you at http://www.experts-exchange.com/Hardware/Q_20516252.html
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Is it worth it to buy an Echo? In a word, yes! For me it was definitely worth it. I use mine on a daily basis. Prologue & Privacy At first, I was very skeptical about the Amazon Echo. In general, I don't like voice assistants. I don't li…
In this article we have discussed the manual scenarios to recover data from Windows 10 through some backup and recovery tools which are offered by it.
Many functions in Excel can make decisions. The most simple of these is the IF function: it returns a value depending on whether a condition you describe is true or false. Once you get the hang of using the IF function, you will find it easier to us…
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now