Solved

W2K Networking question

Posted on 2001-09-13
25
177 Views
Last Modified: 2010-04-14
I have 2 network cards (NICs):

NIC1: Cable modem plugged into this one (DHCP allocated address)

NIC2: Plugged into hub (Static IP address: 192.168.0.1)


My problem is this: Internet explorer defaults to using NIC2 and therefore is not connecting to the internet. If I DISABLE NIC2, IE works ok, and then I can enable NIC2 again.

What do I do to remedy this situation?




Windows 2000 IP Configuration

        Host Name . . . . . . . . . . . . : gateway500
        Primary DNS Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Hybrid
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Cable Modem:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : 3Com EtherLink XL PCI TPC NIC (3C900
B-TPC)
        Physical Address. . . . . . . . . : 00-10-5A-3C-21-53
        DHCP Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 62.31.227.115
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 62.31.227.1
        DHCP Server . . . . . . . . . . . : 195.188.52.62
        DNS Servers . . . . . . . . . . . : 195.188.52.62
                                            195.188.52.61
        Lease Obtained. . . . . . . . . . : 13 September 2001 12:08:22
        Lease Expires . . . . . . . . . . : 14 September 2001 12:08:22




Thanks for your help...
0
Comment
Question by:jhattingh
  • 10
  • 6
  • 3
  • +3
25 Comments
 
LVL 41

Expert Comment

by:stevenlewis
ID: 6480091
In IE go to tools, internet options, connections, lan settings, and check auto detect settings. Do you have ICS running on this box? if so go to tools, internet options, connections, shring and make sure the correct adapters are chosen to connect to the internet and the LAN
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 6480106
In addition, IF ICS is running, you may need to clean out the DNS IP of the internal NIC.

Routing should then take place properly.

I hope this helps !

0
 
LVL 1

Author Comment

by:jhattingh
ID: 6480139
What is ICS ?
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 6480175
inernet connection sharing
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 6480189
Yeah I can type LOL
ICS = internet connection sharing
0
 
LVL 1

Author Comment

by:jhattingh
ID: 6480202
Thanks ;)

I haven't got ICS enabled, but I *am* using WinGate to do the same job...
0
 
LVL 1

Author Comment

by:jhattingh
ID: 6480205
The thing is, it all works fine (including Wingate's ICS mechanism), just gets off to a bad *start*... :(
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 6480229
try unistalling/disableing wingate, and use ICS (it's built in to w2k)
0
 
LVL 1

Author Comment

by:jhattingh
ID: 6480306
I have tried it before, and found it difficult to set up.

Would my 2nd card become redundant if I used Win2K ICS?
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 6480363
NO, the one card connected to the cable modem should have it's ip info set to auto
the one connected to the LAN should be set to
ip 192.168.0.1
mask 255.255.255.0
gateway blank and disable dns and wins
the client NIC (the other machine(s))
ip 192.168.0.(2-254)
maks 255.255.255.0
gateway 192.168.0.1
enable dns and use 192.168.0.1
disable wins
on the host (the one connected to the cable modem)
go to Inernet explorer, tools, internet options, connections, sharing and s
make sure the correct NIC's are chosen as connect to internet and connect to LAN
0
 
LVL 1

Author Comment

by:jhattingh
ID: 6480424
Thanks for all the input, Steven,

One question before I start attempting that: I don't see sharing anywhere in the IE options - does this only appear when ICS is enabled?
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 6480461
Yes it does, you have to enable ICS before the button shows
see here
http://www.microsoft.com/windows2000/en/server/help/howto_share_conn.htm
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 12

Expert Comment

by:Housenet
ID: 6480939
Have you tried chaning the binding order for the NICS ?
-Click on Advanced-> advanced settings in properties of network places & reverse the binding order.
0
 
LVL 1

Expert Comment

by:ismart
ID: 6482745
Please could you open a DOS window and type ROUTE PRINT. This will print out your routing table. It sounds like that your machine is pushing all traffic to NIC 2 so it needs to be told that all traffic for Internet addresses should go to NIC 1.

You can change this using the ROUTE ADD command. If you post the results of the ROUTE PRINT then we can work out the correct routing you need for Internet access.
0
 
LVL 1

Author Comment

by:jhattingh
ID: 6483036
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x1000003 ...00 04 5a 49 ef f4 ...... Linksys LNE100TX Fast Ethernet Adapter(LNE
100TX v4) NDIS5 Driver
0x1000004 ...00 10 5a 3c 21 53 ...... 3Com EtherLink PCI
===========================================================================
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0      62.31.227.1   62.31.227.115       1
          0.0.0.0          0.0.0.0      192.168.0.1     192.168.0.1       1
      62.31.227.0    255.255.255.0    62.31.227.115   62.31.227.115       1
    62.31.227.115  255.255.255.255        127.0.0.1       127.0.0.1       1
   62.255.255.255  255.255.255.255    62.31.227.115   62.31.227.115       1
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
      192.168.0.0    255.255.255.0      192.168.0.1     192.168.0.1       1
      192.168.0.1  255.255.255.255        127.0.0.1       127.0.0.1       1
    192.168.0.255  255.255.255.255      192.168.0.1     192.168.0.1       1
        224.0.0.0        224.0.0.0    62.31.227.115   62.31.227.115       1
        224.0.0.0        224.0.0.0      192.168.0.1     192.168.0.1       1
  255.255.255.255  255.255.255.255      192.168.0.1     192.168.0.1       1
Default Gateway:       192.168.0.1
===========================================================================
Persistent Routes:
  None



I hope it is legible... ;)
0
 
LVL 1

Expert Comment

by:ismart
ID: 6483086
Try the following

route delete 0.0.0.0

then

route add 0.0.0.0 mask 0.0.0.0 62.31.227.1 62.31.227.115

then try and access the internet.
0
 
LVL 1

Author Comment

by:jhattingh
ID: 6483274
Thanks for the help:


I got:

D:\>route add 0.0.0.0 mask 0.0.0.0 62.31.227.1 62.31.227.115
route: bad argument 62.31.227.115
0
 
LVL 1

Author Comment

by:jhattingh
ID: 6483279
Could you explain what this means...? It would be great if I could understand it! I am not totally PC illiterate - being a C++ programmer, so don't be too daunted by the task!
0
 
LVL 14

Expert Comment

by:AvonWyss
ID: 6485951
The solution is simple: remove the default route from the LAN adapter (in the properties of the atapter). The default route specifies where "unknown" traffic is to be routed, and therefore it must only be routed to the internat but not your LAN (the LAN are all known addresses).
0
 
LVL 1

Author Comment

by:jhattingh
ID: 6486041
That makes sense - thanks for explaining it.

Could you tell me if this is how it should look?



===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0      62.31.227.1   62.31.227.115       1
      62.31.227.0    255.255.255.0    62.31.227.115   62.31.227.115       1
    62.31.227.115  255.255.255.255        127.0.0.1       127.0.0.1       1
   62.255.255.255  255.255.255.255    62.31.227.115   62.31.227.115       1
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
        224.0.0.0        224.0.0.0    62.31.227.115   62.31.227.115       1
  255.255.255.255  255.255.255.255    62.31.227.115   62.31.227.115       1
Default Gateway:       62.31.227.1
===========================================================================
0
 
LVL 14

Accepted Solution

by:
AvonWyss earned 100 total points
ID: 6486171
This looks as if you completely disabled the internal adapter. This was not what I intended to say (because liekt this you cannot use your LAN anymore), just remove the default gateway from the TCP/IP-properties of the adapter:
Enable the LAN adapter again, open its properties, click on TCP/IP protocol and open its properties, go to "Advanced..." on the bottom and make sure that there are no entries in the "Default gateway" list. Confirm all settings with OK, and you should get something like (this is my table, yours will differ with the addresses):

Aktive Routen:
     Netzwerkziel    Netzwerkmaske          Gateway   Schnittstelle  Anzahl
          0.0.0.0          0.0.0.0    217.162.128.1  217.162.128.150      1
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
      192.168.1.0    255.255.255.0      192.168.1.1     192.168.1.1       1
    192.168.1.255  255.255.255.255      192.168.1.1     192.168.1.1       1
217.162.128.150      1
    195.141.85.72  255.255.255.255    217.162.128.1  217.162.128.150      1
    217.162.128.0    255.255.252.0  217.162.128.150  217.162.128.150      1
  217.162.128.150  255.255.255.255        127.0.0.1       127.0.0.1       10
  217.162.128.255  255.255.255.255  217.162.128.150  217.162.128.150      1
        224.0.0.0        224.0.0.0      192.168.1.1     192.168.1.1       1
        224.0.0.0        224.0.0.0  217.162.128.150  217.162.128.150      1
Standardgateway:     217.162.128.1

192.168.1.x is the LAN (Local Area Network)
217.162.128.150 is the WAN gateway (wide area network)
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 6489067
jhattingh  :
FYI : I mentioed the DNS problem way at the beginning.

From: SysExpert
                                                            Date: 09/13/2001 08:59AM PST
               In addition, IF ICS is running, you may need to clean out the DNS IP of the internal NIC.

               Routing should then take place properly.

               I hope this helps !

 
0
 
LVL 14

Expert Comment

by:AvonWyss
ID: 6489395
SysExpert, it was not about DNS but about default routes?
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 6491966
That's what I said :

In addition, IF ICS is running, you may need to clean out the DNS IP of the internal  NIC.

<<<   Routing should then take place properly.  >>>>
;-)
0
 
LVL 1

Author Comment

by:jhattingh
ID: 6491975
I think what AvonWyss meant was that simply cleaning out the DNS IP wasn't the solution, even to the routing, since the solution has been to manually delete a route and then add a better one in it's place...

Maybe I'm misreading you folks.


I sure am grateful for all the time put into the question.

Thanks all, it's working great...
0

Featured Post

Complete Microsoft Windows PC® & Mac Backup

Backup and recovery solutions to protect all your PCs & Mac– on-premises or in remote locations. Acronis backs up entire PC or Mac with patented reliable disk imaging technology and you will be able to restore workstations to a new, dissimilar hardware in minutes.

Join & Write a Comment

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
Performance in games development is paramount: every microsecond counts to be able to do everything in less than 33ms (aiming at 16ms). C# foreach statement is one of the worst performance killers, and here I explain why.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now